Modding Discussion A place to discuss map editing and other related stuff

Discussion in 'Mods' started by QuantumConcious, Apr 1, 2016.

  1. Allayna

    Allayna Pangalactic Porcupine

    possibly! you might try just using Content Patcher and this mod and see what happens... If that still doesn't work, i could take a look at your edited file?
    • vickimed

      vickimed Aquatic Astronaut

      I deleted, and did a clean install of the mod, then planted seeds. Forwarding one day, they appeared to have grown. I'm going to guess it was a glitch in the first installation that was the problem (namely the person sitting at the keyboard as a best guess). Thank you for testing for me! You're a rock star!
      • mominthevalley

        mominthevalley Void-Bound Voyager

        Don't know if anyone is around. I have some questions, but I'll start with the first one. Back story first. In the past I made a map replacement of the beach for my husband that made it so the new beach is longer and you could walk on the most shallow portion of the water. I'm trying to remake a map patch using TMX with the same features because I want it to be less breakable as well as more compatible with SVE.

        My first question is, in a map patch do you need to still include the warps from the original map even though the patched area doesn't include those warps?

        I'll add other questions as I go. My mind is kind of wandering as I work on it so I forgot my other questions but I'm sure if they're important they'll come back to me.

        Edit: When adding a warp to a map patch, do you base the coords on the size of the patch or the entire map which it patches?

        If you are extending a map's size, how do you go about writing it in the tmx's json? (will be looking at other people's maps to see how they did it)

        My patch seems to be working, but the viewport stops before the end of the part I added. Is there a way to get it to go further?
          Last edited: Jan 1, 2020
        • Tanpoponoko

          Tanpoponoko Big Damn Hero

          Would be so grateful if anyone could help me answer this.... (I'm trying to become better at coding/map editing, I swear, but I struggle)

          I'm trying to figure out how to do the day/night tiles o edit maps. One of the things needed to do that, according to the wiki here, is the "Tilesheet Index" number. How on earth do I find out what that number is? I'm trying to draw from a new tilesheet, not an existing one. I'm using Tiled to edit.

          Thank you for reading!
          • Moragaine

            Moragaine Existential Complex

            Each 16x16 square on a tilesheet is referred to by a number: starting at 0 with the upper left-hand corner of that tilesheet - that's the index number. If you mouse-over or high-light a square on map in Tiled, it shows you the x/y position of that square within the map and (in parenthesis) the position number of that tile on it's parent sheet. In that example, you're telling the game where (x/y position) you want a certain tile(s) from a tilesheet - #256, which is part of a glowy daytime window (288 is the bottom half).
              Tanpoponoko likes this.
            • Tanpoponoko

              Tanpoponoko Big Damn Hero

              Thank you so much!!


              So I tried this method and I got crashes every time. I tried using the tile index from the original tilesheet I wanted and no luck. I tried adding the new tiles to the 'town' sprite sheet, since that's where the other day/night tiles are on the working map, crashes again. I'm totally pulling out my hair trying to figure out what's not working.

              I also tried on content patcher, using a method like this:

              "MapProperties": {
              "DayTiles": "Buildings 62 13 2432 Buildings 63 13 2433 Buildings 65 13 2435
              Buildings 66 13 2436 Buildings 62 14 2464 Buildings 63 14 2465 Buildings 65 14 2467 Buildings 66 14 2468",
              "NightTiles": "Buildings 62 13 2336 Buildings 63 13 2336 Buildings 65 13 2339
              Buildings 66 13 2340 Buildings 62 14 2368 Buildings 63 14 2369 Buildings 65 14 2371 Buildings 66 14 2372",

              This was my log with the failed Tiled edit.

              Here is the map
              I'm trying to edit. The town sheet is what I was trying to draw from on the 2nd attempt, correct numbers written in the day/night on the map in Tiled. Spring extras is what I originally tried to draw from, number do no match currently.

              Would appreciate any help if anyone is willing to give it. I'm essentially just trying to get the windows of the house to light up at night haha T^T I suuuuck.

                Attached Files:

                Last edited: Jan 20, 2020
              • stardewforever

                stardewforever Void-Bound Voyager

                I learned after a great while and finding a forum post that saving a map edit in tiled makes the map barf and goes corrupt if you save via using the pull down File > Save or pull down File > Save As.

                On my version the only way I can get it to save properly is to make my map edits then close the map via force closing the tiled window (clicking the upper right window "X") and when the prompt "there are unsaved changes do you want to save" appears and you confirm "Yes" then it saves properly. Dunno if this is your issue or not and sorry if it doesn't fix your problem but maybe give that a try.
                • Squiver

                  Squiver Scruffy Nerf-Herder

                  Hey so this is probably a really newbie question and maybe it's just because it's 4am and I've got a headcold that I can't figure it out via Google, but I'm trying to make a custom map for the first time ever using Tiled, and I'm trying to edit the tile properties of grass so as to make them diggable, but the entire "properties" tab is greyed out and not able to be edited. Is there something special I need to do? Is this possible in this program?

                  Thank you so much in advance!

                  Edit: I finally found the little tab underneath the tilesets that lets me edit the properties, I used the "+" to manually add the property "diggable" with the variable "T" as I've seen in other maps with diggable grass, but when loading up the map, it didn't seem to have worked.

                  Second edit: I started again with a fresh map and it seems to have worked now. I'm not sure why or what I did differently, but I am just glad it's working!
                    Last edited: Feb 3, 2020
                  • carodactyl

                    carodactyl Void-Bound Voyager

                    Hi friends! Trying to mod the spouse rooms right now and having trouble adding working window tiles that light up in the day and go dark at night. I'm using the Tiled and adding the DayTiles object property and (as far as I know) properly adding the reference tilesheet's values to add lit up windows, but it isn't working in game. I can't really find any proper tutorials on how to add a window, so I'm not 100% sure I'm actually doing this right? Any suggestions?
                    • Ellyssa

                      Ellyssa Subatomic Cosmonaut

                      Trying to get back into some basic map editing and I'm getting an error. I know it's from the edit I made but not really sure what I did wrong, did the same things I used to do, but I'm guessing I've forgotten something along the way.

                      All I did with my edited map was increase each layer, add a small room and two floor ladder tiles with Action Warp properties to each other.

                      Error log:
                      • Moragaine

                        Moragaine Existential Complex

                        @carodactyl Take a look Karmylla's Spouse room edits, I believe she does that.

                        @Ellyssa What map are you trying to edit?
                        • Ellyssa

                          Ellyssa Subatomic Cosmonaut

                        • Moragaine

                          Moragaine Existential Complex

                          If you're using the target 'Maps/Mines', try using 'Content/Maps/Mines' instead.
                          • Squiver

                            Squiver Scruffy Nerf-Herder

                            While editing a version of a map in Tiled I somehow somewhere accidentally deleted the tiledata for the entrance to the greenhouse. Other than just starting over from a backup, is there a way to recover that?
                            • Moragaine

                              Moragaine Existential Complex

                              Open an unedited version of the map and copy the tiledata to your edited one.
                              • carodactyl

                                carodactyl Void-Bound Voyager

                                I opened her .tbin maps in Tiled and tIDE and don't see any Tile Data that would change the windows at night, but somehow it works in game. I have no idea how she made it work. :( Was hoping someone knew steps to take
                                • QuantumLeek

                                  QuantumLeek Void-Bound Voyager

                                  Hey, I've got a question about the friendship requirements for entering rooms. I want to add a bedroom to the Wizard's tower, which functions like every other bedroom in the game and I'm not certain how to do that. I note that the door tile for, say, Marnie's room has the property "Door Marnie", but if I do the same thing in the Wizard's tower map (except adding the tile property "Door Wizard" it doesn't work, but instead results in a semi-transparent door that can't be interacted with. What am I doing wrong? Does the tile property "Door Wizard" have to be defined somewhere?
                                  • blossomjuice

                                    blossomjuice Intergalactic Tourist

                                    I’m not sure if this is the correct thread or not, but here it goes...

                                    Would anyone be able (and willing) to go into these map folders and remove/fix the two bugged plants that appear in both (there’s already an example of the bugs posted on Nexus, it’s the very first comment, plus the second you load the maps you’ll see it for yourself). I’ve tried everything that I know how to do, but when it comes to map editing, I’m completely lost.


                                    Halp? :cry:
                                    • tiffy961

                                      tiffy961 Scruffy Nerf-Herder

                                      Hi, could you please check if this fixes it?
                                      I don't use Content Patcher so I can't check.

                                      • blossomjuice

                                        blossomjuice Intergalactic Tourist

                                      Share This Page