1. This forum is archived for reference. For support & bug reports visit the help section of forums.stardewvalley.net

Bug/Issue Bug: Accidental fishing rod cast in doorway put game into deadlock

Discussion in 'Support' started by Telkir, Feb 27, 2016.

  1. Telkir

    Telkir Scruffy Nerf-Herder

    First of all, fantastic work on the game! Overall it's a really polished and incredibly charming experience and was every bit worth the wait. I'm not even through my first Spring yet but I can see that there are going to be a lot of fun things to do. :)

    A bug I found just now which is fishing-related: After getting a mail from Willy to tell me he had a new fishing rod in stock, I visited him and purchased it. Went outside and fished a few things to test it out, then went to go back into his fishing hut to sell.

    As I faced the door, I misclicked and hit LMB instead of RMB. This made a very weak cast with the fishing rod. At the end of the animation I expected it would fail and I'd be able to use the door, so I was clicking RMB a couple of times while waiting. Instead, my character was locked in place holding their fishing rod as if the bobber was floating somewhere inside the graphic of Willy's hut. Mouse movement worked and the cursor changed to the hand icon when over the door, but couldn't do anything with the keyboard except Alt+F4. Waited a while but there was no possibility of catching anything to get back to normal - game had gone into a sort of deadlock.

    No big deal thanks to the daily autosave fortunately but still, one to fix when you get chance!

    Summary: Accidentally cast fishing rod into Willy's shack at the door while trying to enter (LMB instead of RMB ) and the game became unresponsive.
    • KKGB

      KKGB Space Penguin Leader

      Also got this, accidentally cast a fishing rod in Willy's shack, not sure where the bobber went but I dont think it went to the door. Now my character's frozen
      • Ordona

        Ordona Former Staff

        I had the same thing when casting upwards into the river on the bridge you repair next to Elliott's hut on the beach (standing one tile off-center to the right). Rod (bamboo) is out, bobber missing, character standing, and time still passes as usual.

        Waited until 4am to be sent home at the cost of 700g, but kept my items and everything worked again after that, so that's an option if you don't want to lose anything aside from the cost to be sent home and some time.
          Last edited: Feb 29, 2016
        • jibas

          jibas Space Hobo

          I had something similar happen while fishing, if you look at the picture I aimed at the red X and it got me stuck halfway in the fishing animation.

          • CassetteApe

            CassetteApe Master Chief

            Something very similar happened to me. I went fishing behind Willy's shack and cast the rod at maximum strength, the bobber fell just to the right of Willy's shack and I got stuck, couldn't move at all, not even open the menu or inventory which made me resort to restarting the game.

            Here's an image of the bug:
            • M.Car

              M.Car Space Penguin Leader

              Same thing happened to me, except it was stuck in Sam's head.

              Share This Page