RELEASED Chest Label System

Allow you to name your chests!

  1. jlee100

    jlee100 Void-Bound Voyager

    Attached the source. :)

    The one that was causing problem when naming animals/child was this
    Code:
    if(lastMenu == null || Game1.activeClickableMenu == null || lastMenu != Game1.activeClickableMenu)
    {
    Game1.keyboardDispatcher.Subscriber = null;
    }

    "if(lastMenu == null || Game1.activeClickableMenu == null || lastMenu != Game1.activeClickableMenu)" is equal to true when naming animals/child so I either have to change the if statement or remove the "Game1.keyboardDispatcher.Subscriber" in order to fix the problem.

    For the chest label out of place when zoomed out, I just use another method that was available in the API.
     

      Attached Files:

      Milly Rainbowskittlez likes this.
    • OrSpeeder

      OrSpeeder Phantasmal Quasar

      Yep, I was suspecting it was taht line about the dispatcher.

      I... totally forgot to check if I am fucking up someone else dispatcher :p OOoops.
       
      • OrSpeeder

        OrSpeeder Phantasmal Quasar

        Just noticed all my copyright notices are wrong too... (they all say that "Storm is free software bla bla bla")
         
        • jlee100

          jlee100 Void-Bound Voyager

          Lol Oh yeah forgot to mention that to you xD
           
            Dikong227 and Superior_s like this.
          • Randonx

            Randonx Scruffy Nerf-Herder

            jlee, see anything that would be causing the chest renaming window to overlap the chest inventory window, instead of being above it?

            Also, I don't know what this relates to... My chest tooltips only work if I aim at the bottom 15% of the chest, or underneath it. If I aim my mouse anywhere else on the chest it's not visible, even though the hand that lets me interact with the chest is still there.

            Great work both of you.
             
            • Eldrants

              Eldrants Seal Broken

              err it work but i guess it doesn't support zoom
               
              • jlee100

                jlee100 Void-Bound Voyager

                I've look into it and found out the cause. Its our screen resolution. Screen resolution is your default 100% zoom and the problem is we have different screen resolutions.

                Anyway can you give me some screenshots so I can confirm this and find a proper fix.

                Screenshot please :)
                 
                • remix1014

                  remix1014 Aquatic Astronaut

                  Found a bug.

                  I'm not sure if you have fixed this in your latest version or not.

                  If you have a child, there is a prompt where you can name your child.
                  If you have the mod active, you can't select the text input box for the name of your child. Due to this, you have to shut down the game and restart your day with the mod off in order to proceed.
                   
                  • Eldrants

                    Eldrants Seal Broken

                    what i mean is graphical problems like double arrows and wrong placement.
                    svs1.PNG svs2.PNG
                     
                    • jlee100

                      jlee100 Void-Bound Voyager

                      RaulMarq likes this.
                    • Eldrants

                      Eldrants Seal Broken

                    • Milly Rainbowskittlez

                      Milly Rainbowskittlez Cosmic Narwhal

                      whats your screen resolution, i might be able to test this later tonight.
                       
                      • Eldrants

                        Eldrants Seal Broken

                        mine is 1920x1080
                         
                          Milly Rainbowskittlez likes this.
                        • OrSpeeder

                          OrSpeeder Phantasmal Quasar

                          thanks people that were trying to maintain the mod while I couldn't fix it.

                          I updated it, it should all work now, including in 1920x1080 :)

                          But please, if you spot more bugs, tell me! I maybe made a mistake somewhere, had to change code massively for it to work as I want.
                           
                          • BananaBubble

                            BananaBubble Void-Bound Voyager

                            Is it compatible with SMAPI 0.39.2?
                             
                            • OrSpeeder

                              OrSpeeder Phantasmal Quasar

                              Nope.

                              And I didn't even finished updating my mods to 38.6 that is on the SMAPI main thread... I decided now that I will for now work on that (updating to 38.6) and ignore "cutting edge" SMAPI.

                              People that are updating to Alpha versions are doing at their own peril.
                               
                                Superior_s likes this.
                              • BananaBubble

                                BananaBubble Void-Bound Voyager

                                For now, I'm gonna stick with 38.6.

                                I just wanted to know because I've seen many mods been updated to be compatible with 39.1 & 39.2.

                                Thanks.
                                 
                                • Hazerofdoom

                                  Hazerofdoom Scruffy Nerf-Herder

                                  This post shows how to make 0.37 SMAPI mods compatible with 0.39.
                                  All it really is - is moving the mod files into a folder of their own and adding a manifest.json.
                                  The post explains how to do it.
                                  Though I'm not sure if this mod is for 0.37 (I think it is?) but it's worth a try if you're using 0.39 and want to try and use any of the SMAPI mods you're using for 0.37 with 0.39!
                                   
                                    BananaBubble and Superior_s like this.
                                  • cantorsdust

                                    cantorsdust Phantasmal Quasar

                                    Yeah, just FYI if you delete the version line from manifest.json it works just fine. Just open it in Notepad etc and delete that one line.
                                     
                                      BananaBubble and Superior_s like this.
                                    • Jadzi

                                      Jadzi Void-Bound Voyager

                                      I just switched (back) to Smapi and this mod looks perfect for my organizational needs :) However, I too am using smapi 39.2 atm. I think many people would be, if they are wanting to use any of Zoryn's mods (fishing, durable fences, etc).

                                      So does this process work? I'm a bit nervous about trying it, but will if I have to :D
                                       

                                      Share This Page