1. Please be advised of a few specific rules and guidelines for this section.

RELEASED Draconis- The race of humanoid dragons 1.4

A mod that adds a race of playable half-dragons.

  1. Notameme

    Notameme Title Not Found

    Notameme submitted a new mod:

    Humanoid dragon race - A mod that adds a race of playable half-dragons.

    Read more about this mod...
     
  2. SiFiGeek36

    SiFiGeek36 Scruffy Nerf-Herder

    I would love to take a look at this mod... Just wondering if you have any screenshots of the race itself, it kind of boast trust between the mod downloader and the modder
     
  3. floranman111

    floranman111 Void-Bound Voyager

    Draco? (Monster musume?)
     
  4. Xylia

    Xylia Tiy's Beard

    Hmm, this has promise. I'll have to keep an eye on this. I usually prefer wings on the back, but this is an idea you don't see all that often for dragon hybrids, so it is still interesting.

    There's a few screenshots on the overview page now.
     
  5. Mooncalf99

    Mooncalf99 Ketchup Robot

    There's no craftable flag, and when I turned on admin mode, the game crashed. I'm putting this mod on wait until you've worked out the kinks.
     
  6. Xylia

    Xylia Tiy's Beard

    While I'm not the author, logfiles or at least the error message itself helps. If the game crashed when going into /admin that means there's something wrong with one of the crafting recipes (maybe the flag itself!) and the error log would be useful in trying to track it down and/or you could even edit it yourself for a temp fix if you know how (or one of us can tell you how).

    Just a suggestion.
     
  7. Mooncalf99

    Mooncalf99 Ketchup Robot

    Oh, right, that would've been helpful. I'll try to recreate the situation... and this time it crashed to desktop instead of crashing to start menu. Huh.

    Checking the logfile, this line seems to tell the story:

    [02:30:11.298] [Error] Application: exception thrown, shutting down: (ItemException) No such item 'flagsktest'

    Sadly, I'm still learning how the code works, so I don't quite know how to correct this myself. Any ideas?
     
  8. Xylia

    Xylia Tiy's Beard

    Uh, most likely you'd have to open player.config.patch within this mod, and look for the line that contains "flagsktest" and replace that with one of the other race's flags temporarily. Not sure what they are called. Or just remove that line altogether (though this means, no flags).
     
  9. Mooncalf99

    Mooncalf99 Ketchup Robot

    No, that doesn't work because that file contains no such reference. I ran a grep for the line, and found that "flagdragon.recipe" did contain that item as a product, but there is no item file for it - just files for the object. Easily fixed by making it create a human flag for now.

    Mod author Notameme: Please add proper item files at some point, thanks.
     
  10. Xylia

    Xylia Tiy's Beard

    Weird... because usually you would add a racial flag by adding it to player config... is there a "flagdragon" in player.config.patch? I haven't downloaded the mod yet (I'm a bit too busy lately lol).

    EDIT: I found the problem.

    In flagdragon.recipe, change "flagsktest" to "flagdragon" and it should work fine, AND give you the flag that was really meant to be there.

    A newbie mistake, the author at some point had the flag named "flagsktest" and then decided to change the name of it to "flagdragon" but forgot one of the instances. I've done that different times myself in coding lol. It's a very easy omission to do.

    Basically what's happening, is flagdragon.recipe is telling the game to output a "flagsktest" and the game looks for flagsktest, and doesn't find one, and then kicks you to the titlescreen with an error. That's because the actual object is called flagdragon.object. (You COULD also rename all instances of flagdragon to flagsktest and it would also work but that's far more work).
     
  11. Notameme

    Notameme Title Not Found


    Thanks guys, I'm currently fixing these bugs. I couldn't figure out what was causing it, so thank you very much.
     
  12. Xylia

    Xylia Tiy's Beard

    np. If I weren't so busy I'd be glad to playtest things by loading up your mod... perhaps when my current project is closer to being done, I'll see if there's anything else I can help with.

    Tho just a caveat -- I'm a bit of a newbie as far as mods and JSON goes myself. I know the basics... and I usually am decent at deducing a problem... but I'm no pro.
     
  13. Notameme

    Notameme Title Not Found

  14. YakkinoAyo

    YakkinoAyo Void-Bound Voyager

    Are you planning to make a Workshop Version of this?
    that will be awesome!
     
  15. Notameme

    Notameme Title Not Found

    I hope so. First I should fix and add a couple of things to this mod.
     
  16. Xylia

    Xylia Tiy's Beard

    I think it would be best to wait until the mod is more feature-complete and relatively bug free before putting it on the workshop, IMO.

    But that's just my opinion lol.
     
  17. Nomad_Bal

    Nomad_Bal Void-Bound Voyager

    Oh my, this race is awesome!
    I literally can't wait to see it on the workshop.
    If you upload it and convince sayter to make a compatibility patch for FUraces I promise I will create at least 100 accounts to upvote your mod.
     
  18. Notameme

    Notameme Title Not Found

    Notameme updated Humanoid dragon race with a new update entry:

    Now with some Frackin Races support

    Read the rest of this update entry...
     
  19. Mooncalf99

    Mooncalf99 Ketchup Robot

    Can't find the new crafting station. How do you make it? Inventor's table, barehanded crafting menu?

    Also, racial clothes can't be crafted. They don't appear on the spinning-wheel crafting menu despite recipes existing. When I turned on admin mode to see if they were just locked, well... crash to menu, with the following message:
    upload_2017-2-20_5-2-55.png
    It appears to be basically the same issue as you had with the flag.

    Still enjoying this well enough. What racial abilities are you including, I wonder? Hope it's something cool. :)
     
  20. Sarduka

    Sarduka Scruffy Nerf-Herder

    I really like the mod and hope you keep up the good work, buuut...
    after I upgraded my ship from t2 to t3:
    [Error] UniverseServer: exception caught: (ObjectException) No such object named 'bigboosterflameDragon'

    Now I stuck with that char in the loadingscreen.
    Do I'm the only one with that problem?
     

Share This Page