Modding Help EoF error, cannot determine problem.

Discussion in 'Starbound Modding' started by BugsyBro, Jul 9, 2017.

  1. BugsyBro

    BugsyBro Void-Bound Voyager

    Currently me and a friend are using this modpack on the steam workshop that I have made.

    however he is having a constant issue where he will be disconnected with the following error:

    [Error] Exception caught in client main-loop
    (EofException) Failed to read full buffer in readFull, eof reached.

    When I look at the logs for the reason for his disconnect it has a blank space:

    [Info] UniverseServer: Client 'Jeff' <2> (local) disconnected for reason:
    [Info] Chat: <server> Player 'Jeff' disconnected

    We have tried both reinstalling the mods as well as the game itself, he has tried new characters and it seems to be when he is loading the world even if I have already loaded it, help would be greatly appreciated. It does say we have mismatches and thus he cannot connect via IP unless we allow it although im not sure how to fix that since we have the exact same install. If anyone knows any mod incompatibilities just by glancing at the modpack please let me know.[​IMG]
  2. projectmayhem

    projectmayhem Spaceman Spiff

    The mismatch things confuses me also. Me and my wife have the same install and same mods and it tells us the same thing as well.
  3. lazarus78

    lazarus78 The Waste of Time

    Probably a bad update in one of the mods. There is literally nothing anyone here can do.

    Though the error mentioning buffer and a read error also lead me to think it could be maxing out memory.
  4. Dakrhunter30

    Dakrhunter30 Scruffy Nerf-Herder

    I suspect this error appears when the game encounters a problem with loading the world.

    I had the same problem and solved it by deleting the newest planet save in the starbound/storage/universe folder.

Share This Page