1. This forum is archived for reference. For support & bug reports visit the help section of forums.stardewvalley.net

Bug/Issue Game isn't launching

Discussion in 'Support' started by BluezFilms, Oct 5, 2016.

  1. BluezFilms

    BluezFilms Void-Bound Voyager

    Hi all,
    Here's the situation. I believe it was after the Windows 10 Anniversary Update when the game stopped launching (Although after updating to Windows 10 I've stopped playing to wait for the 1.1 update). When I click on 'Play' in Steam, it starts running for about 5 seconds (at this point nothing appears) and then stopped running.

    Here's something to consider might be the cause. This is something I changed as well before the Windows 10 Anniversary Update. Due to the update and according to some research, Microsoft updated their DirectX 9 (something in there was updated at least). Some of my games running with DirectX 9 started stuttering like a slideshow. A solution to fix that was to download the old DirectX 9 file and replace the new one.

    PC Specifications:
    Windows 10 64-bit
    Processor: Intel(R) Core(TM) i7-3770 CPU 3.40GHz
    RAM: 8GB
    Graphics Card: Nvidia GTX 960 2GB (Updated the driver a day ago)

    Though, I can confirm that when I was still in Windows 8.1 my game runs perfectly fine. I even got married in game.

    Here's the error log:
    Message: The screen device name must be a non-empty, non-null string.
    Stack Trace: at Microsoft.Xna.Framework.WindowsGameWindow.ScreenFromDeviceName(String screenDeviceName)
    at Microsoft.Xna.Framework.WindowsGameForm.ResizeWindow(String screenDeviceName, Int32 clientWidth, Int32 clientHeight, Boolean center)
    at Microsoft.Xna.Framework.WindowsGameForm.EndScreenDeviceChange(String screenDeviceName, Int32 clientWidth, Int32 clientHeight)
    at Microsoft.Xna.Framework.WindowsGameWindow.EndScreenDeviceChange(String screenDeviceName, Int32 clientWidth, Int32 clientHeight)
    at Microsoft.Xna.Framework.GraphicsDeviceManager.ChangeDevice(Boolean forceCreate)
    at Microsoft.Xna.Framework.GraphicsDeviceManager.Microsoft.Xna.Framework.IGraphicsDeviceManager.CreateDevice()
    at Microsoft.Xna.Framework.Game.RunGame(Boolean useBlockingRun)
    at StardewValley.Program.Main(String[] args)

    Any ideas what is going on? Could it be the fact that the game's having trouble recognizing my dual screen (but only launch on one) setup? Blocked by some programs? I can only guess it's having some trouble creating the game window. Otherwise I'm not sure what the error log is saying.

    I've tried most of the solutions I could find online. Any help would be appreciated :)
    • Lokorfi

      Lokorfi Big Damn Hero

      I'm also having this problem. I'm hoping that there's a solution to be found here.
      • BluezFilms

        BluezFilms Void-Bound Voyager

        Bump. anyone?
        • BluezFilms

          BluezFilms Void-Bound Voyager

          Finally! I found the solution to this problem!

          It seems that some of my system files are corrupted. I fixed it by running "/sfc scannow" without the quotes in CMD (Run as Administrator).
          Hopefully your game can run after trying this fix :)
          • bignosepig

            bignosepig Starship Captain

            Seems legit, but if even that's not working you cant always delete it then install it, you will still have the game, just remember to back up your save located in C:\Users\(Insert User)\AppData\Roaming\StardewValley\Saves if your going to do it
            • bluebamboo

              bluebamboo Space Hobo

              Thanks! Things are working for me now. But it was "sfc /scannow" for me.
              • bignosepig

                bignosepig Starship Captain

                That's great!

                Share This Page