Modding Help Game starts fine but once started screen is black

Discussion in 'Mods' started by sexisquidward, Oct 15, 2016.

  1. sexisquidward

    sexisquidward Aquatic Astronaut

    I've run SMAPI before some time ago and started the game up again after the new update. I reinstalled SMAPI and 3 mods with the updates and now when I try to run the game, it starts fine with the menu screen but after it opens the save file the screen goes black. I can hear the game and once I navigate in darkness to the front door, the game exits abruptly. Has anyone else had this dilemma?
     
    • Borodin

      Borodin Master Astronaut

      Can you post your log?
       
      • sexisquidward

        sexisquidward Aquatic Astronaut

        I would if I understood what that meant. How do I do this?

        I'm sure this is useless but here's my system specs

        Processor
        Intel(R) Core(TM) i5-2320 CPU @ 3.00GHz

        Video Card
        AMD Radeon R9 200 Series

        Video Card #2
        Intel(R) HD Graphics

        RAM
        16 GB

        Operating System
        Microsoft Windows 10 (build 10586), 64-bit
         
        • VIspReaderUS

          VIspReaderUS Void-Bound Voyager

          :rofl:... Win+r>%appdata%/roaming/stardewvalley/logs
           
          • foghorn

            foghorn Pangalactic Porcupine

          • VIspReaderUS

            VIspReaderUS Void-Bound Voyager

            yeah,^that.im not on my computer
             
              foghorn likes this.
            • sexisquidward

              sexisquidward Aquatic Astronaut

              Found it!
               

                Attached Files:

              • Entoarox

                Entoarox Oxygen Tank

                You are using a old version of the sprinkler mod, you need to update, a patched version can be found in the misc mods section in the "Ento Home of abandoned mods" topic.
                 
                • sexisquidward

                  sexisquidward Aquatic Astronaut

                  Ok, so I found that and downloaded it and the same error still seems to be happening.
                   

                    Attached Files:

                  • Entoarox

                    Entoarox Oxygen Tank

                    You still have the old version in the `2-SMAPISprinklerMod` folder, as long as it remains in the Mods folder the mod will be loaded, even if you change the directory name.
                     
                    • Borodin

                      Borodin Master Astronaut

                      I could be reading that log wrong, but it looks as if you've got the Sprinkler mod loading twice.
                       
                      • sexisquidward

                        sexisquidward Aquatic Astronaut

                        Ok, so I've since deleted all the mods that were in there and the game still starts up black with the music in the background. Like I can visually see the menu screen and after I load the save file it's darkness.
                         
                        • sexisquidward

                          sexisquidward Aquatic Astronaut

                          I cannot for the life of me figure out where these random mods are located. I just read the log and said three mods loaded. The only one that should be in there is the TrainerMod
                           
                          • Borodin

                            Borodin Master Astronaut

                            [10:19:21.228 AM] LOADED 4 MODS

                            (Not my capitals. That's from the file.)
                             
                              Last edited: Oct 16, 2016
                            • sexisquidward

                              sexisquidward Aquatic Astronaut

                              From the file I posted it said four but after deleting the two I had in there it says 3. But there's nothing in my Mods file now besides the TrainerMod and I try running the game with just that in there and it still says 4 mods
                               
                              • GSPU

                                GSPU Phantasmal Quasar

                                You should have one in your roaming folder (Searching for %appdata% should bring you there relevantly), and one where you have the actual game installed in, but I'm assuming you have it in the latter. What else is there is this

                                [10:19:49.651 AM] [ERROR] An error occured in the overridden draw loop: System.MissingFieldException: Field not found: 'StardewValley.Game1.content'.
                                at SprinklerMod.SprinklerMod.Event_PreRenderHud(Object sender, EventArgs e)
                                at System.EventHandler.Invoke(Object sender, EventArgs e)
                                at StardewModdingAPI.Events.GraphicsEvents.InvokeOnPreRenderHudEvent(Object sender, EventArgs e) in Z:\Projects\SMAPI\src\StardewModdingAPI\Events\Graphics.cs:line 95
                                at StardewModdingAPI.Inheritance.SGame.Draw(GameTime gameTime) in Z:\Projects\SMAPI\src\StardewModdingAPI\Inheritance\SGame.cs:line 1217


                                Which is the cause of the screen going black. Make sure it's updated along with everything else, even if you said you did so. If you have to remove the mod to see if it works normally, then it has to be done.

                                Additional info: I saw you have these mods:
                                -Configurable Improved Sprinklers Mod by Maurício Gomes (Speeder) - Version
                                -You have two instances still, remove both and readd the latest version.
                                -LookupAnything by Pathoschild - Version
                                -Trainer mods by Zoryn (Obviously that's fine)
                                 
                                • Ladysarajane

                                  Ladysarajane Phantasmal Quasar

                                  Did you try both Stardew Valley Folders? There is one under Steam and there is another one under %appdata%/roaming/stardewvalley/mods
                                   
                                  • Borodin

                                    Borodin Master Astronaut

                                    I'm assuming SDV runs perfectly if you remove the sprinkler mod, correct? Post your log to us without the sprinkler mod in it, and let's see what it says.
                                     
                                    • GSPU

                                      GSPU Phantasmal Quasar

                                      Just posting that I have added more info from my post, as you still have duplicates in there. Or specifically:
                                      [10:19:20.955 AM] LOADED MOD : Configurable Improved Sprinklers Mod by Maurício Gomes (Speeder) - Version StardewModdingAPI.Version | Description: Make the Sprinklers work better. (@ C:\Users\gadge\AppData\Roaming\StardewValley\Mods\2-SMAPISprinklerMod\SMAPISprinklerMod.dll)
                                      AND
                                      [10:19:21.165 AM] LOADED MOD : Configurable Improved Sprinklers Mod by Maurício Gomes (Speeder) - Version StardewModdingAPI.Version | Description: Make the Sprinklers work better. (@ C:\Program Files (x86)\Steam\steamapps\common\Stardew Valley\Mods\SMAPISprinklerMod\SMAPISprinklerMod.dll)
                                       
                                      • Borodin

                                        Borodin Master Astronaut

                                        Yeah, I mentioned above "I could be reading that log wrong, but it looks as if you've got the Sprinkler mod loading twice." So we're likely right: he has the mod in two places. Either that, or something is seriously wrong with his setup. Removing all mods should help narrow it down--assuming one mod remains active in the log. At least, it's a start.
                                         

                                        Share This Page