Modding Help Hammer shockwave special attack broken

Discussion in 'Starbound Modding' started by gregest, Nov 26, 2022.

  1. gregest

    gregest Orbital Explorer

    Somehow the shockwave attack on hammers is completely broken for me, when I try to use it for the first time after starting the game, it just freezes the game for like 10 seconds, the shockwave ground animation plays and then it's just stuck, the animation never completes and the hammer never slams the ground, it gets unstuck when I switch weapons however the animation always gets stuck like that.

    I tried looking around and I haven't found anyone who has ever encountered this issue, I tried unpacking the game myself to look in the files and try to figure out the problem with my basic lua knowledge, that didn't work and I'm still clueless.

    I attached the log file, however this is the stacktrace
    stack traceback:
    [C]: in field 'playSound'
    [string "/items/active/weapons/melee/abilities/hammer/..."]:62: in function <[string "/items/active/weapons/melee/abilities/hammer/..."]:58>
    stack traceback:
    [C]: in function '_ENV.error'
    [string "/items/active/weapons/weapon.lua"]:101: in method 'setAbilityState'
    [string "/items/active/weapons/weapon.lua"]:279: in method 'setState'
    [string "/items/active/weapons/melee/abilities/hammer/..."]:53: in function <[string "/items/active/weapons/melee/abilities/hammer/..."]:19>
    stack traceback:
    [C]: in ?
    [C]: in function '_ENV.error'
    [string "/items/active/weapons/weapon.lua"]:41: in method 'update'
    [string "/items/active/weapons/melee/meleeweapon.lua"]:27: in function <[string "/items/active/weapons/melee/meleeweapon.lua"]:26>
  2. Rezetrx

    Rezetrx Void-Bound Voyager

    First off, are you using any mods or self-made weapon?

    From the stacktrace it looks like the weapon is trying to call the "fire" sound which is not defined or missing within the weapon you are using.
    In the case of hammers, the "fire" sound is both defined inside the hammer.animation and the .activeitem the hammer is defined in.
    Either of these is missing.

Share This Page