1. Welcome to the Starbound support forums. Please check the support FAQs before posting: http://playstarbound.com/support

Resolved Have finished Tech Quests, but cannot buy/use any other tech (like Rocket Jump)

Discussion in 'Starbound Support' started by Wingzrooke, Jan 12, 2020.

  1. Wingzrooke

    Wingzrooke Scruffy Nerf-Herder

    So, according to my quests log, I've finished all the original tech quests the Scientist gives you, and I can see the tech in the right-hand station at the Outpost, but the station on the left will not unlock, and I cannot unlock any of the other tech, like Rocket Jump, even though I've got a ton of chips. It may just be something I'm missing, but I've searched all over and can't figure out where I'm going wrong. I do have a few mods installed, but as far as I know they shouldn't effect the tech (I will list the mods below later). I made sure I have the latest version of Starbound installed, also. I tried using an admin command to make the tech purchasable, but it still shows I can't:

    upload_2020-1-11_18-22-26.png upload_2020-1-11_18-22-47.png
    And all the scientist says is he's busy now, or that they're at the forefront of tech technology. I put some screenshots in above, hopefully they post correctly.

    My mods include:
    Galactic Shops by Tremerion
    Ceiling Sprinkler.pak
    Pet Chickens.modpak

    Please help me figure out where I've gone wrong!

    Thanks. :)

    Attached Files:

    Last edited: Jan 12, 2020
  2. Iris Blanche

    Iris Blanche Pudding Paradox Forum Moderator

    Please provide your starbound.log after you opened the tech console on the right. This is where you unlock and equip the techs. The left one tho should have unlocked after the last scientist quest. At the left station you can buy a personal tech station for a few pixels.
    Also did you do all the quests in this universe or another one (e.g. playing with a friend)
  3. luna-tuna

    luna-tuna Scruffy Nerf-Herder

    I have attached the log below. As far as I remember (it's been awhile since I last played, not counting yesterday), I completed the quests on my own (no online play). New update on problem:
    So, my tech did (eventually, like 5 minutes later) randomly switch to the Rocket Jump after I used the admin command:
    /maketechavailable rocketjump
    however, none of them are available on the tech console, it doesn't show even the basic one available to purchase on the tech console (now that it's on the rocket jump),
    I attached the log I think is the correct one. I will try the admin command to switch to multijump and see if it works again. I still want to fix whatever isn't letting me do it the normal way, though.


    P. S. ` sorry, for some reason the site logged me on under hubby's log-in. Still same person for the bug.

    Attached Files:

  4. Iris Blanche

    Iris Blanche Pudding Paradox Forum Moderator

    As far as i can see it is that the tech console itself is working (judging by the screenshots). You can only have one tech selected per slot. E.g. rocketjump cant be used with multijump and so on. As for the left console this seems to be a bug which might be caused by a mod but im not sure about this. The log itself doesnt throw any errors on this one.

    Since the outpost progress is shared between all characters in the same universe you could make a new character and do the scientist quests again. Maybe the last flag wasn't set correctly after finishing the final scientist quest.
  5. Wingzrooke

    Wingzrooke Scruffy Nerf-Herder

    Okay, thanks! I'll try that.

    Using a different character to complete the quests fixed the left-hand panel problem. And I figured out the other thing. Thanks for your help!
    Last edited by a moderator: Jan 12, 2020
  6. Iris Blanche

    Iris Blanche Pudding Paradox Forum Moderator

    Glad it worked out. :nuruhappy:

Share This Page