1. Thanks for visiting! These forums are for the original Risk of Rain, if you're interested in discussing the newly released Risk of Rain 2 head over to that game's steam discussion forum
    Dismiss Notice

Help! Risk of Rain Data not saving after quitting

Discussion in 'General Discussion' started by Ionracas, Aug 11, 2015.

  1. Ionracas

    Ionracas Space Hobo

    Hello, I am in quite a situation. I had nearly gotten through all the game, most of the achievements, etc. Then one day, I got on to play it and all the data had been missing, when I thought of it as no big deal, I just got on and played the first character, unlocked some stuff, and quit for the day. Upon going on the game again to play it, I found that the data had once again been deleted. So I tried playing once more to unlock a few things to test it out. Turns out, after quitting the game, the data is erased and the files that were there disappear. I've tried turning cloud sync off and backing up the files, but I haven't got it fixed and it's quite irritating. I've not had this issue with any other game except this one.
    • KausGoMu

      KausGoMu Space Hobo

      I believe I have the answer. This was happening to me and I lost all my progress back in December. Go to the Steamapps Common folder, then to Risk of Rain. Notice the date of Save.ini. If it has a date much older than the last time you played, then Save.ini is corrupted. If your scores never save, then it is corrupted anyways. In DOS mode (Command promp), try typing it out. It should show nothing, but it probably contains unprintable characters. So the solution... Delete Save.ini (or rename it). Play Risk of Rain again for a few seconds, then quit the game. Now you should be able to type out Save.ini and see that it is a text file just like Prefs.ini, but much longer. Moral of this story: Save.ini is subject to corruption. Advice: Backup Save.ini whenever you can remember to, or write a simple script to auto-backup and restore. At least that way when it does get funky, then you can restore to the last saved point. Let me know if this works for you. I'm back in the rain...
      • MochiMadness

        MochiMadness Space Spelunker

        Hey. So, I know how dead this forum is, but I was hoping to get a little bit of help. I did what you said, KausGoMu, and it still didn't work. I deleted Save.ini, whose date was 2018, and then played the game. However, when I checked back, the save was there with the same date. Any suggestions?
        • Lachee

          Lachee Existential Complex

          If you are using a virus protection like BitDefender, sometimes it can block the save from being written.

          Share This Page