Tutorial How to Download Mod Updates with GitHub

Discussion in 'Starbound Modding' started by Xylia, Sep 9, 2016.

  1. Xylia

    Xylia Tiy's Beard

    Some mod users are using GitHub, and for good reason! GitHub is a powerful, powerful tool for any developer.

    You can easily download using the "Clone or Download" button, but there's a problem with that:

    1). It'll spit out a zip that you need to unpack, which has a folder named "Modnamehere - Master" which you will have to rename or your mod won't work.

    2). On extremely large mods like Frackin'Universe, it can take 15+ minutes for the computer to unzip the file because of the tens of thousands of files in that .zip.

    So... how about we take a 5-10min experience and cut it down to 10 seconds? Yes, that's possible, with git-scm. A lot of you may have tried GitHub Desktop and just could not figure the thing out (and it REQUIRES a GitHub Account, which the people reading this probably obviously do not have or have any interest in creating).

    Git-SCM does not require a GitHub Account at all, and I will talk about how to set it up, how to get your mod working, and how to update using it.

    Also, I'm typing some of this from memory (I already have the thing installed so I can't screenshot the install phase) so if I have anything messed up in here, please let me know and I'll fix it.

    Step One: Download it and Set It Up.

    To even FIND this, you have to do a lot of digging around in GitHub's website, but here's the direct link: https://git-scm.com/download/win .

    Go there, and download the appropriate version (this is for Windows, if you go back you can choose non-windows versions).

    Once downloaded, follow the directions. Most of the correct choices are already installed. I suggest telling it to use the MINGW64 version, and make sure you include the Shell Extension (the additions to the right-click menu in Windows Explorer). That's very important.

    Step Two: Clone the Repository.

    1). Start by Navigating to your \starbound\mods\ directory.
    2). Right click somewhere in an empty space.
    3). Click "Git GUI Here".
    4). Click "Clone Existing Repository".
    5). Switch to web browser, Go to the mod's GitHub page, click the green "Clone or Download" and copy the URL that it displays (it should end in .git).
    6). Paste that into the Source Location: box in Git GUI.
    7). Click "Browse" on the Target Directory line and click OK.
    8). Add the Mod's Name after it (it'll say \starbound\mods\ . Put your cursor at the end of the line and type the mod's name, eg, FrackinUniverse so that it reads \starbound\mods\FrackinUniverse\).
    9). Don't touch anything having to do with Clone Type.
    10). The next screen will take awhile, and for some reason the progress meter does not work, this is normal. Just let it sit until it tells you it is done.

    Once this is done, you should be able to navigate to the folder and you should see that the mod is there (there's also a hidden folder called .git. Do not mess with this folder, ever.

    Step Three: Updating.

    1). Navigate to the \starbound\mods\modnamehere directory. (Tip: Right click that folder and click 'send to desktop (as shortcut)')
    2). Right-click.
    3). Click Git Bash, NOT the GUI.
    4). You'll see a Command Line window pop up.
    5). Switch to your browser.
    6). Go to the Mod's GitHub Page (I recommend bookmarking it).
    7). Click the green "Clone or Download" button.
    8). Copy the URL ending in .git.
    9). Go back to the Command Line window.
    10). type this:

    git pull
    And then paste the URL after it.

    11). Hit Enter.
    12). You'll see lots of "stuff" flying by on the screen. When you see a new command prompt, it is done.
    13). Close the command line window. Your mod is updated.

    Except for very large updates, this shouldn't take more than 5-10 seconds at most.

    Some things to note:

    1). Do not change any files inside of the mod for any reason: This will cause Git Bash to error because it detects that you made a change. If you need to temporarily change a file, make a backup copy and restore the backup copy before attempting to update so that the file is back to the way it was. Otherwise you'll have to delete the mod and re-download it using Step Two above.

    2). Git Bash scans for changes made to the version on GitHub and compares them to your version, and makes your version the same as the version on GitHub which is how it can update so fast. If only 1 file was changed, then it will be done in a split second, because Git Bash knows that only that file was changed and only changes THAT file instead of re-downloading the entire mod.

    So hopefully this helps you people running GitHub Mods, especially Frackin'Universe.
    UchanSu, Aegonian, Kirbyroth and 8 others like this.
  2. seiyrios

    seiyrios Space Hobo

  3. LaughingAlex

    LaughingAlex Ketchup Robot

    For some reason when I try to use this to update it isn't letting me paste anything into the command prompt.

    Edit: Nvm, seems ctrl+v isn't paste, just remembered linux used something else for paste.
  4. Cyel

    Cyel Scruffy Nerf-Herder

    Just in case, command prompt paste is usually ctrl+shift+v, or alt+shift+insert for some even older / weird stuff, and most command prompts allow you to open the context menu (right click) -> paste
  5. ryan orias

    ryan orias Void-Bound Voyager

    the game just closes
  6. Zoraman611

    Zoraman611 Space Hobo

    I got the same problem as Ryan. I followed the steps and installed the mod. The game starts, but after the logo it just closes. I've tried running in admin mode, compatability mode, and admin with compatibility mode. Is there some way to this this issue? I really want to play with FrackinUniverse.
  7. IHart

    IHart Scruffy Nerf-Herder

    share your logs.
  8. buz9

    buz9 Void-Bound Voyager

    Thank you so much for this guide. I have actually been looking for a simple, good guide on git for like half a year. can't believe i found it here on the starbound mod forums. thanks again man!
    Xylia likes this.
  9. Xylia

    Xylia Tiy's Beard

    I'm glad this helped you, and yes it is confusing to the layman and I'm glad to have discovered how to do it so I can share it so other github newbies can do it too!
  10. Multistream

    Multistream Void-Bound Voyager

    i cant find how to install shell extenction, it didnt asked me to install while installing GitHub Desktop, and there is nothing related in Settings
  11. Xylia

    Xylia Tiy's Beard

    Did you visit the link in my OP, or did you just google it?

    The thing I linked above is not GitHub Desktop. It is called "Git-SCM" instead and there should have been a few questions the program asked you when you installed it, and one of those questions should have been whether or not you wanted the shell extension installed.
    The | Suit likes this.
  12. Multistream

    Multistream Void-Bound Voyager

    anyway i got it working with github desktop and it is even easier. Yes, i didnt read you need specific client and i installed the official one, thanks for help
  13. Wartavian

    Wartavian Pangalactic Porcupine

    Um... So, I followed the instructions, and yes, I got the modsElithianRaces folder, its in the starbound directory, and it holds all the assets of the mod. Here's the thing: Nothing of the mod is actually appearing in-game.
  14. Xylia

    Xylia Tiy's Beard

    Check your folder structure, did you somehow make a mistake with the .git GUI in step 2?

    Do you see


    or do you see


    or perhaps something like


    The middle one is the one you want. If it is wrong, simply copy&paste the contents (make SURE you have hidden files&folders displayed so you get the .git folder too) to correct the filepath.
  15. wylandylan22

    wylandylan22 Space Hobo

    Will this work if the mod is partially updated? (Started to replace all files while looking for a faster way then stopped replacing them 5% of the way through?)
  16. wylandylan22

    wylandylan22 Space Hobo

    I installed this but i am not sure if it installed the Shell Extension. How do I know?
  17. wylandylan22

    wylandylan22 Space Hobo

  18. Xylia

    Xylia Tiy's Beard

    Odd. It could be just a Github hiccup or something.

    That, or maybe you made a mistake in one of the other steps? I advise asking in FU Discord in #help, if this keeps happening if you give it an hour or two.

    SSL/504/404 errors on websites are somewhat common and usually resolve themselves after awhile, so maybe this is something like that?
  19. wylandylan22

    wylandylan22 Space Hobo

    I got it to create the Frackinuniverse folder but now it just sits there saying cloning but not doing anything.

    Attached Files:

  20. wylandylan22

    wylandylan22 Space Hobo

    Now it did this again:

    Attached Files:

Share This Page