Tutorial How to successfully pack and unpack .pak files

Discussion in 'Starbound Modding' started by SexualRhinoceros, Jan 26, 2014.

  1. IHart

    IHart Scruffy Nerf-Herder

    I am linux. share the command you are using?
  2. Minerscool

    Minerscool Scruffy Nerf-Herder

    Aye, thanks :/
    but why not trying the BoTW ? :)
    (Simply search for Minerscool on Steam so we can plan "the meeting " :p )
  3. dullreverie

    dullreverie Void-Bound Voyager

    Thanks helped a whole lot
  4. Sypher866

    Sypher866 Intergalactic Tourist

    "C:\Program Files (x86)\Steam\SteamApps\common\Starbound\win32\asset_unpacker" "C:\Program Files (x86)\Steam\SteamApps\common\Starbound\assets\packed.pak" "C:\Program Files (x86)\Steam\SteamApps\common\Starbound\modassets"

    worked fine for me , I had to fix a fiew things for the new updates also I made a file on my starbound dirrectory called modassets
  5. SpazDiesFirst360.0

    SpazDiesFirst360.0 Phantasmal Quasar

    Uh... I have a problem: The command window was replaced with Windows Powershell (windows 10), and the packing and unpacking do not work the same way. I tried doin it the same way, and:

    "C:\Program Files (x86)\Steam\SteamApps\common\Starbound\win32\asset_packer" "C:\Program File
    s (x86)\Steam\SteamApps\common\Starbound\mininglaseraddon" "C:\Program Files (x86)\Steam\SteamApps\common\Starbound\mini

    At line:1 char:78
    + ... set_packer" "C:\Program Files (x86)\Steam\SteamApps\common\Starbound\ ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    Unexpected token '"C:\Program Files (x86)\Steam\SteamApps\common\Starbound\mininglaseraddon"' in expression or
    At line:1 char:153
    + ... laseraddon" "C:\Program Files (x86)\Steam\SteamApps\common\Starbound\ ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    Unexpected token '"C:\Program Files (x86)\Steam\SteamApps\common\Starbound\mininglaseraddon.pak"' in expression or
    + CategoryInfo : ParserError: :)) [], ParentContainsErrorRecordException
    + FullyQualifiedErrorId : UnexpectedToken

    I don't know how to create buttons, so :(
  6. Supernovakid1

    Supernovakid1 Scruffy Nerf-Herder

  7. Supernovakid1

    Supernovakid1 Scruffy Nerf-Herder

  8. SpazDiesFirst360.0

    SpazDiesFirst360.0 Phantasmal Quasar

    I fixed it. I made a batch file set up the same way as I would the command window and it works now.
  9. CalebStich

    CalebStich Big Damn Hero

    When I type it in it just says "The system cannot find the path specified" How do I fix this?
  10. Jhroomy

    Jhroomy Seal Broken

    Floran found thisss extremely helpful. Floran thanksss you.
  11. SpazDiesFirst360.0

    SpazDiesFirst360.0 Phantasmal Quasar

    Having the same issue, even if I use a batch file that runs the command, it says "the filename of directory is incorrect" and almost instantly closes out.

    I used:
    "C:\Program Files (x86)\Steam\steamapps\common\Starbound\win32\asset_unpacker.exe" "C:\Program Files (x86)\Steam\steamapps\common\Starbound\assets\packed.pak" "C:\Program Files (x86)\Steam\steamapps\common\Starbound\UnpackedAssets"
  12. 777Dan777

    777Dan777 Cosmic Narwhal

    I blame PowerShell.
  13. SpazDiesFirst360.0

    SpazDiesFirst360.0 Phantasmal Quasar

    It is not really PowerShell that is is the problem. Yes, powershell does not have the capabilities of packing and unpacking as far as I know. But that is not really the problem that is being discussed (as far as I know). The problem is that cmd.exe (or also known as the Command Prompt, found via searching in C:\WINDOWS\System32) is having problems packing and unpacking, when it apparently used to be able to. Maybe an update broke the asset packer and unpacker. I tried using an older version of the asset unpacker (because I back up just about anything I feel may be important, not the point) and it works just fine, granted it takes forever.
  14. luizrenan16

    luizrenan16 Void-Bound Voyager

    Can someone give me an example of packing a folder in the new code?
  15. SpazDiesFirst360.0

    SpazDiesFirst360.0 Phantasmal Quasar

    I just tested opening cmd via a shortcut on desktop, and typing all the paths out entirely works.

    Try using this;

    "C:\Program Files (x86)\Steam\steamapps\common\Starbound\win32\asset_packer.exe" "<entire path to what you are packing>" "<entire path to where you want the content to be packed to>" (do NOT include brackets)

    Example: "C:\Program Files (x86)\Steam\steamapps\common\Starbound\win32\asset_packer.exe" "C:\Program Fies (x86)\Steam\steamapps\common\Starbound\test" "C:\Program Files(x86)\Steam\steamapps\common\Starbound\mods\test.pak"
  16. drathi

    drathi Void-Bound Voyager

    Tried to put the assets unpacker in the terminal and now its gone.:nurusad:
  17. drathi

    drathi Void-Bound Voyager

    im on mac btw
  18. shinyarceus4

    shinyarceus4 Pangalactic Porcupine

    Using the unpacker on Windows, it works okay but at some point it stops, saying that that the program timed out waiting for extraction to finish. The process is definitely incomplete, as a number of files (noticeably the entire species folder) are missing, but I have no clue what could be causing it besides the program quitting out for taking too long. Is there another cause for this issue, and if it is simply because it takes a long time, is there any way to prevent it from automatically aborting the process?
  19. Jonnie the Novakid

    Jonnie the Novakid Space Hobo

    Im having issues with it. There is a packed.pak in my assets folder, but i cant open it. Powershell, .bat files and other stuff isnt working. What should it do?
  20. SpazDiesFirst360.0

    SpazDiesFirst360.0 Phantasmal Quasar

    Maybe you closed it out by accident? Only thing that makes sense.

    What are you trying to open it with? Notepad++ will say it's too big, Powershell will ignore you, basically cannot be opened. The only way to unpack it is to set up a batch file like this;
    "C:\Program Files (x86)\Steam\steamapps\common\Starbound\win32\asset_unpacker.exe" "C:\Program Fies (x86)\Steam\steamapps\common\Starbound\assets\packed.pak" "C:\Program Files(x86)\Steam\steamapps\common\Starbound\unpackedAssets"

Share This Page