Tutorial How to successfully pack and unpack .pak files

Discussion in 'Starbound Modding' started by SexualRhinoceros, Jan 26, 2014.

  1. Yanazake

    Yanazake Space Kumquat

    I've been trying to extract the viera pak file just to try and see if the ships are in there. No luck.
  2. Fortnititudus

    Fortnititudus Space Hobo

    the code doesn't work, all I get is "The system cannot find the path specified." Am I doing it wrong?
  3. ilego

    ilego Void-Bound Voyager

  4. The | Suit

    The | Suit Agent S. Forum Moderator

  5. Wostrowski

    Wostrowski Aquatic Astronaut

    it didnt work for me. :(
  6. Timecop!1986

    Timecop!1986 Aquatic Astronaut

    At line:1 char:28
    + "win64\asset_unpacker.exe" "contents.pak" "Downloads"
    + ~~~~~~~~~~~~~~
    Unexpected token '"contents.pak"' in expression or statement.
    At line:1 char:43
    + "win64\asset_unpacker.exe" "contents.pak" "Downloads"
    + ~~~~~~~~~~~
    Unexpected token '"Downloads"' in expression or statement.
    + CategoryInfo : ParserError: :)) [], ParentContainsErrorRecordException
    + FullyQualifiedErrorId : UnexpectedToken
  7. Stella Darkmatter

    Stella Darkmatter Void-Bound Voyager

    Are you using CMD or "Powershell"?

    Using the method explained in the OP, on windows10, will give Powershell as the option instead of CMD. (Blue window instead of black). Go to the folder's address bar, click on an empty spot (highlight it blue) and type CMD. That will launch the proper CMD window with the folder's address set. (Like the OP's Shift+Right clicking). It should work at that point.
  8. roobboobjoob

    roobboobjoob Void-Bound Voyager

    Can I make a pak file out of a folder, and if so, can I do it with a mod folder, I couldn't quite understand the guide.
  9. GreenTriangle

    GreenTriangle Void-Bound Voyager

    Please help!
    I'm dying, I want to unpak one mod, but nothing happens. Works only with ingame assets. I feel I am really stupid. How to unpak a mod?? Specifically, I want to edit a ship mod for custom race. Just personal edit.
    Man, I figured it out. Just needed to rename .pak...
    Thanks for tutorial. Very clear for people that can read (not me, sadly)...
    Last edited: May 28, 2019
  10. Nexus Of Chaos

    Nexus Of Chaos Parsec Taste Tester

    GreenTriangle.... .modpak is a very old mod extension. now all mods use .pak like the base game assets, so where did u get ur hands on 1 and how did u unpack it?
  11. krszysztof

    krszysztof Void-Bound Voyager

    man thanks i've been trying forever to unpack the assets and this worked :nuruhappy:
  12. Maxmilian99

    Maxmilian99 Void-Bound Voyager

    Hey... I've been trying to unpack a pak file of a mod(not a modpak)... Instead of unpacking it, i got this:

    (IOException) could not open file "<pak file>" 2

    Could someone please help me??? Any help would be appreciated...
  13. The | Suit

    The | Suit Agent S. Forum Moderator

    Certain older formats need an older version of the unpacker
  14. SacredSabre

    SacredSabre Void-Bound Voyager

    Can someone help me? I tried opening packed.pak as a paint file and now I can't use it.
    Is there any way to fix this, or do I have to reinstall starbound?

    This is a serious question.
    Last edited: Jul 30, 2019
  15. MagnaSHAKE

    MagnaSHAKE Void-Bound Voyager

    How do i re-pack the unpacked file, i did what i wanted to but idk how to get it back into the folder.
  16. The | Suit

    The | Suit Agent S. Forum Moderator

    You want to aviod making changes to the master asset file.
    Instead make the changes into a mod.
  17. hobojobo99

    hobojobo99 Space Hobo

  18. alecu

    alecu Space Hobo

    it stops packing after 200 mb for no reason

Share This Page