1. Welcome to the Wargroove support forums. Please check the support FAQs before posting: http://wargroove.com/support

Bug/Issue Incorrect button mapping of Xbox wireless controller on Mac version

Discussion in 'Support' started by patsengo, Feb 20, 2022.

  1. patsengo

    patsengo Space Hobo

    Hi there,

    I just tried playing Wargroove on my Mac (new MBP with a Silicon chip) with a wireless Xbox controller (for the Xbox series consoles) and the button mappings are all wrong.

    For instance, when I go to "options" from the start screen, I can not switch tabs ("general", "video", "sound", etc.) with RB/LB. However, the Y button switches tabs to the left, and X displays the credits (which is normally meant to be what Y does). I have to use the keyboard to quit the credits (with a long press of ESC) because no controller button seems to do the trick.

    I haven't gone very far in-game, but there are other issues there. Like the drawer of the overview screen, which is meant to be toggled with X. But X just quits the overview screen altogether, and no button seems to be able to toggle the drawer.

    The D-PAD, joysticks, A and B buttons work as expected.

    I have played other games like Hades on this Mac and there are no issues there, everything works straight out of the box and there are no custom settings through Steam Input. I have tried disabling Steam Input, forcing Steam Input or just using the default settings. None change much of anything. I even tried remapping buttons through Steam's controller settings and those seem to be ignored by the game.

    I have no issues on Windows with the same controller. I also don't use any custom drivers like https://github.com/360Controller/360Controller. I just pair the controller through Bluetooth as Apple have added built-in support for recent Xbox controllers (see https://support.apple.com/en-au/HT211232)

    Hoping someone can shed some light on this!
    • Pangaea

      Pangaea Forum Moderator

    Share This Page