1. This forum is archived for reference. For support & bug reports visit the help section of forums.stardewvalley.net

Bug/Issue (Linux Mint) Touchpad doesn't work when moving

Discussion in 'Mac / Linux Bug Reports' started by thedodecahydra, Mar 6, 2020.

  1. thedodecahydra

    thedodecahydra Void-Bound Voyager

    Using Linux Mint 19 64bit game in Fullscreen mode

    If my player is moving via the arrow keys, the touchpad won't recognize input. I have to move the player, then stop where I want him/her, then I am able to use the touchpad.

    Let me know if there's more information you need, I will gladly supply what I can.

    Okay, discovered this wasn't a Stardew Valley bug, but a problem in my Linux.

    Not sure how to delete a thread that I've created, or if only a forum mod can do that. But I did also find the solution to my problem, so maybe this should stay if someone else has the same issue.

    I found the solution on Stack Exchange:

    The problem I was having involved the "Disable While Typing Enabled" feature of my trackpad. These are the steps I used to solve it.

    1. Make sure xinput is installed.

    2. Type xinput to find the name of the trackpad device. mine was "ETPS/2 Elantech Touchpad"

    3. xinput --list-props "DEVICE" to list the properties of the device

    4. Go through the list until you find something like "Disable While Typing"

    5. Use xinput --set-prop "DEVICE" ID_OF_PROPERTY 0. For me, this was xinput --set-prop "ETPS/2 Elantech Touchpad" 294 0
      Last edited by a moderator: Mar 6, 2020

    Share This Page