RELEASED Longevity v1.5->v1.6 (DNPCD_BETA) [@v1.6.9]

Discussion in 'Mods' started by RTGOAT, Mar 13, 2017.

  1. Neechan13

    Neechan13 Void-Bound Voyager

    While its not game breaking, the longevity mod breaks some character sprites (some glitch in and out like maru and Evelyn) and one schedule that I know of (Sebastian just stayed in his room all day)

    The worst is Shane in Joja mart when he works, and it doesn't know what to grab while the mod is installed, and it cycles through sprites that he shouldn't (it looks strange like he's having a mental break down)

    I know its this mod because i just tested it by removing it and it fixed it.... (also, I'm in the beta, so maybe that's why?)

    I'd figure I'd let someone know (and I'm running the latest version of SMAPI beta)
    • thornsby

      thornsby Void-Bound Voyager

      Same. Also can't ever meet Leah because she also never leaves her house. Gus was glitched as well. Sometimes he left his house, but on his birthday he stayed standing in front of the couch in his bedroom all day so I couldn't give him a birthday present. Maru did this same thing on her birthday, never left her room. It probably wont be a problem once I get my hearts up with them since I could then just go in their room to give them their present, but not being able to meet Leah was a bit sad.
      • blisfulloblivion

        blisfulloblivion Void-Bound Voyager

        I'm having the same issues. I'm already in summer of year 1 and still haven't completed the Introductions quest yet due to Leah never leaving her house.
        • sashuka

          sashuka Void-Bound Voyager

          Did anyone find a solution for this glitches?
          • RTGOAT

            RTGOAT Cosmic Narwhal

            The solution is an update.
            That update is in progress!
              leilacrystal and simply_fabulous like this.
            • WyvernRider

              WyvernRider Intergalactic Tourist

              Hey, I don’t know if you’ve been made aware of this, and this goes mostly for RTGoat but for all in the thread. The SMAPI console, that’s the window that starts before the game itself, says that the mod isn’t compatible with the game anymore, so that’s why you’re all getting the glitches and the missing functions.
              • RTGOAT

                RTGOAT Cosmic Narwhal

                Longevity v1.6.9:

                Longevity v1.6.9 is now live!

                • MCM trees should now be plantable and no longer require tilling the land as before.
                • Select NPCs should now follow their normal schedules (Leah, Gus, Pam, etc).
                • Fixed an infinite loop with Pricing updates in player inventory.
                • Fixed Taxes, they should now work as they did before.
                • Pricing and capital tax for chests/items in buildings (barns, sheds, etc) may function properly as before (NOT TESTED)
                • Affected MCM xnbs have been reworked to include new items and to be more compatible with future changes and content loaders.
                • Data.txt file will no longer be included in release. Longevity will detect if you already have the file and create one if you do not.
                Installation Guide: Here!

                Download: Longevity v1.6.9
                Previous Version Threads: Longevity v1.0->v1.2 | Longevity v1.3->v1.4

                Feel free to PM me your thoughts, suggestions, or feedback.
                Thank you!
                • sashuka

                  sashuka Void-Bound Voyager

                  Shane is still lagging in my game(((
                  • RTGOAT

                    RTGOAT Cosmic Narwhal

                    What do you mean lagging?
                    • coldazrael

                      coldazrael Phantasmal Quasar

                      Is it possible only to implement the taxes and have the rest of the features disabled?
                      • leilacrystal

                        leilacrystal Void-Bound Voyager

                        I still can't plant MCM trees - everything else is working great tho!

                        I don't see any errors in my SMAPI log, but I'm going to do some digging and see if I have any other mods that affect the crops.

                        Would an image replacement loaded by content patcher prevent them from being plantable? I've modified the crops png, as well as fruit trees png, but I merged them with your mod's pngs so that it would all appear as usual...
                        • RTGOAT

                          RTGOAT Cosmic Narwhal


                          Could be, not sure.
                          Are you planting them normally like regular saplings, or are you tilling the land?
                          Also, do you see the saplings as 'fruit' and not 'sapling'?
                          • coldazrael

                            coldazrael Phantasmal Quasar

                            My bad really o_O No idea why this silly brain of mine made a such conclusion like the MCM are hardcoded and couldn't be disabled.
                            I'll give it a shoot now, thanks.
                            And I'll update the mod as well.
                              RTGOAT likes this.
                            • leilacrystal

                              leilacrystal Void-Bound Voyager

                              I've tried not tilling and tilling, neither works.

                              As for your second question, I'm not quite sure what you mean? They're saplings (seed category) in the game, not labeled as 'fruit'-type items. I just mentioned fruit trees since that's a png i've modded.

                              I did try deleting my edited crops/fruit trees images, so that it was just loading your versions, and it didn't fix it. I also tried removing the better fruit trees mod, but that also didn't change anything, either. I'm really lost on what's off, since nothing is throwing new errors and there are no errors connected to the Longevity mod, specifically, either. But I do use a lot of mods, so maybe there's one Longevity isn't compatible with that I don't know of.

                              Here's a smapi log, if it helps.
                              • RTGOAT

                                RTGOAT Cosmic Narwhal

                                Make sure you're using v1.6.9, and you've overwritten the game's content with the provided MCM content.

                                These trees either don't exist in the game data, or you're using an old version of Longevity or its data content.
                                • leilacrystal

                                  leilacrystal Void-Bound Voyager

                                  I literally just reinstalled longevity (as of today, 8/30), and removed all my other mods except CJB Cheats & SkipIntro. I also re-bought my saplings from Pierre, in case something had funked up with the ones I'd already bought. Still not working. This *is* an older save file, where I had used Longevity before, then uninstalled it, then reinstalled it, but I can't imagine that would be the issue? Dunno tho. I tried playing with it on a newer save file (made post-1.3) and still couldn't plant mcm trees.

                                  Oh well, I guess I just won't have those extra fruit trees! I guess I could reinstall all my game files, but that's too much hassle for just some cool fruit, haha.

                                  Sorry to have been such a bother, hopefully the next update for smapi or longevity will magically fix it~ lol
                                  • Spiffyman

                                    Spiffyman Void-Bound Voyager

                                    I am getting an error that prevents this mod from working. I have Stardew Valley 1.3.28 with SMAPI 2.7 on Linux. In the pre-1.3 game I was able to use the mod without incident. However, with the 1.3+ mod and the new longevity version, something seems to be going wrong.

                                    [Longevity] Mod crashed on entry and might not work correctly. Technical details:
                                    System.IO.DirectoryNotFoundException: Directory '/run/media/spiffyman/Games/lingog/stardew_valley/game\Mods' not found.
                                      at System.IO.Directory.ValidateDirectoryListing (System.String path, System.String searchPattern, System.Boolean& stop) <0x417a1390 + 0x00197> in <filename unknown>:0
                                      at System.IO.Directory.GetFileSystemEntries (System.String path, System.String searchPattern, FileAttributes mask, FileAttributes attrs) <0x41a2d400 + 0x00063> in <filename unknown>:0
                                      at System.IO.Directory.GetDirectories (System.String path, System.String searchPattern) <0x41a2d3d0 + 0x0001b> in <filename unknown>:0
                                      at System.IO.Directory.GetDirectories (System.String path) <0x41a2d3a0 + 0x00017> in <filename unknown>:0
                                      at Longevity.Conversion.GetLongevityDirectory () <0x41a2d220 + 0x0003b> in <filename unknown>:0
                                      at Longevity.Main.Entry (IModHelper helper) <0x41a2a520 + 0x0002b> in <filename unknown>:0
                                      at StardewModdingAPI.Program.LoadMods (StardewModdingAPI.Framework.IModMetadata[] mods, StardewModdingAPI.Toolkit.Serialisation.JsonHelper jsonHelper, StardewModdingAPI.Framework.ContentCoordinator contentCore, StardewModdingAPI.Toolkit.Framework.ModData.ModDatabase modDatabase) <0x41967000 + 0x0390c> in <filename unknown>:0 
                                    I have tried multiple installs, both on that drive and on my /home partition. In both cases, it looks like it wants to open "/game\Mods" which I think may be the issue. It should be "/game/Mods" Any idea how I can fix that?

                                    EDIT: i had SMAPI dumpMetadata to true and the log it generated looked like it was looking in the proper directory (/Mods). I tried this with both the GOG version and the steam version of the game with the same results. Every other mod I've tried is fine. It seems that just this mod will cause this error.
                                      Last edited: Sep 2, 2018
                                    • RTGOAT

                                      RTGOAT Cosmic Narwhal

                                      You cant fix preexisting Objects.
                                      Try doing it with a newly bought sapling.
                                      • AlexanderBau

                                        AlexanderBau Void-Bound Voyager

                                        Can someone tell me, how can I make soda? :rofl:
                                        • Spiffyman

                                          Spiffyman Void-Bound Voyager

                                          Regarding the error I am getting with this mod, I've tried on another pc as well with similar results. Is there something hardcoded in this mod? It tries to open things as if it were on a Windows OS (with \ instead of /).

                                          Share This Page