Notice Manually Uploading to Steam workshop with Linux and Mac and Windows

Discussion in 'Starbound Modding' started by The | Suit, Jul 25, 2016.

  1. Monijir

    Monijir Scruffy Nerf-Herder

    That was the method I used when I ended up with my conflict problem - just whichever mod was downloaded most recently would show up in the mod list. Don't think I have the right files to replicate it now though. I have learned to first upload a private version to make sure everything's up and running.
  2. ManicRykker

    ManicRykker Phantasmal Quasar

    If anyone knows how you'd add a mod to categories with this method (Now that that workshop mod category tag feature's live) that would be very useful to know.. as I currently don't even know how to reap the new feature. :/
  3. GonDragon

    GonDragon Pangalactic Porcupine

    Just add to your .metadata file a new parameter called "tags" with the tags in the next format:

    "tags" : "tag1|tag2|tag3",
    Here, an example with all the actual tags of steam.

    "tags" : "Crafting and Building|Miscellaneous|Planets and Environments|Musical Instruments and Songs|NPCs and Creatures|Weapons|Quests|Dungeons|Cheats and God Items|Ships|Species|User Interface|Furniture and Objects|Character Improvements|Food and Farming|In-Game Tools|Mechanics|Vehicles and Mounts|Armor and Clothes",
    The | Suit and ManicRykker like this.
  4. The | Suit

    The | Suit Agent S. Forum Moderator

    For those not aware | is done by Shift + \ for Windows. It is not the lower case letter l or number 1.
  5. ManicRykker

    ManicRykker Phantasmal Quasar

    For some reason I couldn't get this to work... I got everything uploaded to the workshop, waited like a day, and neither mod I added the tags metadata line to show up in the tags I specified..
    That said, they don't use all of the tags so... did I just do something wrong?

    (Other metadata not included due to redundancy)

    "tags" : "Species|Furniture and Objects|Armor and Clothes",

    "tags" : "Miscellaneous|NPCs and Creatures|Furniture and Objects",
    (I think one was out of place for the latter... but that still doesn't explain the former..)

    Any ideas?
  6. GonDragon

    GonDragon Pangalactic Porcupine

    Mmmm, they looks right... May be that the place where the "tags" line is it also important?

    Here an example of a working metadata (uploaded with the official mod upload tool)

      "author" : "GonDragon",
      "description" : "I found a very good race mod but, sadly, isn't supported by frackin races. The race already have some inherent \"special ability\" coded into it, but it lack of some things to be a full Frackin' Races experience.\n\nSo, I decided to make that patch by myself. First, I maded it for personal use, but as I saw some people asking for it, I think to better release it.\n\nTo use this patch you need both, the Blattra race and Frackin' Races.\n\nThese are the changes in this patch:\n[list]\n[*] Diet: Omnivores.\n[*] Negative traits: -10% HP, 50% Ice Weakness\n[*] Positive traits: Low food consumption, +10% Energy , +10% speed\n[*] Resistances: +50% Poison, +30% Radioactive\n[*] Bonus: Gain a hefty health bonus in toxic, irradiated and decayed biomes.\n[*] Immunities: Poison, Radiation (both already in the race mod)\n[/list]\n\nI want to say thanks to the mod creators of both mods, for creating such amazing things and features to customize Starbound. That game wouldn't be the same without moders like you two. Thanks!",
      "friendlyName" : "Racial Roaches",
      "includes" : [],
      "link" : "steam://url/CommunityFilePage/1132476329",
      "name" : "FrackinRoaches",
      "requires" : ["Blattra", "FrackinRaces"],
      "priority" : 100,
      "steamContentId" : "1132476329",
      "tags" : "Character Improvements|Mechanics",
      "version" : "1.1.3"
    As you see, the "tags" parameter is between "steamContentID" and "version". Maybe is that?
  7. ManicRykker

    ManicRykker Phantasmal Quasar

    Not too sure... Frackin Universe has it under author, and theirs works perfectly fine... this is very odd.

    UPDATE: Never could get the tags working with this method, so I guess we may be out of luck on that front, unless anyone's found anything on this. :/
    Last edited: Jan 14, 2018
    Sock_Bunny likes this.
  8. Zancuno

    Zancuno Existential Complex

    By any chance, can you link a good packing software to make .pak files? I tried the first method but failed, so I may have to pack my mod up first.

    Edit: Issue solved, never mind

    I did not insert the full path into the cmd.
    Last edited: Apr 9, 2018
  9. nnnn20430

    nnnn20430 Scruffy Nerf-Herder

  10. The | Suit

    The | Suit Agent S. Forum Moderator

  11. K_H007

    K_H007 Scruffy Nerf-Herder

    Do you have a version that works in Catalina? because 32-bit apps no longer work on OSX Catalina; for some dumb reason, Apple decided to remove 32-bit program support.
  12. Bam4000

    Bam4000 Scruffy Nerf-Herder

    It makes an error.
    ERROR! Failed to update workshop item (Access Denied).

    Edit: I was stupid and found out what the problem was.

    now it says
    ERROR! Failed to update workshop item (Failure).

    Edit: I was stupid, again. so now it works!
    Last edited: Nov 22, 2020
  13. Solsolis

    Solsolis Scruffy Nerf-Herder

    Isn't that much easier just to run the windows version of the Steam client with Wine?
    I have a Wine-prefix to run a windows Steam-client just for playing NeoScavenger, because there is a bug in the Linux version, splitting stacks not working.
    I never tried runnig it with Steam Play, because back than when I bought NeoScav, Proton doesn't existed, and also some games simply not working with Proton.

    Anyways, just for curiosity I started the uploader and it fired up with no problem, but I don't have mod to upload so I don't know if it really capable of uploading a mod or not.

    I tried it out with a mod template, and it worked without any errors or problems! The mod is uploaded, and it was there in the workshop.
    So, you can use the Windows version of the Steam client in Wine to upload mods.
    Last edited: Nov 29, 2021
  14. YellowApple

    YellowApple Void-Bound Voyager

    I ended up automating this with a Makefile:

    it expects $STEAMCMD_USER to be set to my Steam username (I use direnv and a .envrc file to do this automatically whenever I cd into the mod folder), and expects there to be a metadata.vdf.template with spots to fill in absolute paths. Running "make" in the mod folder will copy the files actually relevant to the mod into out/src and run asset_packer to put a descriptively-named PAK in out/pkg. Running "make upload" will then copy the PAK to out/workshop/contents.pak, generate metadata.vdf (by replacing placeholders in metadata.vdf.template with absolute paths), and run "steamcmd +login $STEAMCMD_USER +workshop_build_item $PWD/metadata.vdf +quit".

    The nice thing about this approach is that cloning the repo directly into the Starbound mods folder still works as expected, and in general I can keep the mod code and Workshop metadata all in one place without extra folder nesting. It also avoids me having to hardcode absolute paths in the VDF file.

    All in all, seems to work pretty well.
    rl.starbound likes this.

Share This Page