1. This forum is archived for reference. For support & bug reports visit the help section of forums.stardewvalley.net

Bug/Issue "No Suitable Graphics Card" Error?

Discussion in 'Support' started by nolliemai, Feb 27, 2016.

  1. nolliemai

    nolliemai Space Hobo

    I'm having some issues with starting up the game and was hoping to get some help. I have been on steam community and all suggestions from there have not worked.
    This is the message that comes up when I try to start the game. http://i.imgur.com/OrQpx18.jpg
    I tried (with computer restarts between theses) updating my graphic drivers, reinstalling the game, reinstalling the XNA framework and the Dotnet files, restarted steam. Other games run fine on my computer and I've been told that my Specs meet the requirements for the game. Also everyone I've seen with this issue are people on Laptops, I'm on a computer.

    My Specs are: (I know you probably dont need all this information but not sure what you would need haha)

    Component Details Subscore Base score
    Processor AMD Athlon(tm) II X2 215 Processor 6.3 3.2
    Determined by lowest subscore

    Memory (RAM) 3.00 GB 5.5
    Graphics NVIDIA GeForce 6150SE nForce 430 3.6
    Gaming graphics 1407 MB Total available graphics memory 3.2
    Primary hard disk 107GB Free (284GB Total) 5.9
    Windows 7 Home Premium


    Manufacturer HP-Pavilion
    Model VG240AA-ABU s5202uk
    Total amount of system memory 3.00 GB RAM
    System type 64-bit operating system
    Number of processor cores 2


    Total size of hard disk(s) 764 GB
    Disk partition (C : ) 107 GB Free (284 GB Total)
    Disk partition (D : ) 2 GB Free (14 GB Total)
    Media drive (E : ) CD/DVD
    Disk partition (G : ) 314 GB Free (466 GB Total)


    Display adapter type NVIDIA GeForce 6150SE nForce 430
    Total available graphics memory 1407 MB
    Dedicated graphics memory 256 MB
    Dedicated system memory 0 MB
    Shared system memory 1151 MB
    Display adapter driver version
    Primary monitor resolution 1440x900
    DirectX version DirectX 9.0 or better

    I am not sure what else to do so if anyone can help I'd be hugely thankful :D I don't know if its my game or my computer (probably the latter) but i really would love to get to playing :)
    • Raayven

      Raayven Space Hobo

      I've been getting this same error. It's annoying, because I can play other games by chucklefish easy. Like Starbound, without error. Perhaps this is just a starting day issue? But it's making the game unplayable.
      • Wisdo101

        Wisdo101 Intergalactic Tourist

        I have the same problem.
        I can play Starbound just fine but when I open Stardew I get this error.
        I've restarted my comp multiple times and still get it
        • iammenasco

          iammenasco Void-Bound Voyager

          I read somewhere that if the developer changed some settings it should be better for everyone:


          Users facing this issue in a different game saw the error go away after the developer followed this action:

          "Originally posted by nitram:

          " Hi there, I've got this HiDef issue here too, on a crappy laptop computer.

          HiDef profile requires Shader Model 3.0 graphics card. So the 2.x card you got here will not be able to run the game :(
          (source: http://msdn.microsoft.com/en-us/library/ff604995.aspx)

          I'm developer too, and I already made some Xna games, and the HiDef profile is checked by default in the Visual Studio projet. But it can be unchecked to reach more platforms (because Shader model 3.0 seems a little high requirements in my opinion).
          Of course, the game should have shaders that are not using 3.0 features.

          When we made Blocks That Matter for the xbox, we weren't using any complex shaders, but the game was not running on some config when we sent versions to the press. So we just unchecked that checkbox in the VS project :) "

          - Could you uncheck the HiDef profile and re-patch the game? Or would that screw too many things up? Seems like thats the issue anyhow. Thanks again."

          As nitrate suggested, I'm not sure if its as easy as "unchecking a box" and not having the whole thing blow up, but if seems as easy for Stardew Valley as it was for this other game, I'd say its worth a shot to ask ConcernedApe.
          • LLGold

            LLGold Scruffy Nerf-Herder

            i hope something is done soon it seams this is a problem with laptops mostly and that is what i have. I am getting the same problem and i have been waning to play this for so long
            • JollyNG

              JollyNG Intergalactic Tourist

              I'm getting the same error message. I'm on a laptop with integrated intel graphics. Hope this is fixed in the next patch.
              • HonorableJulian

                HonorableJulian Seal Broken

                Yeah just that everyone can see that this is really urgent, i'll say it here again, i have this too (using wine under Linux). Like many, i spent hours with this and i really would like to play :D
                • JollyNG

                  JollyNG Intergalactic Tourist

                  Last edited: Feb 28, 2016
                • demonsamura

                  demonsamura Master Chief

                  Nice find. It works now, the watermark is a little annoying but atleast the game is playable now.
                    Avarwen likes this.
                  • JollyNG

                    JollyNG Intergalactic Tourist

                    Yeah, I can't figure out how to remove the watermark unfortunately. There's a lot of posts about how to do it online but they're all copy & pasted from the same source and none of them work.

                    "96 00 00 00 C8 00 00 00" isn't in this version of the DLL so I have no clue what to do. I also haven't been able to find a single version of the DLL that has that line in it.
                    • ConcernedApe

                      ConcernedApe Stardew Valley Dev Developer

                      Unfortunately, I can't just change the setting from HiDef to Rech... the game uses multiple render targets which are not supported by the reach profile.
                      • demonsamura

                        demonsamura Master Chief

                        If there isnt anything you can do can we atleast get this thread stickied incase anyone else has this problem?
                        • ballow009

                          ballow009 Space Hobo

                          I just got this Error when I first launch the game after buying it from steam. But what I managed to fix it by opening my NvDia Control Panel -> Then Setting "Preferred Graphics Processor" from "Auto-Select" to "High-Performance.."~

                          I didnt let this error to freaking hold me back from playing this awesome game :))) Cheers!

                          hope this helps~ :)
                            Last edited: Feb 28, 2016
                          • Wisdo101

                            Wisdo101 Intergalactic Tourist

                            Does this mean those who have this problem can't play the game? I mean, if that's the case it's a waste of $15.....
                            • JollyNG

                              JollyNG Intergalactic Tourist

                              You could always ask for a refund.
                              • demonsamura

                                demonsamura Master Chief

                                The fix that jollyNG posted worked for me, but you'll have a watermark that covers about 10% of the screen.
                                • JollyNG

                                  JollyNG Intergalactic Tourist

                                  Yep, one that is like 5% transparent so you can't really see anything behind it. Pretty annoying solution, but better than nothing.
                                  • Piggfloydd

                                    Piggfloydd Intergalactic Tourist


                                    Big fan of the Starbound game, so I decided to try this one out but kept getting the "Graphics Card" error. Spent atleast 3 hours trying to get that watermark file thingy working, but couldn't get it to.

                                    Fortunately I stumbled upon a YouTube video about graphics cards in general, and the game in the video is about "Graphics Card" errors for Terraria. I followed what was suggested in the video and now Stardew Valley is working perfect!

                                    If anyone can't access the video, what he does is go to the "Task Manager" (Ctrl Alt Delete) and stops the Steam.exe file application. On Windows 10, which i'm currently using, I found this under the "Details" bar between "User" and "Services".

                                    I have no idea how this works, I only know that it does work, and it doesn't involve any downloads or installations and no watermark either!!!!

                                    Thank you to the BugEyedReplyMan who created the graphic card video!!!!!!!!!!!!!!!!!!!!!! I'm so hyped to finally play this!

                                    Hope this helps anyone else having the same issues I do. I run an HP Pavilion Laptop for a comparison.
                                    • Dunto

                                      Dunto Guest

                                      I'm pretty sure you can get the same effect by simply disabling the Steam overlay (which I believe has already been mentioned).
                                      • Wisdo101

                                        Wisdo101 Intergalactic Tourist

                                        Doesn't work for me. I followed what he said to do and I'm still getting the same 'no suitable graphics' problem. :\

                                        Share This Page