Modding Help Packet Exception when Deploying Mech (Multiplayer Only)

Discussion in 'Starbound Modding' started by Halvaard, Nov 17, 2017.

  1. Halvaard

    Halvaard Void-Bound Voyager

    So when I try to use my mech on my friend's server, it deploys and sends me to the title screen with a Packet Exception.

    Here's the error from the server log:
    [01:42:52.017] [Error] WorldServerThread exception caught handling incoming packets for client 8: (EofException) Failed to read full buffer in readFull, eof reached.
    [0] 12fe94a
    [1] 12fd808
    [2] 12929d5
    [3] 129f0fe
    [4] 1297cfb
    [5] 1297704
    [6] 12977e0
    [7] 14cb34b
    [8] 14f2966
    [9] 14dc6d5
    [10] 12dd52e
    [11] 12dd9fe
    [12] 12dd52e
    [13] 12dd9fe
    [14] 13a11e5
    [15] 16e9bd6
    [16] 175a300
    [17] 176bd7f
    [18] 176b83a
    [19] 12fb2ac
    [20] 7517336a BaseThreadInitThunk
    [21] 76f298f2 RtlInitializeExceptionChain
    [22] 76f298c5 RtlInitializeExceptionChain
    [01:42:52.088] [Info] UniverseServer: Client 'Hal' <8> (my IP) disconnected for reason: Incoming client packet has caused exception
    We use Frackin Universe and several other mods and have used our mechs before with no issue, I can depoly my mech in my single player world just fine.
    I've tried restarting the server, my own game, I'm about to try removing mods one at a time.
    Any suggestions are welcome.
  2. Halvaard

    Halvaard Void-Bound Voyager

    Solved: Steam updated FU but the server was on last weeks version.

    ANyone know of a dedicated host that keeps mods up to date?

Share This Page