1. Please be advised of a few specific rules and guidelines for this section.

RELEASED PenGUIn - Starbound Server GUI

Discussion in 'User Interface' started by Senerio, Jul 22, 2016.

  1. Senerio

    Senerio Pangalactic Porcupine

    That's indeed unrelated to PenGUIn. I've tested a bit and tried to figure out how someone login it could crash it. I've logged in a bunch and had some people causality play it. Never had the problem.

    If you ever figure out what's causing it, keep me informed, I'll fix it asap. Basically, what I'm looking for is a way to reproduce the problem. So I'd need to know under what circumstance it happens. For example, when someone logs in when he last logged out on the outpost. (That's a bad example but that's what I'm looking out for)
  2. Pyrza

    Pyrza Space Hobo

    Ok I'll keep looking and tell my friends to keep on lookout too.
    But in the end problem is so minor it doesnt really bother me because when I log in to server pc, its usually just to restart computer/server.
  3. Aurastorm

    Aurastorm Yeah, You!

    I absolutely love this tool. It has helped me with figuring out a lot about Starbound servers and I thank you immensely for making this.
    Recently, however, I have found that one of my characters (the one that I have progressed by far the furthest on) no longer likes PenGUIn. Other characters that I've tried work just fine, but once I go on my main guy, PenGUIn will work for a few seconds and then stop responding indefinitely, causing me to close PenGUIn and end the server task so I can run the server executable by itself. The server itself still works fine, but PenGUIn doesn't like it and I have no idea why this is happening plz halp.
    I am running a decent amount of mods (around 40, along with some client-side ones) including Frackin' Universe, if that information is important.
  4. Senerio

    Senerio Pangalactic Porcupine

    Hmmmmmmm... That's odd. Could you per chance send me your character and world files? Also need to know which branch you are playing on.
  5. Novabella

    Novabella Scruffy Nerf-Herder

    Did you ever manage to figure out what I might've done wrong? As far as I know, I port-forwarded correctly. It was identical to the original port forward for 21025, but with a 6 instead. All I want is to be able to send messages through console to the players.
  6. Senerio

    Senerio Pangalactic Porcupine

    I did look at it. Sorry for not coming back to you.

    Unfortunately there is nothing to report... It was working for me. I'm not sure what's wrong on your side! :(
  7. Aurastorm

    Aurastorm Yeah, You!

  8. Cheeseboy157

    Cheeseboy157 Void-Bound Voyager

    Hey there!
    I've tried installed .NET Framework 3.5 for the past hour, and I haven't gotten any success with it.
    Is there a way it can be compatible with .NET Framework 4.6? Thanks.
  9. Senerio

    Senerio Pangalactic Porcupine

    It should have no problem running on 4.6
  10. throwaway12341

    throwaway12341 Intergalactic Tourist

    I also had this problem the last time I played. One of the mods (FU maybe, not sure) was echoing json to the console on I think world change or teleport. (Debug stuff probably, it had an item name in it)
    The instant the the text got echoed the gui would lock up. It's been a really long time since I played but stuff similar to this is in a bunch of my logfiles after I stopped using the gui and I'm pretty sure it was these doing it:

    [20:42:46.969] [Info] Unhandled Item:
    {config: {description: Durasteel beam., itemName: tier4beam, materialId: 2334, dropCollision: {1: -2.5, 2: -2, 3: 2.5, 4: 2}, rarity: Common, shortdescription: Durasteel Beam, inventoryIcon: tier4beamicon.png}, parameters: {}, directory: /items/materials/}
    Last edited: Jun 16, 2017
  11. Little_Teenwolf

    Little_Teenwolf Big Damn Hero

    I have some problem with RCON settings

    upload_2017-6-17_12-56-25.png I trying to decode this symbols, and i get this: >?KB:0

  12. Senerio

    Senerio Pangalactic Porcupine

    That's a weird error message. Are you certain you port-forwarded properly?

    Try to port forward with 21025 and 21026.
  13. jresine

    jresine Void-Bound Voyager

    Hello, please update for 1.3 please :(
  14. Senerio

    Senerio Pangalactic Porcupine

    I haven't gotten to check deep into 1.3. I tested the basics and it was still working. Can you tell me what's wrong with it?
  15. Little_Teenwolf

    Little_Teenwolf Big Damn Hero

    Well, the server is working. Moreover, messages are sent, including commands. However, this error appears after each command sent...
  16. zigarot

    zigarot Void-Bound Voyager

    Hey SorenIX, First up this is freaking amazing, it's exactly what I was looking for with my dedicated server on winServ2012, however I notice it freezes after a few hours. Any idea of log files I can look into? I run a factorio and terraria server as well, but these are working fine while penGUIn is non-responsive (starbound-servers also shows the server as offline, even though the exe is chewing some processing).

    Edit: This is what I seem to be getting just before it freezes:
    ServerRconClient exception caught: (NetworkException) tcp recv error: A
    and another one
    I/O error in TcpPacketSocket::readPackets, closing: (IOException) Internal error in uncompressData, inflate_res is -3
    and another
    I/O error in TcpPacketSocket::receiveData: (NetworkException) tcp recv error: A
    Last edited: Jun 29, 2017
  17. Senerio

    Senerio Pangalactic Porcupine

    That is pretty weird.

    Unfortunately, I am not an expert when it comes to network stuff. From what I gather, it seems something is closing which in turn cuts the line between the UI and the server process. And then you say the server is still running? I honestly have no clue how to fix that.

    I've found a thread related to the issue though, maybe you can take a look at it : http://community.playstarbound.com/threads/uncompress-error-upon-character-start-up.48198/

    Edit : It's a long shot, but it could be some sort of corrupted data in your universe/character files
  18. zigarot

    zigarot Void-Bound Voyager

    well I think you are onto something with that error, but i found the issue *I'm* having is actually caused when I remote desktop/ RDP into my server. I have it running without any other input devices, just power and LAN, and remote desktop into it. as soon as I disconnect my remote desktop, and reconnect, penGUIn freezes, but everything else is running fine. time to stretch my google-fu.
    It looks like PenGUIn is still running, it's just stuck on something.
    Last edited: Jul 1, 2017
  19. Senerio

    Senerio Pangalactic Porcupine

    That is an odd behavior. I can't say I know too much about remote desktops though...
  20. williamjcm

    williamjcm Void-Bound Voyager

    Hello, SorenIX.

    I just tested PenGUIn with SB 1.3.2 (the current stable at the time of this writing), and there are four things I like to tell you.
    1. Good job!
    2. Nice bonus, though the password was easy to find (hint: sort by duration, descending order).
    3. When player ships travel to coordinates, Player Tracking says "(coordinates unknown)"
      • On top of that, the ship icons in the Ships tab (and maybe the Player Tracking tab) do not change to the "traveling" icon
    4. I've tried setting up the RCON server, and I get the following:
    [10:20:07] [Info] RCON connection established. Type /help for server commands.
    [10:20:07] [Info] Server ready
    [10:20:08] [Error] ServerRconClient exception caught: (NetworkException) tcp recv error: U
    [10:20:39] [Error] ServerRconClient exception caught: (NetworkException) tcp recv error: U
    Points 3 and 4 are not important to me, yet I would have liked to try the RCON commands.

Share This Page