1. Please be advised of a few specific rules and guidelines for this section.

RELEASED PenGUIn - Starbound Server GUI

Discussion in 'User Interface' started by Senerio, Jul 22, 2016.

  1. gravydigger56

    gravydigger56 Scruffy Nerf-Herder

    Don't worry so much. Your GUI is something I would LOVE for a lot of games, and you are doing a really good job. Plus, I would prefer a slightly buggy version of PenGUIn than no GUI at all :)
  2. hikarushirou

    hikarushirou Scruffy Nerf-Herder

    Holy moly thank you for this! :nuruhype:
  3. Aaeeschylus

    Aaeeschylus Space Spelunker

    Hey, im really loving this. Has made making a server to play with friends so much easier. Everything is working perfectly, even with mods. However, I am having a little bit of trouble setting up the RCON. I have the port forwarded, the correct IP, the server starts normallly with no error, however whenever I try to type in a command in the GUI such as "/help", nothing happens. Nothing appears in the console, or even in the logs. I am wondering if I have done something wrong or if this is expected.
  4. Senerio

    Senerio Pangalactic Porcupine

    I've had trouble with people having trouble with RCON. It works perfectly for me but it could be due to something in my setup enabling it to be easy. If you tell me you really did everything correctly then there's probably only one thing I could do and that's seeing it for myself. Perhaps if I could see what your setup looks like I could help and figure out something from it. If you're ok with that, I'd like to remote control your computer and see what's going on.
  5. Delicious Vixen

    Delicious Vixen Space Hobo

    SorenIX, I have been using this server app for a while now, and I don't know if this has been gone over (there are a lot of posts) but I was trying to get 'enhanced storage' mod to work with the server, but I am running into crashes and incompatibility issues.... I was wondering if I am doing it wrong
    I am just placing the mod in the mods folder... do I need to do something special to get it to work?
  6. Senerio

    Senerio Pangalactic Porcupine

    If you're running into issues it's not likely to be PenGUIn. PenGUIn only acts as a mirror of the server output. Try running your server without PenGUIn, you should be seeing the same errors. If not come back to me :lickitung:
  7. mateuspm

    mateuspm Void-Bound Voyager

    Hi Senerio, I loved the bonus content !!! very useful for my times of relaxation.

    Are you still developing penGUIn or have you stopped? I'm curious abt
  8. Senerio

    Senerio Pangalactic Porcupine

    I'm still hoping the devs will make a small change so that I can fix a very annoying bug but otherwise... yeah it's pretty much done. Unless there's really something that's begging to be added.
  9. Crushedice

    Crushedice Void-Bound Voyager

    You still working on this program?
    Its great to host a server and manage everything.
    in what language is it written??
    Cause im thinking about a tool for Serversided characters, and thought that it could be possible to combine it with this.
  10. Senerio

    Senerio Pangalactic Porcupine

    It's been a while since I last worked on it. It's written in .NET using WinForms. Basic of basics.
  11. MrClassyWolf

    MrClassyWolf Orbital Explorer

    i keep getting the same error (networkExeption) ive included both my change logs if anyone could help it would be greatly appreciated. i made sure i did the port forward aswell

    Attached Files:

  12. Senerio

    Senerio Pangalactic Porcupine

    That doesn't have anything to do with PenGUIn but I can try to help.
    The only thing I can really suspect from that is that you didn't port-forward properly even though you say you did so we'll double check.
    I see the client is trying to connect on port 21021 and 21025. Are you sure one of them is the port you forwarded?

    Edit : I just tried to replicate the problem on my side and it really looks like it's a port issue. You need to make sure the port in your server config is the same as the one you port-forward. And if you're not using 21025, you need to put the right port number in the port box when you're logging on the server in-game.
    Last edited: Oct 5, 2018
  13. Senerio

    Senerio Pangalactic Porcupine

    Important message :

    The functionality allowing to update the app from within the app became outdated and is not working in versions below 2.1.6 as of today.
    If you want to get new updates when they come out, you will have to re-download the app from the main post.

    Thank you!
  14. Lerlo

    Lerlo Space Hobo

    PenGUIn doesnt start i tried everything i want to play with my friend
  15. Senerio

    Senerio Pangalactic Porcupine

    No error message? Also, hosting and being able to play doesn't require anything other than starbound_server.exe. PenGUIn is just a bonus.
  16. Dreadnautilus

    Dreadnautilus Void-Bound Voyager

    Just curious, but does this allow for automatic updating of mods on a server-end? Or auto-updating of the server, through steam?
  17. Senerio

    Senerio Pangalactic Porcupine

    No and no. :nope:
  18. crimsonblod

    crimsonblod Void-Bound Voyager

    Just wanted to give feedback that I am also still getting this error.


    Nothing critical, all it does is kill any updates to the gui until I restart PenGUIn, so it's not the end of the world, but I wanted to make sure you were aware that it was still an issue. It sounds like there isn't much you can do on your end though.
  19. Senerio

    Senerio Pangalactic Porcupine

    Kinda need the detail of that error message to be able to figure out anything. It would also help a lot if I were able to reproduce the error. If you have an idea of how it's happening that would give me a chance to fix it.
    But yeah there's another issue that I can just not fix without the server client having a tiny modification. But at this point, I don't think the devs are still working on much for the game. And it's likely I won't get the change I need.
  20. crimsonblod

    crimsonblod Void-Bound Voyager

    Whoops. I somehow missed the detail button.

    I'll post that the next time I come across that error, as well as a screenshot of the application itself. I just didn't have shareX running on the host machine at the time so I got distracted saving the snipping tool image, then transferring it over to my main pc, but that's fixed now. But yeah, it sounds like I'm having the same issue the other guy had, so I doubt it'll be fixable on your end if that's the case.

    For me, it seems to almost be random, but it may be related to teleporting, because that's often the last thing the logs show before the GUI stops updating. Surprisingly, it didn't happen last night, otherwise I would have uploaded that.

Share This Page