1. Please be advised of a few specific rules and guidelines for this section.

RELEASED PenGUIn - Starbound Server GUI

Discussion in 'User Interface' started by Senerio, Jul 22, 2016.

  1. Ykei69

    Ykei69 Aquatic Astronaut

    Hi Senerio, I was using PenGUIn and then I got this error when I tried to start the server:

    [Info] Session started on 2019-02-11 22: 31: 39
    Error: Too many positional arguments given, expected at most 0 got 1
  2. Ryonez

    Ryonez Void-Bound Voyager

    Hi there, having a little issue. I'm trying to set up custom commands, but they don't seem to work.

    This is a test command I made: https://i.imgur.com/HB6Nlsx.png

    I've tried triggering it with `test` and '/test`, but it won't trigger, even after a server restart.
  3. Ryonez

    Ryonez Void-Bound Voyager

    Today marks the second day I've unlocked my computer to find the PenGUI frozen. The only way to "recover" has been to kill it in task manager, along with the server as I can't access it anymore.
  4. Ryonez

    Ryonez Void-Bound Voyager

    And it's locked up for a third time.

    @Senerio There's something wrong with it.
  5. Ryonez

    Ryonez Void-Bound Voyager

    Traced the issue of PunGUI locking up to locking the computer.

    This is happening on Windows 10 Pro 64bit Version 1809. I lock the computer with the standard lock "Win + L" keys.
  6. crimsonblod

    crimsonblod Void-Bound Voyager

    Alright, I finally got the error again. It lasted quite a while without issue this time though.



    Last edited: Feb 26, 2019
  7. Ryonez

    Ryonez Void-Bound Voyager

    And just got this error. Which looks like the same as crismsonblod's

    See the end of this message for details on invoking
    just-in-time (JIT) debugging instead of this dialog box.

    ************** Exception Text **************
    System.NullReferenceException: Object reference not set to an instance of an object.
    at PenGUIn.Main.CheckInfo()
    at PenGUIn.Main.ProcessNewLine(String s)
    at PenGUIn.Main.bgw_ReadOutput_RunWorkerCompleted(Object sender, RunWorkerCompletedEventArgs e)
  8. Senerio

    Senerio Pangalactic Porcupine

    A sort of new Windows protocol messed up my update module so you'll have to re-download it via the link below or on the main post.
    I wrote a new module for it so it shouldn't be an issue anymore (until they mess with it again). I skipped university for this. #priorities

    Download Here : PenGUIn

    So what you'll have to do is very simple. Just run the app like you usually do until you get the bug you're usually getting.
    Once that happens, there will be a new message that will indicate there was a fatal error. Simply send the file it's telling you to send over to me and I'll be able to maybe figure out, first what's causing it, and second maybe a way to fix it.

    Last edited: Mar 11, 2019
  9. tjpowell7009

    tjpowell7009 Void-Bound Voyager

    Link doesnt work
  10. Senerio

    Senerio Pangalactic Porcupine

  11. Senerio

    Senerio Pangalactic Porcupine

    Alright everything is fine
    Download Here : PenGUIn
  12. Ryonez

    Ryonez Void-Bound Voyager

    Thanks for having a look.
    I've grabbed this version and gave it a go, but the program locked up when I locked the computer again. No error message is given.
  13. Senerio

    Senerio Pangalactic Porcupine

    I do not understand why that would happen. I make a lot of apps and locking your computer was never an issue. I know for a fact that the error message you are getting and the GUI unresponsiveness are two different issues.

    I could probably manage fixing the error when it comes around, but I am really clueless about the other one.
    Last edited: May 4, 2019
  14. Ryonez

    Ryonez Void-Bound Voyager

    I'm in the same boat, I've never had an app lock up quite like that just because I locked the machine. It doesn't make any sense.
  15. Ghislandi

    Ghislandi Void-Bound Voyager

    is it compatible with 1.4?
  16. Senerio

    Senerio Pangalactic Porcupine

  17. PhilipponMaison

    PhilipponMaison Space Hobo

    Hi , so I recently started to play with the gui app with my friend and out of nowhere sometimes , this happens and I can't do anything on the app , it just crash.

    But the server keeps running but I can't have access to gui again.
    When I try to reboot it , it stays at "Checking for updates" for a indefinite period of time.

    So heres is the log!
    Thanks for the help!

    Attached Files:

  18. Senerio

    Senerio Pangalactic Porcupine

    Hey there, what version of PenGUIn do you have? I ran your file with the latest version and there was no crash. Can you not update it?
  19. PhilipponMaison

    PhilipponMaison Space Hobo

    Hi again! Just opened the app and I have an update to do! So I guess it will be updated.
    It's weird cause I was sure it was up to date like it says on the top corner.
    Thanks for the fast answers!
    Love the app so much!
  20. TGRaiden

    TGRaiden Intergalactic Tourist

    Running into an error, PenGUIn crashed a couple of days ago and now it will not recognize the server or the server config file. I can't manually select the universe or the server config file I've downloaded these later links to the UI and reinstalled .NET but no luck. Running the server without PenGUIn is still fine and stable but I did enjoy the software.


    Attached Files:

Share This Page