1. Thanks for visiting! These forums are for the original Risk of Rain, if you're interested in discussing the newly released Risk of Rain 2 head over to that game's steam discussion forum
    Dismiss Notice

[SOLVED] Problems with saved games across computers (solution in last post)

Discussion in 'General Discussion' started by 2Zak, Apr 26, 2015.

  1. 2Zak

    2Zak Intergalactic Tourist

    Post-solving PS: To any dev reading this post: This is a cross-compatibility issue caused by how different versions of the game write and read the Save.ini file (not sure if it's a SteamOS/Linux vs Windows issue or a 1.2.5 vs 1.2.8 issue). I'd like to request it to be fixed at some point in the future.

    I'm having a problem with my saved games not getting synced across the two computers I usually play in. One is a desktop PC with Win7, the other is a laptop with Kubuntu. When I play on either of them, Steam Cloud doesn't sync the Save.ini files.
    I searched around my laptop and found out that the actual Save.ini file used in Kubuntu is not in the Risk of Rain Steam folder, but in /username/.config/Risk_of_Rain/, so I copied my Save.ini from my desktop PC into that folder and it worked.
    The problem is that it doesn't work the other way around. If I copy that Save.ini file from my laptop into my desktop PC's Risk of Rain Steam folder, RoR doesn't actually load it. So I searched around my desktop PC, I found out RoR has a config folder on Windows7 too, located at C:\Users\username\AppData\Local\Risk_of_Rain\, where there's another Save.ini file, but overwriting it isn't working either.
    So I guess there's yet another Risk of Rain folder somewhere on Windows 7 where the actual Save.ini file used by Risk of Rain is maybe? Can anyone help me with this? I'd like to keep the progress from the games I play on my laptop.

    UPDATE: I kept working on this and found out something pretty weird is happening. The Save.ini file inside the Steam folder in Windows 7 kepts getting overwritten whenever I launch the game. The weird thing is that I have disabled Steam Cloud sync and put Steam in offline mode in order to manually check what's happening. So, it seems like the game is somehow loading my old save from some magic place and then overwriting my actual saved game.
      Last edited: Apr 28, 2015
    • 2Zak

      2Zak Intergalactic Tourist

      I'm sorry for the double post, but I'm still having problems with this.

      I've deleted the files on Steam Cloud and disabled it but I still didn't manage to make my Windows game to accept my Kubuntu Save.ini.
      I have also been monitoring my hard drives in order to find out what's happening, and I found out that the Windows game, at launch, is editing the Save.ini in RoR's Steam folder (Steam\SteamApps\common\Risk of Rain\Save.ini) and setting some achievements' values back to 0. I don't know why or what those achievements are, but here are the exact values before the game resets them:
      I'm assuming those are either the achievements that unlock the characters I unlocked on my laptop (Sniper, Akrid, Loader and Chef) or the achievements that are unlocked with them. Probably both, since it looks like 53 or 33 are Loader's Power Glove achievement and 15 looks like Akrid's "cover everything with crap" achievement.
      What I don't understand is why is the game deleting them and setting them to 0 as seen here:
      Anyone have any idea of what's going on?

      UPDATE (mere minutes after pressing send): OKAY, I just found out that the SteamOS/Linux and Windows versions of the game are different. The Current content BuildID on the Local Files tab in the Properties menu for RoR is 580009 for Windows and 471805 for Linux. I read around the forums that this could cause some problems with saved files. Could this be it? I'll keep you updated if only for the hell of it.[DOUBLEPOST=1430226885][/DOUBLEPOST]FINALLY SOLVED
      It turns out that the Windows and Linux versions save their achievement values differently. Windows stores and expects integers (i.e. "2" or "1240") as the Save.ini values, while SteamOS/Linux version writes and reads them as floats (i.e.: "2.000000" and "1240.000000"). This is what was causing the Windows version to delete my achievement_progress lines: The achievements unlocked in Linux were written as floats, which Windows didn't recognize as proper values for them, so it didn't unlock the characters, so the progress for their achievements had to be fake and was reset.
      Also, for achievement_progress lines, Linux saves them as literal strings in-between double quotation marks. (i.e.: "1240.000000" instead of 1240.000000), which Windows also considers a no-no.

      To solve it: Just delete the finishing .000000 on every achievement line and any double quotation mark on every achievement_progress lines. So if you have lines like:
      Leave them as:
      And that's all. That will finally allow you to play with a Linux save on a Windows computer.
        Last edited: Apr 28, 2015
      • Wolfgam

        Wolfgam Space Hobo

        I need to transfer my windows save to linux, how i do it?
        • 2Zak

          2Zak Intergalactic Tourist

          Windows to Linux is fairly easy, Linux accepts Windows saves as long as they're inside Risk of Rain's actual configuration directory. The path to the config directory is "/home/username/.config/Risk_of_rain/" (at least in Debian-based distros such as Ubuntu and Kubuntu).

          Just copy your Save.ini in there and you'll be good to go.
          • Wolfgam

            Wolfgam Space Hobo

            wow, thank you :)
            • Powq

              Powq Space Hobo

              Just a slight necro for anyone coming in from Google - The "real" save.ini on OSX is located at /Users/username/Library/com.riskofrain.riskofrain.

              At least for me. Running El Capitan 10.11.6.

              It also saves as floats however, so for transferring to Windows you need to modify the file according to the guide above.

              Share This Page