[Steam] Multiplayer Disconnecting

Discussion in 'Support' started by JaxRyan, Aug 8, 2019.

  1. JaxRyan

    JaxRyan Space Hobo

    Hi all,

    I've been playing multiplayer via Steam and player 2 (not myself as the host) disconnects anywhere between instantly to an hour later. It occurs regularly. Over 10 hours playtime there has been ~20 disconnects.

    I've read through every thread on Steam with the word disconnect in it (most seem to be from 2018) and I've had a look around on this forum.

    I've tried so far:
    • Disabling all anti-viruses on both my PC as the host, and on player 2s. This includes windows defender.

    • Ensuring both game versions are up to date and the same

    • Verifying game integrity for both of us

    • "Turning it off and on again" via game, steam, PC and tourer

    • No stutter/high ping/latency issues via ping test (also no other issues with any other online game)

    • We've tried connecting in all ways possible i.e. join lan game/enter invite code

    • We’ve both tried being the host, player 2 disconnects

    • We both have 0 mods installed

    • We’ve tried having the host/guest sleep in specific orders (we have day 1 disconnects also)

    Are there any other recommendations we can try? No other game causes issues like this, and as luck would have it, this is one of our favourite games.

    Thank you to any who reply for your time. I genuinely appreciate it a lot.
     
      Last edited: Aug 9, 2019
    • isisvera

      isisvera Intergalactic Tourist

      yes exactly this!!!! I have tried to get help with this and have got zero responses. It is extremely frustrating. I have yet to find anyway of fixing this or why it is doing it.
       
      • Opalie

        Opalie Void-Bound Voyager

        Hello!

        I do not see in the list disabling firewall or even whitelisting Steam/Stardew. Did you try this?

        Else, when you joined game via LAN, did it do EXACTLY the same thing? (did you try with Hamachi, port forwarding, or were you actually using LAN in the same room?)

        Can you install SMAPI (it will make us a log we can read) so we can maybe troubleshot the issue? You do not need to install mods. Make sure to put the launch options at the end, read all install instructions carefully.
        Once you have SMAPI, can you give a log (instructions on that page) of both players? Just play until it disconnects.
         
        • isisvera

          isisvera Intergalactic Tourist

          I have these with exceptions to the firewall and have even disabled the firewall. What is weird is i was able to play for 2 days about 3-4 hours on both of those days no problem then a few days later we tried and it started to happen. I have tried every method except hamachi even port forwarding and nothing. I can try to download SMAPI to get you more info. I believe this is happening to quite a few people if you look in the known issues thread you will see other posts with log reports that might shed more light on what is going on. Hope i can get this resolved because this is a fantastic game that my wife and i can both play so any help is greatly appreciated.
           
          • Opalie

            Opalie Void-Bound Voyager

            Heh, I am community game support on the server, we see this bug more than often. Actually someone asked me to come and help here.

            I'd really like you to try Hamachi, and send me a log with the NON working version. Keep me updated!

            EDIT: all of this is still relevant to OP and anyone have the same issue coming here
             
              Last edited: Aug 15, 2019
            • isisvera

              isisvera Intergalactic Tourist

              Ok so just an update after about an hour of figuring out how to get hamachi to work my wife and i were able to play for about 4-5 in game days before it disconnected again. I thought i would be able to get a log from hamachi but i guess i missed the part about downloading that SMAPI thing so I will try to download that and try to play again and get you a log sometime in the next couple days. *sigh* i thought i had it worked out for a second lol
               
              • isisvera

                isisvera Intergalactic Tourist

                Ok so I am still getting quite a few disconnects here ais a log from smapi not sure if i did this right.
                 

                  Attached Files:

                • isisvera

                  isisvera Intergalactic Tourist

                  This was played by using hamachi I.P. with my wife hosting and me joining.
                   
                  • isisvera

                    isisvera Intergalactic Tourist

                    Was able to play for another hour or so then had a black screen when i entered pierre's store. Not sure if that is related but here is the log for that.
                     

                      Attached Files:

                    Share This Page