1. Welcome to the Starbound support forums. Please check the support FAQs before posting: http://playstarbound.com/support

Bug/Issue Strange Teleportation Glitches

Discussion in 'Starbound Support' started by TheMumbles, Jul 30, 2016.

  1. Zoa28

    Zoa28 Space Hobo

    I thought I was the only one with this bug. ;o;
  2. Kulsius

    Kulsius Scruffy Nerf-Herder

    Ok, I tried lending SSD and putting 1.0.3 on it (it's backup SSD, over 95% full with files slowing down overall performance), put on it many random mods and with 5 browsers (Firefox (with plugin to make backup copy every 5 minutes), Chrome, Comodo Dragon, IE and Edge) running and music (from WMP) in background, game ran more smooth and i never managed to get rubberbanding on teleport. (It's SSD afterall, it really is much faster to load stuff). Managed to replicate rubberband on my older HDD with no apps running and getting almost every time if playing from SD card. This really looks like longer loading issue to me. Or at least something that makes game stop loading sequence and try to put player in not fully loaded instance or trying to shut down world for idle (to save memory) even before player even gets a chance to spawn in there.
    What's interesting, if I play game with my Firefox open, I get much longer loading times (because of backup addon), but I still don't get this bug, while faster loadings sometimes seem to be broken if Firefox isn't running.
    Would be interesting if someone with extensive (you know, like >50% of the time) rubberbanding teleport would defragment all Starbound (only Starbound, so it's faster) files using Defraggler and try again to see if it makes any difference.
    --- Post updated ---
    Did some derping and noticed that placing teleport flag in certain places can make teleporting back 100% probability.
    And it generated log as most people post:

    [17:07:36.512] [Info] Assets digest is 1bd612310e61d189882a9e8a02ce481bea087f2f74dffc2d66e6d00ffc9759a3
    [17:07:36.512] [Info] Root: Loaded Assets in 2.61164 seconds
    [17:07:36.539] [Info] Root: Loaded ImageMetadataDatabase in 5.74742e-06 seconds
    [17:07:36.568] [Info] Root: Loaded NameGenerator in 0.0298111 seconds
    [17:07:36.599] [Error] OpenGL errors this frame: GL_INVALID_VALUE
    [17:07:40.193] [Info] Root: Loaded PlantDatabase in 3.62529 seconds
    [17:07:41.687] [Info] Root: Loaded ObjectDatabase in 5.14902 seconds
    [17:07:41.962] [Info] Root: Loaded ProjectileDatabase in 1.76867 seconds
    [17:07:42.211] [Info] Root: Loaded MonsterDatabase in 0.52424 seconds
    [17:07:42.225] [Info] Root: Loaded StagehandDatabase in 0.0142811 seconds
    [17:07:42.235] [Info] Root: Loaded NpcDatabase in 0.273154 seconds
    [17:07:42.239] [Info] Root: Loaded VehicleDatabase in 0.0130787 seconds
    [17:07:42.241] [Info] Root: Loaded PlayerFactory in 0.0056608 seconds
    [17:07:42.242] [Info] Root: Loaded VersioningDatabase in 0.00144342 seconds
    [17:07:42.242] [Info] Root: Loaded EntityFactory in 0.00356956 seconds
    [17:07:42.390] [Info] Root: Loaded ParticleDatabase in 0.147151 seconds
    [17:07:43.182] [Info] Root: Loaded MaterialDatabase in 0.939161 seconds
    [17:07:43.355] [Info] Root: Loaded TerrainDatabase in 0.172748 seconds
    [17:07:44.084] [Info] Root: Loaded BiomeDatabase in 0.729788 seconds
    [17:07:44.112] [Info] Root: Loaded LiquidsDatabase in 0.0273257 seconds
    [17:07:44.256] [Info] Root: Loaded StatusEffectDatabase in 0.144086 seconds
    [17:07:44.813] [Info] Root: Loaded DamageDatabase in 0.557512 seconds
    [17:07:44.882] [Info] Root: Loaded EffectSourceDatabase in 0.0686304 seconds
    [17:07:44.895] [Info] Root: Loaded FunctionDatabase in 0.0125134 seconds
    [17:07:44.982] [Info] Root: Loaded TreasureDatabase in 0.0868091 seconds
    [17:07:46.420] [Info] Root: Loaded DungeonDefinitions in 1.43793 seconds
    [17:07:46.420] [Info] Root: Loaded TilesetDatabase in 4.8032e-05 seconds
    [17:07:46.422] [Info] Root: Loaded StatisticsDatabase in 0.00257115 seconds
    [17:07:46.422] [Info] Root: Loaded EmoteProcessor in 7.18428e-05 seconds
    [17:07:46.434] [Info] Root: Loaded SpeciesDatabase in 0.0116755 seconds
    [17:07:46.457] [Info] Root: Loaded QuestTemplateDatabase in 0.022385 seconds
    [17:07:46.461] [Info] Root: Loaded AiDatabase in 0.00463448 seconds
    [17:07:46.463] [Info] Root: Loaded TechDatabase in 0.00150665 seconds
    [17:07:46.544] [Info] Root: Loaded CodexDatabase in 0.0812263 seconds
    [17:07:47.228] [Info] Root: Loaded BehaviorDatabase in 0.684166 seconds
    [17:07:47.259] [Info] Root: Loaded DanceDatabase in 0.0307409 seconds
    [17:07:47.280] [Info] Root: Loaded SpawnTypeDatabase in 0.0206916 seconds
    [17:07:47.287] [Info] Root: Loaded RadioMessageDatabase in 0.00685709 seconds
    [17:07:51.225] [Info] Root: Loaded ItemDatabase in 8.98378 seconds
    [17:08:01.697] [Info] UniverseServer: Acquiring universe lock file
    [17:08:01.754] [Info] UniverseServer: Loading settings
    [17:08:01.756] [Info] UniverseServer: Starting UniverseServer with UUID: 97a506c19bd87a2d383500c75f440e14
    [17:08:01.783] [Info] UniverseServer: Logged in player 'The Star Crasher' locally
    [17:08:01.783] [Info] UniverseServer: Logged in account '<anonymous>' as player 'The Star Crasher' from address local
    [17:08:01.789] [Info] UniverseServer: Reviving player at ClientShipWorld:09ce08dd5fe359a8730569c141667d11
    [17:08:01.789] [Info] UniverseServer: Client 'The Star Crasher' <1> (local) connected
    [17:08:01.797] [Info] UniverseClient: Joined server as client 1
    [17:08:01.865] [Info] UniverseServer: Loading client ship world ClientShipWorld:09ce08dd5fe359a8730569c141667d11
    [17:08:02.180] [Info] Setting steam rich presence connection as steam id 76561198019726773
    [17:08:02.187] [Error] Cannot set Steam achievement kill10poptops
    [17:08:03.495] [Info] UniverseServer: Warping player 1 to ClientShipWorld:09ce08dd5fe359a8730569c141667d11=1035.84.1024
    [17:14:47.187] [Info] UniverseServer: Loading celestial world -430586922:-155900793:-108588417:2
    [17:14:49.965] [Info] UniverseServer: Warping player 1 to CelestialWorld:-430586922:-155900793:-108588417:2=02572302723e04a3aadce53f0faee56a
    [17:14:50.095] [Info] Client received world stop packet, leaving: Removed
    [17:14:50.511] [Info] UniverseServer: Stopping idle world ClientShipWorld:09ce08dd5fe359a8730569c141667d11
    [17:14:55.851] [Info] UniverseServer: Loading client ship world ClientShipWorld:09ce08dd5fe359a8730569c141667d11
    [17:14:59.950] [Info] UniverseServer: Warping player 1 to ClientShipWorld:09ce08dd5fe359a8730569c141667d11=1025.56.1025
    [17:15:00.020] [Info] UniverseServer: Stopping idle world CelestialWorld:-430586922:-155900793:-108588417:2
    [17:15:00.131] [Info] Client received world stop packet, leaving: Removed
    [17:15:09.322] [Info] UniverseClient: Client disconnecting...
    [17:15:09.387] [Info] Client received world stop packet, leaving: Removed
    [17:15:09.671] [Info] UniverseServer: Client 'The Star Crasher' <1> (local) disconnected for reason:
    [17:15:09.671] [Info] UniverseServer: Stopping idle world ClientShipWorld:09ce08dd5fe359a8730569c141667d11
    [17:15:10.568] [Info] UniverseServer: Stopping UniverseServer
    [17:15:10.583] [Info] Clearing steam rich presence connection
    [17:15:13.557] [Info] Application: quit requested
    [17:15:13.557] [Info] Application: quitting...
    [17:15:13.558] [Info] Application: shutdown...
    [17:15:13.773] [Info] Root: Shutting down Root
    [17:15:14.227] [Info] Application: Destroying SDL Window
    [17:15:14.269] [Info] Application: stopped gracefully

    Thing causing
    Client received world stop packet, leaving: Removed
    for me was... uneven ground. Yup, will make screenshots when update 1.0.4 finish (gonna take a while).
    Update log states:
    "revert a previous fix for players beaming into terrain; needs a more complex solution"
    This, I believe, will fix problem for many people (maybe not all, but for me it should).
    Stay strong, Protectors! :D
  3. endertrot

    endertrot Cosmic Narwhal

    ... Well, if it means i get to play the game on my very old machine, i'd rather crash every once in awhile rather than not be able to go anywhere just because my computer's old.
    --- Post updated ---
    Okay, goodie. But what about times when you would try to beam to perfectly even ground, such as a mission teleporter, or the outpost, or, heck, your ship? Ive had trouble rubberbanding in all of these places, and some of them i cant get to at all, it just sends me to my ship, then beams me from my ship back to my sail station, if, say, i try to do something like the hylotl mission.
  4. AlexanderTemple

    AlexanderTemple Scruffy Nerf-Herder

    Yea, can't say I can rightly approve that it was uneven ground given my teleport were between the outpost, my ship and a test chamber. But there was definitely something wrong with that fix, glad they reverted it. Maybe as of today I'll be able to play without irritation. That'd be nice.
  5. endertrot

    endertrot Cosmic Narwhal

    Well... Something is very, very wrong still. I beamed to the outpost and back, both trips going off without a hitch, and then i tried to go to the grand pagoda library. Instead of sending me there and then sending me back to the sail station, it just sent me to my ships teleporter after a minute. So something is still wrong for me, but everything else seems to work. :(
  6. TheCrassDragon

    TheCrassDragon Void-Bound Voyager

    I just had this start happening today, except is specifically won't let me teleport to the outpost. This is happening on multiple characters. :(

Share This Page