1. Welcome to the Starbound support forums. Please check the support FAQs before posting: http://playstarbound.com/support

Bug/Issue Unstable - Invisible Unbreakable Wall in Apex Ship

Discussion in 'Starbound Support' started by Monsieur, Jul 22, 2016.

  1. Monsieur

    Monsieur Void-Bound Voyager

    The area I've highlighted in junktech blocks marks the location of the invisible wall. When I try to break what is there with a MM or a fishaxe it makes the block-breaking sound, but neither tool can remove it. It is not made of invisible platforms - a bug I found in older posts which vaguely resembled this issue, because it is equally solid and impenetrable from underneath. The wall cannot be covered in blocks and then removed - a fix that seemed to work for older invisible wall bugs.

    I made a post a few days ago believing it was the result of a glitched manhole cover - a door item from scorched cities - as the cover shifted after the release of a recent patch, relocating it down one block, and its removal resulted in this wall, but at this point I am now more concerned with what steps I can/should take to remove the wall. Due to the nature of this issue, I am also uncertain as to whether or not this is specific to apex ships.

    If anyone has any suggestions on what to do I'd be more than happy to test them out. Sucks putting this much work into designing the interior of a ship only for it to be ruined by a bug.

  2. Mackinz

    Mackinz The Waste of Time

    First I've heard of this issue, but if its anything like the issue with Novakid ships, try placing blocks over it then mining them away.
  3. Monsieur

    Monsieur Void-Bound Voyager

    "The wall cannot be covered in blocks and then removed - a fix that seemed to work for older invisible wall bugs."

    Already tried it, blocks cannot be placed where the wall is.
  4. JKthree

    JKthree Scruffy Nerf-Herder

    I've had this happen to where I had a few doors after coming back to an 2 month old file. Titanium and Rustic I believe they were. I also get invisible platforms when removing mods and I left a mod object you can stand on. No commands or block placing, destroying & replacing do anything for these issues.
  5. lazarus78

    lazarus78 The Waste of Time

    go into admin mode, do the command /debug then /boxes. This will show the collision. What does it look like?
  6. JKthree

    JKthree Scruffy Nerf-Herder

    My door related one.

    And my deleted mod related one. (there's 2 in this pic, 2nd is in the dirt pile)
  7. Monsieur

    Monsieur Void-Bound Voyager

    Mine looks like this:

  8. lazarus78

    lazarus78 The Waste of Time

    Odd. Usually just putting blocks would remove it. Im at a loss here.
  9. Monsieur

    Monsieur Void-Bound Voyager

    It looks like the same case as JKthree's door bug, apparently placing blocks over it didn't work out for him/her either.
  10. Captain_Walters

    Captain_Walters Void-Bound Voyager

    Hi all, same issue as OP, mine was with a standard apex ship door and now I am unable to pass through it.
    Apex ship as well, so this could be a trend.

    Attached Files:

  11. CaptainT

    CaptainT Scruffy Nerf-Herder

    Same thing happening to me right now.

    What a way to kill a game by making you not be able to go on your ship.
    Monsieur likes this.
  12. Hikarekuno

    Hikarekuno Big Damn Hero

    huh, so this was a known bug in unstable? it seems this bug is still a problem in stable. I don't see any dev responses either, I'm sadly really starting to doubt they actually gave a shit about fixing the game if this was the UNSTABLE version and is still in the """Stable full release 1.0"""
  13. Keihoshi

    Keihoshi Void-Bound Voyager

    My current work around this bug is getting a teleporter in my ship for the area that's inaccessible/blocked off.

    I used the admin command "/warp = 1040.1025" to get the other side thats blocked off becuase of the invisible wall. From there I placed down the teleporter. Now I can just teleport from my home position to my deck.

    Hope this helps.....

  14. Hikarekuno

    Hikarekuno Big Damn Hero

    Ah, that warp command works perfectly. Still a bit of a pain to access the other 90% of my ship but it's good for now.
  15. Uxian

    Uxian Void-Bound Voyager

    Suddenly got the same on Stable with the Novakid Falcon-class ship. I had a modern sliding door placed between two sections and suddenly I couldn't move through it when open. Nothing has worked to fix it (warping aside). When I used the matter manipulator it acts as though I'm trying to break blocks at that location but nothing happens.

    CRKZ likes this.
  16. Xanirus

    Xanirus Ketchup Robot

    Bumping this problem up again, as I'm now having the same problem with a recent design change of one of the crafting devices from the FU mod. Author says he has unable to find a way around this bug for literally years. This will be the second time I have to rebuild my ship/possibly character.
  17. Miletronome

    Miletronome Void-Bound Voyager

    I hope the solution comes up soon. I am having the same problem with FU, and I really wouldn't want to restart my ship or my crew because of it.
  18. locationiskey

    locationiskey Scruffy Nerf-Herder

  19. Jerln

    Jerln Oxygen Tank

    Bumping the topic to mention that I'm also having this problem, but it has to do with where a teleporter pad used to be. I used the mod that locationiskey linked, and the invisible blocks are gone, like nothing ever happened.
    Last edited: Dec 15, 2016

Share This Page