Modding Help Updating mods for Stardew Valley 1.4

Discussion in 'Mods' started by Pathoschild, Jul 2, 2019.

  1. zStormborn

    zStormborn Master Chief

    Benigni likes this.
  2. Asra Fantasy

    Asra Fantasy Aquatic Astronaut

    Okay so, i am able to upgrade my tools to the prismatic tools for some reason now. But the german translation isn't working. And the prismatic sprinklers act like scarecrows, as in they have the radius of them. Once i place one down and remove it however, it doesn't stack and seems to have the real radius. But it was just a visual bug, it still acts like a scarecrow. i think prismatic tools are beyond saving. I forgot to mention that i CAN'T spawn the prismatic tools in, however, as they don't appear on the CJB item spawner list.
     
    • Neckwhiskers

      Neckwhiskers Void-Bound Voyager

      Them acting like scarecrows is a feature. You can turn it off in the config.
       
      • Asra Fantasy

        Asra Fantasy Aquatic Astronaut

        I must've missed that part then... I am sorry.
         
        • sashuka

          sashuka Void-Bound Voyager

        • Allayna

          Allayna Pangalactic Porcupine

          I'll take a look, I think with these pet replacement mods, it's not that they break, it's that the CP mods only replace one of the three variations of pet now in-game.
          And also CP mods with a config now require a 'default' option, and some older CP mods don't have it.

          Edit - Here ya go, this should work! Note- If you want the shepherd or husky dog, run the mod once then change the config option. (Same as with original mod)
           

            Attached Files:

            Last edited: Jan 9, 2020
          • ballabas

            ballabas Space Hobo

            I installed this and it still doesn't work. I don't know if it makes a difference, but I'm on linux
             
            • Gwenhyfer

              Gwenhyfer Void-Bound Voyager

              Hey :) I've got an issue with the mega storage mod. https://www.nexusmods.com/stardewvalley/mods/4089?tab=files

              I also use remote fridge, and when I switch the fridge icon at the chest, everytime I want to cook it creates an error. It does not crash the game comepletely, but I am not able to cook aslong as the fridge icon is switched to "allowed". The mod author said, he is not able to update anymore. Is here anyone, who can make it compatible again? I don't have the skills to do that :-(

              First I thought, the problem is the remote fridge mod, but as long as I don't allow the mega chest for cooking, it does not crash.

              Here is the smapi log for this error.


              [SMAPI] The RemoteFridgeStorage.CraftingPage.RemoteFridgeCraftingPage menu crashed while drawing itself. SMAPI will force it to exit to avoid crashing the game.
              System.ArgumentNullException: Der Wert darf nicht NULL sein.
              Parametername: text
              bei Microsoft.Xna.Framework.Graphics.SpriteFont.MeasureString(String text)
              bei StardewValley.Menus.IClickableMenu.drawHoverText(SpriteBatch b, String text, SpriteFont font, Int32 xOffset, Int32 yOffset, Int32 moneyAmountToDisplayAtBottom, String boldTitleText, Int32 healAmountToDisplay, String[] buffIconsToDisplay, Item hoveredItem, Int32 currencySymbol, Int32 extraItemToShowIndex, Int32 extraItemToShowAmount, Int32 overrideX, Int32 overrideY, Single alpha, CraftingRecipe craftingIngredients, IList`1 additional_craft_materials) in C:\GitlabRunner\builds\Gq5qA5P4\0\ConcernedApe\stardewvalley\Farmer\Farmer\Menus\IClickableMenu.cs:Zeile 994.
              bei StardewValley.Menus.CraftingPage.draw(SpriteBatch b) in C:\GitlabRunner\builds\Gq5qA5P4\0\ConcernedApe\stardewvalley\Farmer\Farmer\Menus\CraftingPage.cs:Zeile 682.
              bei StardewModdingAPI.Framework.SGame.DrawImpl(GameTime gameTime, RenderTarget2D target_screen) in C:\source\_Stardew\SMAPI\src\SMAPI\Framework\SGame.cs:Zeile 1501.


              Thank you very much :)
               
              • Isalami

                Isalami Void-Bound Voyager

                Beon likes this.
              • Eros DkAl

                Eros DkAl Starship Captain

                You can romance him with the mod "Looking for Love"
                 
                • Isalami

                  Isalami Void-Bound Voyager

                  I thought that mod wasn't updated though. :c
                   
                  • MartinMiggs

                    MartinMiggs Aquatic Astronaut

                    Hey, all,

                    Is it okay if I post an error log here for someone to look at? I can't seem to find the most appropriate forum for this; the support forum seems abandoned, I can't follow the reddit thread's organization, and I don't know what particular mod(s) is/are causing the issue for the Mods forum. Basically my game tries to save going into Fall 2, but never actually completes the process.

                    https://smapi.io/log/860763127d0e43fcbb1840d109b1cd96

                    It looks like Pytk is having a hiccup, but I can't be sure that it's the true culprit here. Using the unofficial update 1.12.14.
                     
                    • Allayna

                      Allayna Pangalactic Porcupine

                      First off, this may or may not fix the error you're getting, but *nudge* update your mods!
                      As for the log, can't tell exactly what's wrong without knowing all of your CP and json assests mods,
                      but the hitch happens when an item called "Sigil Table" is added by one of the mods,
                      says an item with that item key already exists.
                      So two mods are trying to add an item using the same item key.
                      I haven't used json assets for quite a while, but I believe you can go in and change the key for items yourself to try to fix.
                       
                        SorryLate likes this.
                      • MartinMiggs

                        MartinMiggs Aquatic Astronaut

                        @Allayna Thanks so much for taking a look! One of the few things I was able to parse from that error log was the fact that the sigil table from the unofficial update to Witch's Valley is failing somehow. Is that really what's causing the saving issue though? I'll try removing it next time I attempt this day. (Ive already tried 4 times, and it's the first of the month with Artisan Valley installed, so each attempt takes like an hour even with cheats lol.)

                        I failed to mention this before, but I religiously update my mods. I even updated SMAPI to try and fixed this issue to no avail. Despite this, I still get the same purple text stating my mods need updating. Not personally concerned about it.

                        I'll comment back tomorrow after taking out Witch's Valley whether that fixed the issue or not.
                         
                        • Redd Foxx

                          Redd Foxx Intergalactic Tourist

                          I can't get it to work. I go to send a gift and I just get this error:
                          https://smapi.io/log/b2fd7602e06749edaa8701e7f40a307b

                          I've tried changing the settings in the config, but that didn't help.
                           
                          • SorryLate

                            SorryLate Poptop Tamer

                            i've test PPS by kouki.neko it's work fine. did you try to remove all your mod first? i think it's have conflict

                            As author said, mega storage has huge issue.
                            Why not move to use Chestex instead?
                             
                              Last edited by a moderator: Jan 10, 2020
                            • Iris Blanche

                              Iris Blanche Pudding Paradox Forum Moderator

                              Please avoid doubleposts after such a short time. These only clutter up topics and can also be considered as spamming. You can reply to multiple people in one post.

                              I merged the posts.
                               
                              • Eros DkAl

                                Eros DkAl Starship Captain

                                Still works fine for me, I think there's an unofficial update.
                                 
                                • Tinymouse19

                                  Tinymouse19 Space Hobo

                                  I'm sorry if I'm posting in the wrong area. I'm not sure where else to go. Ever since the 1.4 update none of my mods hasn't worked. I've updated smapi and all the mods files to the newest update. I've uninstalled and reinstalled smapi and stardew valley multiple times. I've made sure that all the mods are in the mods folder unzipped. However when running stardew valley smapi doesn't even register that the mods exist. It only recognizes the two mods Console commands and Save Backup. I've searched for days trying to see if someone else has the same issue but I can't seem to find anyone who has. Can someone point me in the right direction I would very much appreciate it. I really miss my mods. I took a screen shot of what was happening and all the files in the mods folder.
                                   

                                    Attached Files:

                                  • Melindee

                                    Melindee Zero Gravity Genie

                                    I can't help with Steam since I don't use Steam but where did you get your mods from?
                                     

                                    Share This Page