1. Welcome to the Wargroove support forums. Please check the support FAQs before posting: http://wargroove.com/support

Wargroove patch 1.2.0 - Known Issues and Fixes!

Discussion in 'Support' started by Shubeans, Mar 6, 2019.

  1. Shubeans

    Shubeans QA Wizard Chucklefish

    Hello everyone,

    We've updated to Patch 1.2.0, all consoles will now have a handy little build number in the top left corner of the options screen so you know if you're on the latest build or not!

    As always, if reporting a bug please follow the handy little tips below.
    We're keeping the usual launch issues at the top of the list, but please let us know if you're having any issues! :)

    A better running log of bugs can be found here:
    Please, please search for your issue before reporting it.

    Reporting Tips
    • If you're reporting a crash, please be as detailed as possible about what you were doing when it happened. This will help identify the issue much, much faster.
    • For any other issues as well, please be as detailed as possible about what you were doing in game so we can try to reproduce
    • Even if the issue has been reported, if you have new details please share!
    • Please let us know which platform you are having issues with; Switch, PC, Xbox, PS4?
    Below is a list of issues which we've identified since the release. If you're having a problem in this list marked 'need more details' it would be helpful to provide more info - we're still working on reproducing/determining a cause for these issues. If your issue isn't listed here then please be as detailed as possible reporting it so we can review. Always check you have the newest game/system updates before reporting an issue to make sure it hasn't already been fixed!

    Current Version:
    Steam: 1.2.5 #16952
    Switch: 1.2.5 #16813
    Xbox: 1.2.0 #16424

    Make sure you have the latest version before reporting issues. The game may have been updated.

    Colour Key:
    Fixed - This issue should be resolved in the recent update/next update
    In Develop - Fixed or have a solution in development for a future update.
    Investigating - We have reproduced or confirmed this is an issue, but are still developing a solution
    Need More Details - We're aware of the issue, but don't yet have enough information to reproduce/fix

    Below are some reports from this thread, consolidated to make it easier to scan if an issue has been reported or to find common threads between reports for the same issue.

    Cannot launch on steam:
    Please try some of the fixes outlined here before contacting us about this issue:

    - Try Launching in Administrator mode:
    1. Navigate to your Steam install folder (Default: C:\Program Files (x86)\Steam).
    2. Right click the Steam executable.
    3. Follow the above steps to set it to Run as Administrator.
    4. Restart Steam.
    - Make sure your Media Package is up to date or installed: https://support.microsoft.com/en-us/help/3145500/media-feature-pack-list-for-windows-n-editions

    - Make sure that Visual C++ is update to date: https://www.chip.de/downloads/Visual-C-2010-Express_24081894.html

    - Remove any Joysticks and XInput Flight controllers you may have plugged in
    We're working on a fix for this!

    - Make sure all your drivers are up to date, including Windows updates

    - Run the game in OpenGL

    - Run the game with the launch peramiter '--skip-intro'
    1. Right click on wargroove in your library
    2. Go to 'properties'
    3. Select 'set launch options'
    4. Type --skip-intro into the text bar.
    - Run sfc /scannow in the command prompt; this will find and replace any corrupted files that might be causing the issue

    - If you are getting error message 'GL pixel Format not available' and are on Windows 7, you probably have your monitor set to use 16 bit colour depth. Here's a guide on how to change it to 32bit: http://www.sevenforums.com/tutorials/258-color-bit-depth-display-settings.html

    - Error message 'Node'~' (null) at "(1:1)" is not a map type' on launch.
    This is caused by corrupted save files, please make sure the game saves before turning off your pc or alt-F4ing.

    Fix: Take out the PlayerProgress file found in %appdata%/chucklefish/Wargroove/Saves
    Rename the file 'playerProgress.bak', and remove the '.bak' from the name.
    Make sure Steam Cloud is disabled for Wargroove
    Relaunch the game.

    If this doesn't work, try removing the 'achievements' file. Don't worry, you won't lose progress here!

    - Error message 'Node'~Language' (null) at "(1:1)" is not a string type' on launch.
    Go to %appdata%\Chucklefish\Wargroove\save_local and delete the options file there

    All Platforms:
    • Prologue displaying white cutscene
    • Directional keys still work during battle animations, causing view to be off-centre when returning to map
    • "Your Turn" prompt doesn't work correctly with CPU's in scenarios
    • Halley error when using Checkpoint in a tutorial mission
    • Koji has '#MISSING' Walk type in cutscene editor
    • Selecting a 1p Scenario in Multiplayer results in connection error message
    • Leaving a 2v2 match from the lobby can cause a crash for player 1
    • Game does not End Turn if player dies with a unit inside of an Allied Transport
    • Alchemist and Witches attacks in cutscene are broken
    • UI: Show Dialogue trigger with no text causes crash
    • Having 2+ music changes in the events cause the sound to all pile up
    • Downloading a map sends you back to page 1
    • When editing the "Create Actor" event, the movement resets from "Angry" to "Normal"
    • Sparrow Bomb displays as Balloon in damage preview.
    • Some unlock text states 'unlock via campaign', despite being Unlocked via Arcade
    • Air units have two shadows when flying over water tiles
    • No Counter attack displayed when Merfolk attack from Land>Water tiles
    • Tenri doesn't have the option to reinforce when her groove is active next to a building
    • Shout and Emotes are no longer valid for various characters in the cutscene editors
    • Resigning causes app to Freeze
    • Game not launching on steam - Please see instructions above
    • Game not launching with Windows 8.1 - Please see instructions above
    • Crackly/popping/skipping Audio
    • Workaround: Is OBS or another Streaming software running in the background?
      Workaround: Disable any Virtual Audio Cable and output directly to audio device
      Workaround: Try launching in OpenGL?
    • No Audio
      Workaround: Try launching with ' --audio-device=2 ' as a parameter in 'set launch options' of Wargroove steam properties
    • Game crashing after controller disconnects
    • Having 2 controllers plugged in causes game to crash when one disconnects
    • Crash when selecting Dpad on PS4 controller
    • Overlapping Effectiveness images when using 'esc' to close recruitment screen
    • Crash when Right Clicking on map that have spawn 'any commander' event
    • Pressing Esc on keyboard takes user to highlighted menu option instead of trigger the exit game prompt
    • 'Open to Friends' doesn't stay selected after leaving lobby
    • Lost progress after saving
    • System Error after losing Online match
    • Non-Primary console crashes when returning from sleep mode
    • Audio issues when docking/un-docking console
    • Unable to launch/install Might be caused by Xbox Live being down. Please check this, and restart the console.
    • Multiplayer game crashing when user goes to home screen
    If you are reporting a crash, please add the 'log' text document from the folder AppData/Roaming/Chucklefish/Wargroove to your comment.

    These reports are not confirmed bugs, this is just a list of report posts formatted for readablity. If your issue is not listed here that doesn't mean it's not being read/acknowledged! If an issue is determined not to be a bug it will be removed from this list to keep it readable.
    We plan to continue to collect reports and identify issues to include in updates, but we'll need player reports to be as detailed as possible in order to properly identify/fix bugs. Our priority obviously will be any bugs which impact gameplay like crashes.
    While some issues have threads dedicated to them - posting details either here or in the corresponding thread would be helpful - we'll do our best to make sure any new info/workarounds are communicated in both places to make sure players can find that info easily.
    If you're reporting a bug which was originally reported outside the forums please make sure to add a link to the original post - we may need to contact that player directly for more details.
    We're going to continue monitoring these and any newly reported problems, so please provide as much information as possible for any issues you may run into! We've worked really hard on this, and hope you enjoy Wargroove!

    Thanks everyone!!
      Last edited: Apr 23, 2019
    • rurukawaii123

      rurukawaii123 Space Hobo

      With the redesigned system where you can see enemies weaknesses and stuff, if you hover your mouse over one of the new icons and then press escape (to close that menu), the picture showing you the weakness doesn't go away and stays there until you restart the match.

        Attached Files:

      • Hatkat

        Hatkat Aquatic Astronaut

        I have a small addition to this: when you set a Starting Emote for the unit, then switch their color, the emote resets to default (usually the calm/normal/idle, whatever is on top of the list).

        Example: You make a Red Soldier with 'Telescope' emote, then switch his color to Blue; the Emotion resets from 'Telescope' to 'Idle'.
        • codyfun123

          codyfun123 Scruffy Nerf-Herder

          Maps in puzzle mode should probably silently override the damage range option, since randomness isn't used in puzzles.

          In the cutscene editor, the second spoiler commander has a #MISSING labeled animation, "Positive" and "Charging" identical animations, and one animation that is used in one associated story cutscene that I can't find for use in the editor ("reaching").
            Last edited: Mar 6, 2019
          • Becks27

            Becks27 Space Hobo

            I just got this issue in mission 2.3 and I didn't suspended game.

            What I did was:
            - loaded checkpoint
            - immediatly created a new one (wasn't sure if loaded checkpoint was deleted on load)
            - played a bit then resigned
            - selected load checkpoint and game crashed with the message "Halley exception on checkpoint file"

            Hope this is helpful for debugging
            • malimccalla

              malimccalla Space Hobo

              Platform: Switch

              - Select multiplayer
              - Select online
              - It automatically joins me into an old game on the opponents move and freezes

              Everything freezes apart from the audio. There is nothing I can do once the game has frozen but close the game. If I attempt to play online again the same thing happens

              Additional info:

              My opponent may have left mid way through the game and every-time I try to play online again it automatically goes to the "searching for a match" dialog box and joins the old game. If I quickly press B before the game loads on the "searching for a match" dialog I get "Oops! An error has occurred. Connection to server aborted due to invalid state"
              • Shubeans

                Shubeans QA Wizard Chucklefish

                Thank you SO much for this!
                Is this the first time you create a checkpoint save within the game?
                • Shubeans

                  Shubeans QA Wizard Chucklefish

                  Is this with a Quick match?
                  • malimccalla

                    malimccalla Space Hobo

                    Yes a quick match
                    • Midnight Tea

                      Midnight Tea Phantasmal Quasar

                      Here's a really odd one a friend and I had last night. A sort of desynch issue.

                      We're both on the steam version. She's newer to this style of game so she wanted to play vs a single computer with a veteran (myself) backing her up. So she picked a 3P map (Pako Valley), made the computer the first player, myself the second player and herself the third. Things... would get weird, based on what we were both seeing. Sometimes it'd look like she was taking forever to take her turn and she'd say she was actually waiting on the computer which was stuck for some reason. I'd leave the game and come back and for whatever reason, the game wouldn't be in the same place, it'd be "back" a round. We'd take our turns again but occasionally we'd both have to leave the game and come back. It'd actually cause Wargroove to softlock and a few times I had to actually hard-close the program and relaunch it. (game wouldn't freeze, just become completely unresponsive)

                      Some real weirdness came at the very end when I dealt the finish blow to the enemy commander. I got the victory screen and left the game. On her end, though, it said I had left the game intead of taking my turn and she had to finish the rest of the match herself against the CPU.

                      I'm not sure what was causing the desynch. Could just be some early weirdness with having CPU players play with two humans or being allowed to have the first turn. She also has a fairly unreliable connection in general, she feels that might've contributed somehow. Either way I wanted to share this odd story. We both won the match in the end, even though on her end it looks like I fell on my sword in the final hour. I'm proud of her for keeping the momentum going. (despite not having ever prior used most of the units in front of her)
                        Last edited: Mar 7, 2019
                      • Hatkat

                        Hatkat Aquatic Astronaut

                        There's a bug associated with Campaign Editor/Playthroughs; if you make two branching paths that both utilize main missions, then during your Playthrough you can get 'softlocked' if you try to navigate between them.

                        exhibit a.PNG

                        exhibit b.PNG

                        As you can see, clicking either of the two available 'main' scenarios will default to the one your 'unit' is at.

                        To remedy this, you must first 'Cancel', then move to the previous mission, and only then you can select either of the two.
                        • ponycordero

                          ponycordero Space Hobo

                          I have this same issue on PC steam. Quickplay matches keep trying to load an old match on my opponent's turn in a game that I thought I surrendered and ended. Game freezes immediately after loading.
                          • Fadedsun

                            Fadedsun Astral Cartographer

                            Is the multiplayer desync issue known and a fix being worked on? We're all trying to watch a tournament stream and the match keeps desyncing and having to be reloaded by the casters. Also, when playing multiplayer, the game will randomly desync and have to be reloaded. All moves will have to be re-input.
                            • AeroMikhail

                              AeroMikhail Void-Bound Voyager

                              I'm playing WarGroove on Switch trying to play a map my friend made (Code: 8JW4GB4J) with 2 others (one is on PC the other is on Switch). This is a 3v1 scenario map that has players against 1 AI.

                              Us Switch players are having issues whenever we click on Barracks and Towers and get an error saying "Invalid Config File" and get booted to the main menu. So far I've been able to troubleshoot that the error is mainly on his map as this does not happen on other maps. The error is not replicated on PC and barracks/towers work fine.

                              My friend does not have any restrictions on the barracks/towers. I'm not sure what it can be.

                              My Nintendo Switch and WarGroove are both updated right now.

                              Any help is appreciated.
                              • malimccalla

                                malimccalla Space Hobo

                                Maybe we were playing each other

                                Yeah its particularly frustrating seeing as online is the only mode I play. It's a game breaking bug for me.

                                Let me know if you find a fix to get it working again
                                • Becks27

                                  Becks27 Space Hobo

                                  No, it wasn't, and I'm 90% sure it wasn't the first time I loaded one as well.
                                  • Hatkat

                                    Hatkat Aquatic Astronaut

                                    Another Cutscene Editor error that was definitely introduced with the most recent patch!

                                    Any cutscene in my campaign that uses Lionblades (Heavensong Swordsmen) gets broken as their shouts and emotes (other than 'Idle') become unavailable:

                                    exhibit 350.PNG

                                    I'm using Steam version, Wargroove's build is 1.2.1 #16532
                                    • ponycordero

                                      ponycordero Space Hobo

                                      My opponent's name was "Glitch" which is kinda funny. If that's your username on wargroove then we were probably playing each other which would be hilarious. I hope their is a fix for it soon because I can't use online multiplayer at all.
                                      • Loafcake

                                        Loafcake Space Hobo

                                        I've got the same issue; I recommend heading over to the Support section in the Official Discord, I was able to get some help from one of the Devs directly, but unfortunately we appear to be in different time zones, so I haven't been able to resolve the issue yet.
                                        • Midnight Tea

                                          Midnight Tea Phantasmal Quasar

                                          Just wanted to follow up this story and say the second game we played, we had no problems. And it was on a map she designed too! (it was definitely a map that had a lot of novice design mistakes but it really touched me how much she liked making it)

                                          Share This Page