[WebApp] Stardew Checkup -- Achievement & Completion Progress

Discussion in 'General Discussion' started by MouseyPounds, Mar 10, 2018.

  1. Marley2011

    Marley2011 Lucky Number 13

    I don't know if I'm doing something wrong, or maybe it's my save file but I play single player and it just ends up not loading anymore then what is in the picture. This is my fist time trying to use this and it hasn't worked for me.
     

      Attached Files:

      otterden likes this.
    • prrprrprrprr

      prrprrprrprr Void-Bound Voyager

      Having the same issue as Marley2011, was working fine from start of game until I unlocked the island. Now it's choking at the same point as shown in their image. Running in Chrome, Game version current with two mods that alter the save serializer (PyTK and TMXL) and a handful of other QOL mods.
       
      • otterden

        otterden Intergalactic Tourist

        I would like to report a bug.
        That when I upload my recent save file, it says "working" with a blue loading stripe but never finished.
        Someone suggested me to use developer tool to check and appear to stuck at the NPC session.
        I triggered a group event that I entered Haley's house and all the ladies were angry at me. I think that might be the cause of it. Some says it will maintain the heart at 10 but they will became "single". If you need, I can upload related files

        Actually the same as Marley2011
         
        • dangerousdoris

          dangerousdoris Orbital Explorer

          I think it's definitely that cutscene that's triggering the bug. I also had the cutscene and couldn't get Stardew Checkup to work. The day the ladies forgave me, it worked again :)
           
          • oogpotlood

            oogpotlood Space Hobo

            I have the same bug. Having some Javascript knowledge myself, I debugged the source. In stardew-checkup.js?v=4.0.3 on lines 1233 and 1235 the source uses npc[who].isDatable to count whether you have any Guys/Girls that you dumped, however it seems it should be meta.npc[who].isDatable as the npc-variable doesn't exist. When you have no dumped_Girls or dumped_Guys the source skips npc-variable (as the numeric check is already false), that's why it is automatically fixed the day the ladies/gentlemen forgive you.

            Edit: also I just noticed on line 1236 in the screenshot it says "nmeta.pc[who]" which I assume has to be "meta.npc[who]" as well

            [​IMG]
             
              Last edited: Mar 27, 2021
            • SeaBrightener

              SeaBrightener Space Hobo

              Update 1.5 spoilers

              Suggestion: Add a tracker for Qi's special orders

              Thanks for all your work!
               
              • kewlresist

                kewlresist Space Hobo

                What is this "mod fish"? I don't use any mods. I have been using this tool since long time and I have never seen this before.
                 

                  Attached Files:

                Share This Page