"You already gave 2 gifts" stuck?

Discussion in 'General Discussion' started by Blaze_Jaganshi, May 15, 2018.

  1. Blaze_Jaganshi

    Blaze_Jaganshi Space Hobo

    So I've put like 30hrs into this game, and I didn't have any problems until now. I updated to the beta version. I'm trying to give gifts to one of the NPCs but it keeps telling me that I already have him 2 gifts this week. Except that it has been at least 3 in-game weeks... It won't change. I'm assuming this is a bug.

    I'm playing on Steam with the latest beta version, in single player mode. I had this farm before beta came out.

    Thanks for any advice :)
    • guitardude_324

      guitardude_324 Big Damn Hero

      I haven't come across this myself in the beta or have seen it reported, I'd recommend posting about this in the support page, just in case the Chucklefish and CA don't see this post. It may just be a bug that needs to be addressed. They're making a lot of headway!
      • Jrminot

        Jrminot Scruffy Nerf-Herder

        I've had it happen where the gift check boxes remained checked across a Sunday. It sorted itself after a week though so my experience wasn't as bad as yours.
        • Clovis_Sangrail

          Clovis_Sangrail Subatomic Cosmonaut

          I am not using the beta version, and I have still had some issues with gift giving.

          First thing in the morning, I tried to give my wife a gift, and I got a message that I had already given her a gift that day.

          And later that day, when I went to Robin's and ran into Maru, I tried to give her a gift, and I got the same message, even though this was the first time I encountered her that day.

          I have never had this problem before, so it makes me wonder if some of that buggy multiplayer 1.3 code didn't make its way into single player. Has there been an update to single player?
          • squigglyruth

            squigglyruth Big Damn Hero

            Sometimes it says that message even though the gifting has worked. I think it happens when you are gifting from a stack. Click to talk to the person and see if they say their thank you message - if they do, the gift has gone to them fine.
            • ambs

              ambs Space Hobo

              ive been stuck with this as a glitch for 3 full seasons
              thankfully someone offered to look at my game file for me though

              it happened for me with lewis and evelyn and haley

              Share This Page