1. Please be advised of a few specific rules and guidelines for this section.

RELEASED Avali Drone Pet 1.2.2

A maintenance drone for an Avali starship

  1. leinglo

    leinglo Phantasmal Quasar

    Honestly the collision probably should've been there to be begin with, so yeah.
     
  2. Sarduka

    Sarduka Void-Bound Voyager

    It seems, this line in the .metadata file > "requires" : ["Avali"], < caused an startup error if you use the Steam version of the Avali mod.
     
    Last edited: Aug 20, 2016
  3. Ulithium_Dragon

    Ulithium_Dragon Cosmic Narwhal

    Yeah, I noticed this as well. The version from the Steam Workshop must either use a different name string, or it's just another of those rather dumb issues that are springing up when you try to use a mix of both Steam Workshop and manually installed mods - causes the load order to screw up and often times it errors out and CTD's because it tried to load the child mod before the parent mod that it relies on.

    For the record, I fixed this issue myself by simply installing the version of the Avali Race mod from this site manually instead. Since the Steam Workshop gets "overwritesies" when it comes to mods, I believe in this case it just caused the error to STFU, since everything else seems to work fine even though I now technically have two identical copies of the same mod installed lol.

    Still, it would be nice if you could fix this issue before the Avali Race updates, since I don't know if the above will hold true if the two versions of the mod are not identical. :]

    ___________________________________________
    EDIT: Actually I've honestly been noticing A LOT of errors related to out of order loading since the 1.0 update, and not necessarily just between manual and Steam Workshop.

    I realized that the dependency line really doesn't seem to be required anymore, since I forgot to put the "Avali" dependency into my "Avali Rocket Launchers + Misc" mod when it was uploaded to the Steam Workshop and moved from using a .modinfo file to a _metadata file.

    So I would remove the dependency line - apparently it's not necessary anymore?
     
  4. Sarduka

    Sarduka Void-Bound Voyager

    Well, I removed this line from the .metadata file and it seems to work (at least for me). So, I guess that this is really not necessary anymore.
     
  5. Ulithium_Dragon

    Ulithium_Dragon Cosmic Narwhal

    I mean, the mod would probably still CTD without the parent mod (as it would try to look for assets that were not there), and obviously wouldn't work right without it, but yeah - apparently "declaring" the dependencies is no longer necessary I guess.

    Woulda been nice if Chucklefish had mentioned this, as it seems like a pretty damn important detail (but then they rarely release any documentation on the changes for their updates...).
     
  6. leinglo

    leinglo Phantasmal Quasar

    Requiring the dependency, well, depends. It's unclear how the load order is normally determined, and sometimes you do get lucky and things will load in the right order without being told. Other times, you need a declared dependency, either with "includes" or "required," to make sure that one takes priority over another.
    I'll make a quick update by adding Avali to the "includes" section instead, though if the Workshop Avali version isn't being recognized by "requires" then the "includes" dependency may not work either, even if it doesn't crash, as I've heard the load order normally has Workshop mods take priority over anything non-Workshop. That would mean with the Purchasable Pets version, the drone dock may not function as a pet house, as the Workshop Purchasable Pets petbehavior.lua would take priority. With the vanilla version the drone may not spawn at all as it edits the Avali mod's techstation file to declare the drone as the spawned ship pet instead of a cat, and if the Workshop version takes priority....
    upload_2016-8-20_19-59-36.png
    (sigh) I am really beginning to hate Steam Workshop.
     
  7. leinglo

    leinglo Phantasmal Quasar

  8. Ulithium_Dragon

    Ulithium_Dragon Cosmic Narwhal

    One more thing @leinglo:

    I was having issues with people reporting my Job Offers patch to my Hunter Crewmembers mod causing a similar issue, and one of the things I tried that may(?) have helped was I added this line to the mod that must be loaded first:
    Code:
    "priority" : 90,
    
    This was something suggested to me from a comment on the workshop. I don't know if it helped or not, nor do I know what the default priority value is, but it still may be worth looking at.

    That being said, from everything I've read and seen it DOES look like workshop mods are ALWAYS loaded first, and will overwrite non-workshop mods of the same name. :L
     
  9. leinglo

    leinglo Phantasmal Quasar

    I just broke down and finally uploaded it to the workshop. Not happy about it, but I did it. That should solve any issues
     
  10. Ulithium_Dragon

    Ulithium_Dragon Cosmic Narwhal

    The way that the Steam Workshop handles mods isn't great, but there are A LOT of worse games that use it for mod management (worst I can think of is Skyrim lmfao).

    I tossed mine on there simply because a lot more people will see them there, and I share my mods because I want other people to enjoy them (otherwise I wouldn't share them lol).

    I'm honestly surprised at the statistics of my "Avali Rocket Launcher + Misc Stuff" mod on the Steam Workshop - over 2/3 of the people who viewed the mod actually downloaded it, which is just a STAGGERINGLY high percentage ffs lol.
     
  11. leinglo

    leinglo Phantasmal Quasar

    For just a casual mod user, I'm sure the workshop is more convenient. Just click subscribe and go. But for a mod creator, someone who likes open up and work with mods and communicate with the community, the forums are sooo much better. The only advantage the workshop might have in an overall sup-par experience is, as you said, distribution and exposure.
     
  12. Ulithium_Dragon

    Ulithium_Dragon Cosmic Narwhal

    Agreed. Those are all the same points I was trying to make - I still prefer the forums, but I can see why many would prefer the workshop as well.
     
  13. leinglo

    leinglo Phantasmal Quasar

    ATTENTION: The mod has been updated for 1.1.1, but unfortunately, you'll have to get it at the Workshop for now, as the forums won't let me upload the updated .zip for some reason.
     
  14. leinglo

    leinglo Phantasmal Quasar

  15. Sergun169

    Sergun169 Void-Bound Voyager

    Is this mod is outdated? Drone is not spawning on board when i create new avali character. It does not spawning when i place down avali drone dock.
     
  16. valavaern

    valavaern Scruffy Nerf-Herder

    Having the same problem as Sergun, using purchasable pets and the correct drone mod, and no drone spawns when I put the dock out. :(
     
  17. TylorBane

    TylorBane Void-Bound Voyager

    yeah, bugged for me too, something about starving.lua in my starbound.log

    [07:41:52.300] [Warn] Could not spawn Monster of type 'avalidronepet', exception caught: (AssetException) Error loading asset /monsters/pets/actions/starvingAction.lua
    [07:41:52.317] [Error] Exception while invoking lua function 'update'. (LuaException) Error code 2, [string "/objects/spawner/techstation.lua"]:80: (LuaConversionException) Error converting LuaValue to type 'int'
    [0] 7ff65d158ce3
    [1] 7ff65d157a6e
    [2] 7ff65d12228b
    [3] 7ff65d11d5f6
    [4] 7ff65d30e7f7
    [5] 7ff65d3371f6
    [6] 7ff65d7d290c
    [7] 7ff65d79d22f
    [8] 7ff65d7b19c0
    [9] 7ff65d7a5009
    [10] 7ff65d7d911b
    [11] 7ff65d125e3d
    [12] 7ff65d124dcf
    [13] 7ff65d0ae888
    [14] 7ff65d0c7631
    [15] 7ff65d0ae393
    [16] 7ff65d0aeb6b
    [17] 7ff65d0ae5a0
    [18] 7ff65d0a4ab4
    [19] 7ff65d12cf70
    [20] 7ff65d30876e
    [21] 7ff65d30be15
    [22] 7ff65d30bd30
    [23] 7ff65d312abc
    [24] 7ff65d3ec06e
    [25] 7ff65d68e01e
    [26] 7ff65d29b167
    [27] 7ff65d6b1524
    [28] 7ff65d6b7916
    [29] 7ff65d6b7298
    [30] 7ff65d1550fe
    [31] 7ffb9a0913d2 BaseThreadInitThunk
    [32] 7ffb9c735454 RtlUserThreadStart
    stack traceback:
    [C]: in ?
    [C]: in field 'callScriptedEntity'
    [string "/objects/spawner/techstation.lua"]:80: in function <[string "/objects/spawner/techstation.lua"]:72>
    [0] 7ff65d158ce3
    [1] 7ff65d157a6e
    [2] 7ff65d12bb01
    [3] 7ff65d308787
    [4] 7ff65d30be15
    [5] 7ff65d30bd30
    [6] 7ff65d312abc
    [7] 7ff65d3ec06e
    [8] 7ff65d68e01e
    [9] 7ff65d29b167
    [10] 7ff65d6b1524
    [11] 7ff65d6b7916
    [12] 7ff65d6b7298
    [13] 7ff65d1550fe
    [14] 7ffb9a0913d2 BaseThreadInitThunk
    [15] 7ffb9c735454 RtlUserThreadStart
     
  18. Seby88

    Seby88 Void-Bound Voyager

    So, i have a problem with the dock , it crashes my game every time i place it
     

Share This Page