Modding Help Custom tilesets [CLOSED]

Discussion in 'Starbound Modding' started by Marladian, Oct 7, 2020.

  1. Marladian

    Marladian Orbital Explorer

    Hi everyone!
    So I’m pretty new to Starbound modding and I’m working on this mod that brings some fun decoration objects into the world. I had no problem bringing them into the game, but I also want my custom modded objects to appear in dungeons. So naturally, I copied vanilla dungeon from the unpacked folder and modified it using the Tiled software, which I had previously used to make a custom tileset with my modded objects. All of the modded objects are based on some vanilla objects and therefore, sizes, offsets, etc. should be fine. I even managed to acces this tileset, while editing the dungeon. When I tested, whether there are any changes in the game, I found out that my modded objects don’t appear in the dungeon, but when I tried the same with vanilla objects, it worked. When I checked the game log, there wasn’t any mention of my custom objects not being able to load, or anything. And just for the record, I didn’t forget to add the “object” parameter to the tiles. I couldn’t find help anywhere, so I really hope, someone here could help me with that...
  2. Marladian

    Marladian Orbital Explorer

    Never mind, I figured it out, the problem was that I was trying to access an image, that was not located in the mod folder
  3. KneszY

    KneszY Intergalactic Tourist

    could you explain how to fix this problem? idk what I am missing @A@
    I created tiled folder for keep object img in mod folder , adding object parameter, make tilesets folder for storge tilesets from Tiled in mod folder but objects in tilesets still not show up in my custom microdungeon.
  4. KneszY

    KneszY Intergalactic Tourist

    never mind, it had been fixed.They don't show up because I used Tiled ver1.9 which have different .json structure in tileset file. lol
  5. rl.starbound

    rl.starbound Phantasmal Quasar

    FYI, the last Tiled version used by Starbound devs seems to be 1.2.2, so you probably ought to use that version, or a similarly old version, when making Starbound mods. I have noticed a number of incompatibilities with newer versions of Tiled, the biggest being, as you noticed, the tileset JSON format has changed.

Share This Page