Modding Help Do's and Don'ts of reporting issues with SMAPI mods

Discussion in 'Mods' started by Entoarox, Oct 5, 2016.

  1. TerrorFox12345

    TerrorFox12345 Space Spelunker

    This seems to be the place to come for help with SMAPI crash logs and the like. I will try to be as detailed as possible.

    First off, this is a multiplayer game, and the host PC doesn't seem to be running into any errors (I will have to double check the SMAPI log on it when I get home later.) The issue is happening on my laptop, which my wife uses to play on her account at home. With that said, I am aware that I can pull "Automate" out of her Mods folder, as she is the guest and doesn't need it installed. Any errors/warnings related to Automate, I'm not terribly concerned with. Easy fix.

    I notice a few other issues in her crash log though;
    1. Deep Woods seems to be occasionally spamming the console with blank warp coordinates. We haven't even accessed the Deep Woods yet. Is this normal?
    2. HealthBars by Zoryn seems to have an issue. I might mess with the config to see if I can fix, but maybe someone who knows more can tell me if that's even worth my time. It seems to be the same issue every time. Got the mod here: https://github.com/Zoryn4163/SMAPI-Mods/releases/tag/2.7.1 (per the SMAPI compatibility list, which says this mod is ok to use).
    3. Entoarox Framework is tossing an error about not being able to save bc this isn't the main player. My wife still needs Entoarox Framework installed for Extended Minecarts. How to solve?
    4. Content Patcher is dropping a variety of errors related to Eemies Victorian Buildings, Morgrim's Raptor Chickens, and Cuter Fatter Pigs.
    5. SMAPI; pretty much the whole last chunk of the log is a smattering of SMAPI errors which eventually led to the game freezing and crashing.

    Here is the log: https://log.smapi.io/JGJGF9js

    Thanks for any insight and help that can be given towards resolving these issues.
     
    • Entoarox

      Entoarox Oxygen Tank

      The issue boils down to the fact that Content Patcher is expecting certain textures to be loaded, but for whatever reason they are not.
      This caused the patching process to fail with an error, which meant the farm map was only partially patched, and so when SDV tried to render it, the draw loop kept crashing in a way SMAPI cannot repair.
      Eventually SMAPI decided the error would not be resolved, and so initiated a critical shutdown.

      The real problem is, is that I know of no reason why the textures would have been disposed like that in the first place! :S
       
      • Pathoschild

        Pathoschild Cosmos Killer

        Yep. Not sure why it does that, but I've seen it with other players too.

        There seems to be some invalid location data in the game, but we'd need to run some tests to know more. Let me know if it still happens after we fix the other errors, and we can look into that one separately.

        You can probably ignore that one; it's trying to save custom objects, but Extended Minecarts doesn't use Entoarox Framework's custom objects API.

        The errors happened right after a window resize. The game is pretty sensitive to graphics changes; make sure you don't resize the window while it's loading, and when moving the window to another monitor make sure you release the window onto the second screen, then resize the window separately. Do the errors still happen if you do that?
         
        • TerrorFox12345

          TerrorFox12345 Space Spelunker

          Thanks (to you too Entoarox)

          re: Deep Woods - good to know. I won't worry about it.
          re: HealthBars - I've swapped it out for Enemy Health Bars, as that seems to have been updated. I'd be happy to check on HealthBars again for you though. Let me know if/when you need me to reinstall it.
          re: Extended Minecart - I've actually realized that Extended Minecart only works for the host in MP. I've pulled that out, as it wasn't essential. I also managed to pull out Entoarox Framework with ruining the save, so I think for now I'll just leave that as is. If EM gets that multiplayer update I'll come back to it.
          re: ContentPatcher - I wonder if this is a result of using a zoom mod. I can't remember the name off the top of my head, and I'm not home, but I know it's the one that shows up as all clear on the SMAPI compatibility list. We also pulled out Morgrim's Chicken Raptors as that had the most errors (and also some lines about changing Shane's portrait?).

          After pulling out Extended Minecart, Entoarox Framework, and Chicken Raptors and exchanged Zoryns HealthBars for Enemy Health Bars, we played again for awhile and the log shows no errors. Thanks for the insight on ContentPatcher (and all the mods, really)!
           
          • moou22

            moou22 Void-Bound Voyager

            Another break at save time: https://log.smapi.io/kzCFy2u4

            This time, I deleted most of the old mods, hoping it had been the free dusty one that was the problem, but no dice. All I did was go to sleep for the day after a seemingly normal day. What happens more specifically is, it goes to the end of day stuff, skips it quickly, including skipping save, then I'm frozen in bed the next morning while time zooms on in quick succession.

            This seems to be the only type of break I get anymore lol
            TIA!!
             
            • TerrorFox12345

              TerrorFox12345 Space Spelunker

              Just noticed I forgot to respond to this particular piece. I will have to keep an eye on it over the next week or so and report back on findings. Perhaps, during some troubleshooting, when I was resizing the window from windowed borderless to windowed and back. Perhaps when zooming in/out happens (though I would imagine more reports if this were the case). Thanks again. :)
               
              • chirex

                chirex Void-Bound Voyager

                Hello, hopefully, there could be someone to provide some help.
                I am playing in a multiplayer game and the game seems to be crashing when trying to save with the other player. I tried running the game both in multiplayer without the person joining and also in singleplayer and was able to save the day just fine it seems to be a multiplayer issue. I rearranged mods and verified the game files and it continued to have the same issues. The only time it did not crash was when I ran the game through the .exe instead of smapi. We have reached Spring Day 4 of the second year without issues.

                This is the Error Log: https://log.smapi.io/f3dhrbH0

                I know that the seasonal villager outfits is all crazy I took out some of the portraits as I had a replacement for them but this was not the cause (that I know of).
                Aside from all the troubleshooting, both parties reinstalled all the mods that would need to be synced for multiplayer and even made new games and it's only this save file.

                Any help would be much appreciated as this is the farthest either of us has come and we're really enjoying the game thus far.
                 
                • Entoarox

                  Entoarox Oxygen Tank

                  The error is happening during the attempt to warp a character, do you by chance have any custom NPC's installed?
                   
                  • chirex

                    chirex Void-Bound Voyager

                    Nope, no custom NPC's are installed.
                     
                    • chirex

                      chirex Void-Bound Voyager

                      Found the issue. Error occured after adding the Polygamy and bwdyworks mods. After removing those two in particular and leaving the other mods alone it is now working and saving correctly. Its just weird though since the crashing happened before those two mods were added.
                       
                      • deeya.kaur

                        deeya.kaur Orbital Explorer

                        Smapi Log: https://log.smapi.io/Ms5j7Rgm
                        Im not sure if it's a mod error but I think it has something to do with my UI mod.
                        When i place down a scarecrow, or previously placed scarecrows are in my view, the rang highlight around them is completely red. It started after I looked up Lewis' favourite gifts with one of my other mods. When i break a scare crow and go to place it once again the range highlight is green as usual, but once placed it appears as an ugly red and doesn't go away.
                        I left the map a few times and came back to the same ugly red circle around my scare crows, i tried turning off my sprinkler and scarecrow range highlight but it doesn't do anything.
                         
                        • robingolle

                          robingolle Void-Bound Voyager

                          Hello there,

                          when i want to plant a seed next to my farmer, the cursor disappears and if i dont move it away in like half a second my game crashes.
                          Both Bigger Backpack and Artisan Valley Machine Goods are up to date but are indicated out of date. I read somewhere that should be because of a wrong
                          i have no idea what could cause the problem

                          Here is the SMAPI Log: https://log.smapi.io/4YSyQFNh

                          I found out which mod causes the problems, its artisan valley machine goods
                           
                            Last edited: May 22, 2019
                          • Breesama

                            Breesama Aquatic Astronaut


                            Hello!

                            I've been trying to figure out what is causing this error. Sometimes when I go to sleep, the game will crash on me and produce this error. I think it may be related to something that I put into the Shipping bin the previous day, but so far I'm having trouble pinpointing what's causing the issue.

                            Any help with this would be greatly appreciated!

                            Thanks in advanced!
                             
                            • jahangmar

                              jahangmar Starship Captain

                              The issue seems to be an item in the shipping bin and it's related to "Custom Farming Redux" or "Artisan Valley". That's what I get from the SMAPI log.
                               
                              • CreamAnmitsu

                                CreamAnmitsu Void-Bound Voyager

                                Before deleting duplicate save files: https://log.smapi.io/Jjdg9ePg
                                After deleting duplicate save files: https://log.smapi.io/KJ01ywzx

                                Hello! This is my first run-in with game crashes. I have a few suspicions, but after a string of attempts at self-troubleshooting, I am no longer sure of what specific things I did that was the main cause... or probably everything I did was incorrect orz

                                I used FlashShifter's Stardew Valley Expanded mod, which relies on EntoaroxFramework and TMXLoader. A few days ago these two mods needed to update, and so I did, but perhaps in a not so kosher way by deleting their old files entirely and dragging in the new files (very dumb of me now I realized after rereading how to update mods on wiki). I then also had to update SVE itself. The game was able to load fine to my knowledge, and I played almost 1 in-game day when suddenly the game crashed as I was heading to sleep. The next time I loaded up the game, I noticed that ContentPatcher needed updating. I did and tried again. The load menu showed that I have 2 duplicate saved files for some reason. My dumb self decided to delete one of them, and not too surprisingly, that ended up deleting my save file entirely. I attempted to retrieve the save file following the prescribed methods here: https://stardewvalleywiki.com/Saves#Find_your_save_files but my game still shows no saved files ((; v ;))

                                Any help would be much appreciated, and I would like to say thank you to all the wonderful modders in advance for creating and helping with troubleshooting \((q w q))/
                                 
                                • Ginger256

                                  Ginger256 Void-Bound Voyager

                                  SMAPI log: https://log.smapi.io/mUiedfDh

                                  I haven't played in a while, so it's entirely possible this will just be something simple - if so, very sorry.

                                  So at first, I had an issue where planting one type of seed (e.i. Rice) resulted in a different crop (e.i. Girl Scout Cookies). In an attempt to fix this, I selectively updated my JA crop mods - and Artison Valley Machine Goods when I realized I was missing some produces. Now, in both an old save and a new one, if I hold anything in hand/get my cursor too close to my player for more than a few seconds, my game crashes.

                                  Any and all help would be very much loved!
                                   
                                  • Entoarox

                                    Entoarox Oxygen Tank

                                    Please reinstall your mods from scratch, you have a ton of outdated and duplicate mods which are resulting in a unstable game, this means that bugs may happen that normally would not.
                                     
                                    • lannihamm

                                      lannihamm Big Damn Hero

                                    • Pathoschild

                                      Pathoschild Cosmos Killer

                                      lannihamm likes this.
                                    • uyrl2

                                      uyrl2 Orbital Explorer

                                      Nice to meet you. I'm posting it using the translation feature, so it may be a strange sentence, but still thank you for reading.

                                      I would like to play with "Immersive Farm 2" and "Eemie's Map Recolour For CP" in "Stardew Valley Expanded".
                                      Before applying the June 23 update, I was able to introduce and play on my own.
                                      However, I tried to apply the update but it didn't work.

                                      I overwrote a mod that needs updating, but it didn't work, so I left the MODS folder empty and tried to reintroduce everything from the beginning, but it was not good.

                                      Specifically, "Eemie's Map Recolour For CP" is reflected.
                                      If you look at a building or object, you will also get a properly added message.
                                      But when you start it you get an error message.
                                      There is no way to go from the bus stop to the back mountain, and there are many areas where changes can not be made, such as being unable to go west from the shore.

                                      Please help me by all means.

                                      https://log.smapi.io/aEf6e9nn
                                       

                                      Share This Page