1. Welcome to the Starbound support forums. Please check the support FAQs before posting: http://playstarbound.com/support

Bug/Issue "Exception caught in client main-loop (EofException)"

Discussion in 'Starbound Support' started by Bufftista, Jun 16, 2017.

  1. Bufftista

    Bufftista Big Damn Hero

    Hello Starbound community, I've come across a repeating error in Starbound that prevents me from playing as the character I've created. When I try to boot up the game and load up my character, a message that displays the words "Exception caught in client main-loop (EofException) Failed to read full buffer in readFull, eof reached." appears on screen. Can someone give me instructions on how to fix this without having to erase my character? Here's a list of mods so you guys can help pinpoint the problem more accurately:
    -Xbawks Character Extender;
    -Manipulated UI;
    -Weapon Stats;
    -Inventory Interface Redone;
    -Increase max stack size;
    -Larger Lockers;
    -Matter Manipulator Manipulator;
    -Container UI tweak;
    -Purchasable Pets;
    -Frackin' Universe;
    -Avali (Triage) Race Mod;
    -Wardrobe Interface;
    -Improved Containers;
    -Big Locker and storage;
    -Portable Storage;
    -Food Stack;
    -Ningen Race Mod ver 1.8;
    -Frackin' Breathing
    -Frackin' Music;
    -Slime Race Mod (outdated);
    -Elunite Race;
    -Extended GUI;
    -Familiars Race;
    -Ninjas Play Free;
    -Frackin' Races
    Once again, if any of you know how to fix this, please let me know. Nonetheless, thank you for taking the time to read this thread.
  2. thetraindoctor

    thetraindoctor Orbital Explorer

    Backup your characters in your storage folder, both the universe and player folders. Then uninstall all mods and test mods installed one by one to see what causes the problem. Please also attach a log file and provide this information,


    What to include in your report
    When reporting bugs to us, including a few bits of extra information can help a lot. Try to include:
    • What happened? Did the game crash, freeze / lock up, or just do something wrong (e.g. monster dropped unexpected item)? What did you expect to happen here?
    • What were you doing in the game at the time? (e.g. killing a Poptop, accepting a quest from a colonist)
    • Whether you were able to trigger the bug again by repeating what you did.
    • Your operating system name and version.
    • Are you using any mods? If so, which ones?
    • Whether you're in full screen or windowed mode.
    • If the game crashed, attach (or link) your error logs. These can be found in
      • Windows – Steam/SteamApps/common/Starbound/starbound.log
      • Mac – /Users/USER/Library/Application Support/Steam/*/Starbound.app/Contents/MacOS/starbound/storage/
      • Linux ~/.local/share/Steam/SteamApps/common/Starbound/storage/starbound.log
    Last edited: Jun 17, 2017
    Bufftista likes this.
  3. Bufftista

    Bufftista Big Damn Hero

    Alright, I've already attached the log, I'll do the other stuff as well. In the meantime, please take a look at the log and tell me what the problem is if you can.

    Attached Files:

  4. thetraindoctor

    thetraindoctor Orbital Explorer

    Thanks man. I'll take a look. I'll edit this reply with anything I can find that would be of use.

    EDIT: [00:41:53.900] [Error] Could not load recipe /recipes/weapons/oldtier/broadsword/odb2tier2broadsword_c2.recipe: (ItemException) No such item 'steelbar'
    This is the only error I could find in the log you provided, I couldn't find anything along the lines of the error named in the title of your post. If possible please attempt to reproduce the error and post the logs for the attempted reproduction.
    Last edited: Jun 17, 2017
    Bufftista likes this.
  5. Bufftista

    Bufftista Big Damn Hero

    Hey, I've tried uninstalling the mods and re-starting the game, but instead it just keeps crashing. I can't even get to the screen where the Chucklefish mascot appears and giggles. It just opens up a black window with a small white square and then crashes. If I re-install the mods it works again. Any ideas?

    EDIT: Nevermind the previous paragraph, I've found the mod that is giving me trouble. It's the "Manipulated UI" mod. If I uninstall that mod and reboot the game it crashes. Tried with Xbawks and it didn't crash. What should I do?
    Last edited: Jun 17, 2017
  6. thetraindoctor

    thetraindoctor Orbital Explorer

    I believe one of those mods is needed by one of the others. Not sure about which one though.
    Bufftista likes this.
  7. Bufftista

    Bufftista Big Damn Hero

    So, just to get this straight, how should I proceed about finding the mod? Should I just keep deleting the "Manipulated UI" mod and another and see which one has the game work correctly? I'm sorry to be such a nuisance, I just want to make sure everything is right.
  8. lazarus78

    lazarus78 The Waste of Time

    Yes, that is basically the only way to troubleshoot issues like this.

Share This Page