1. Welcome to the Starbound support forums. Please check the support FAQs before posting: http://playstarbound.com/support

Gamepass starbound will not start

Discussion in 'Starbound Support' started by drakosoldier298, Dec 11, 2020.

  1. drakosoldier298

    drakosoldier298 Void-Bound Voyager

    I recently got the game on gamepass and it wont start, I have tried multiple times.

    windows 10, 64 bit
    I cant find the error log on the gamepass version.

    it did however give an error I cannot copy it so here's a screenshot


    i see what the cause is after looking. my documents folder is on my d: drive I have no idea what to do to fix this issue however

    Update 3

    for those wondering how to fix this issue go to your c drive click users then the user you're on then create a folder named Documents, make sure its a capital d.
    Last edited by a moderator: Dec 12, 2020
  2. Saxhleeel

    Saxhleeel Space Hobo

    So i tried this and it hasn't worked. I have the exact same error message but when I created the documents folder It was already there, it asks me to merge the two I can't have 2 folders with the same name and it wont find the one already there.
    Does anyone have any ideas to help me?
  3. Iris Blanche

    Iris Blanche Pudding Paradox Forum Moderator

    If the documents folder is already present it might be that starbound has insuffiecient rights to create it's folders. The only workaround might be adjusting the security settings of the folder (tho not recommended at all) or launching the game as admin (if that is possible).
  4. Saxhleeel

    Saxhleeel Space Hobo

    I have also tried both of those things, I also tried isntalling it all to the same drive which hasnt worked. And I've tried creating a starbound folder for it in the documents folder, but it says that its just unable to open it. The game has full permission like all the others do from gamespass too
  5. Iris Blanche

    Iris Blanche Pudding Paradox Forum Moderator

    Hm that's weird. I gonna try getting my hands on the gamepass version so i can dig a bit deeper into it. :)
  6. Saxhleeel

    Saxhleeel Space Hobo

    Thats much appreciated, thank you
  7. Iris Blanche

    Iris Blanche Pudding Paradox Forum Moderator

    Free gamepass stuff through discord is funsies hehe

    Anyways, i downloaded it and it runs fine for me. Do you receive an error message upon start? If yes can you provide it? :)
  8. Saxhleeel

    Saxhleeel Space Hobo

    Its the exact same error message in the screenshot here, when I create a Starbound folder for it in the Documents folder It changes from "Could not create directory" to "Could not open file" but otherwise is the same.
  9. Iris Blanche

    Iris Blanche Pudding Paradox Forum Moderator

    Sounds like Starbound has reading access but not writing access. It might be worth a try to set full access for "everyone" on the starbound folder. Maybe Windows' UAC is interfering with it.

    i mean the starbound folder in the documents folder.
  10. Saxhleeel

    Saxhleeel Space Hobo

    Is that under properties?
    Under attributes it has read only, I disabled that.
    And under the security tab everyone already has full control access.

    Under the "give access to" on the right click menu it also already has full access to everyone. I am still getting the same error message with all that done.
  11. Iris Blanche

    Iris Blanche Pudding Paradox Forum Moderator

    For me under advanced security settings (Properties > Security > Advanced) it says the owner of the folder is myself. The users "System", "Administrators" and i for myself have full access. On my system UAC is disabled, tho it shouldn't matter for the own user folder.
    The account I am logged in as is an adminstrator account. I don't know if there's a difference to a "normal" user account tho there shouldn't be.

    Unfortunately i can't offer that much help on that particular issue since I am not able to reproduce it. :c
  12. Saxhleeel

    Saxhleeel Space Hobo

    ahh Okay, Mine are all the same and I am also the admin of my pc... perhaps the issue is gamespass related rather than starbound related, I will keep searching.

    No worries, I appreciate you going through all that effort on my behalf anyways! :)
  13. Iris Blanche

    Iris Blanche Pudding Paradox Forum Moderator

    It's fine. I finally had a use for that gamepass thingy from discord.X3

    I gonna keep a look too, maybe there's something I oversaw when it comes to permission stuff on Win 10.
  14. robtinbc

    robtinbc Space Hobo

    On the PC Game Pass it still does not work, I think its looking for a folder on C: to create temp files in but I deliberately dont have my Users folder on C:. I have been playing with the paths in the MicrosoftGame.config and SBInit.config files to try and figure out the issue.

    Looking in your FAQ it talks about an error log but it seems to be giving information only for Steam users.

    my sbinit.config file is:

    "assetDirectories" : [
    "storageDirectory" : "G:\Documents\Starbound\",
    "assetsSettings" : {
    "pathIgnore" : [],
    "digestIgnore" : [
    "defaultConfiguration" : {
    "allowAdminCommandsFromAnyone" : true,
    "anonymousConnectionsAreAdmin" : true,
    "gameServerBind" : "*",
    "queryServerBind" : "*",
    "rconServerBind" : "*"

    I created those folders and its still not working.

    Please help us PC Game Pass users plat this game, I pay for gamepass I dont want to pay on Steam as well for something i should be able to enjoy on a service I already pay for.
  15. Iris Blanche

    Iris Blanche Pudding Paradox Forum Moderator

    Can you provide a screenshot of the error message per chance? I assume its the same read/write access problem that OP had. I dont have access to gamepass atm but the error message could be enough to work with.
  16. Holmez

    Holmez Space Hobo

    I'm so happy I stumbled across this it wasn't just me in the dark and Friend Now not so long ago about a couple of months I was able to play the game It was after the last update That caused this problem I'm someone who spent nearly 300 hours on pc game pass Is Now Playing on the steam version Kind of annoyed Because I really wanted to get back into it on xbox game pass for pc I do believe it's a problem on their Later up dat end cause I've got other friends saying the same So we do have to wait for an update To fix this But it would be nice If there was a confirm on this problem Waste of time trying anything else as The results are the same I didn't want To be able not to play it agen on game pass pc :( 16859204277836547918697542269114.jpg
  17. Iris Blanche

    Iris Blanche Pudding Paradox Forum Moderator

    Permission error probably caused by Windows/Gamepass itself. Try creating the folder "Starbound" in your Documents folder yourself and set permissions to Read/Write for "everyone". This *should* fix the issue.
  18. Holmez

    Holmez Space Hobo

    Tried that one When the problem started. buddy doesn't work Do you know if you would roll out a fix for game pass
  19. Iris Blanche

    Iris Blanche Pudding Paradox Forum Moderator

    I am "only" a volunteer forum moderator so all I can do is to relay it to Chucklefish. Due to waiting for the external company and the console port things are basically on halt regarding Starbound atm so chances are low that this will be a priority.
    Also the question is if all Gamepass users are affected or only a few, depending on their setup. E.g. for me Gamepass has been working flawless so it might be some windows stuff interfering with permissions in which case either the Microsoft store or the OS itself would be at fault. According to the error message that pops up it appears that Starbound fails to write to your private documents folder which should be accessible in this case unless the Store/Gamepass thing starts the game with different credentials but still reads out your folder.
    But yea, as mentioned above, I can relay it to Chucklefish nontheless but I can't promise anything.
  20. Haso

    Haso Space Hobo

    I'm also on gamepass but I'm not experiencing the same issue,basically when im launching the game i get this error and i've tried compatibility set on windows 7 and also running as administrator but no help: upload_2023-7-25_19-32-47.png
  21. RandomUser2000

    RandomUser2000 Space Hobo

    I found a fix (idk if this will work for anyone else)

    Go to (Your user name) Documents then find the starbound file in there and delete it then just relaunch starbound
    If this doesn't work I'm sorry

Share This Page