1. Please be advised of a few specific rules and guidelines for this section.

RELEASED PenGUIn - Starbound Server GUI

Discussion in 'User Interface' started by Senerio, Jul 22, 2016.

  1. Senerio

    Senerio Pangalactic Porcupine

    Send me the file at this location :

    After that you can try to delete it and retry.
  2. TGRaiden

    TGRaiden Intergalactic Tourist

    That worked. PenGUIn loaded up just like new.
  3. Senerio

    Senerio Pangalactic Porcupine

    You're welcome. Your file was totally broken for some reason. *shrug*
  4. dansalvato

    dansalvato Intergalactic Tourist

    I saw that another user had reported an issue with the GUI becoming unresponsive when they lock their computer. While this doesn't happen to me, today I connected to my PC via a remote TeamViewer session and experienced the same GUI lock-up. From the moment I started the remote session (and even after ending it), the GUI would not accept any mouse inputs anywhere, including in the title bar (eg. the window could not be dragged around). Strangely, Windows never detected the program as "Not Responding", either. The server continues to run while the GUI is locked up, but all visual elements in the GUI stop updating - the log and uptime do not advance, and the penguin sprite stops walking.

    When selecting "End Task" in the Windows Task Manager, I believe the GUI briefly unfroze for a short moment before being force quit.

    That's all the information I have on this issue - I hope it may provide some insight.

    Edit: I experienced another GUI lock-up after leaving my PC locked overnight (no TeamViewer involved this time). But I have some new information.

    If I right-click the program icon in the taskbar and select "Close Window", then the GUI gives me the dialog box "The server is still running. Do you want to stop it and exit?" While this dialog box is open, the GUI once again becomes responsive and the penguin starts walking (although it can't accept any inputs since the dialog box steals focus). If I click "No" on the dialog box, the dialog box goes away and the GUI becomes unresponsive again. Strange, right?
    Last edited: Nov 19, 2019
  5. Senerio

    Senerio Pangalactic Porcupine

    Thanks for the detailed report. It is very strange indeed. I've never had that behavior happen in any other of my apps ever so once again I'm a bit clueless as to what's causing it. I'll give it another shot, maybe I'll stumble upon something.
  6. lucaspec72

    lucaspec72 Big Damn Hero

    Hey, for some odd reason the server executes the task for when a player connects when i just warp to somewhere else like for example from a planet to my ship... =|
  7. Senerio

    Senerio Pangalactic Porcupine

    I tried it and I'm not getting that problem. I'll need more info than that. What are your tasks like?
  8. lucaspec72

    lucaspec72 Big Damn Hero

    i've got two, the first one is a basic welcome message "say ^white;Bienvenue ^yellow;&player_name^white;, il y a ^orange;&count_players^blanc; joueur(s) en ligne en ce moment." (the colors are bugged when it creates a new line in the chat but that's not important) The second one is basicly the same thing, but it's just to tell when a admin connected. it's something in the lines of "say /!\ Attention, un admin vient d'arriver /!\" but i don't remember exactly. I also tested a bit and it only seems to happen when i warp to my ship, not when warping to the outpost or a planet. a last thing to point out would be that penGUIn seems to crash when using any remote control tool like AnyDesk or Teamviewer like some people already pointed out...

    So the task bug seems to only occur with some characters, strange... i'm gonna experiment a bit and try to find the reason it bugs. that crash when using remote control programs are also annoying =(
    Last edited: Dec 15, 2019
  9. Senerio

    Senerio Pangalactic Porcupine

    I'm sorry. That will never happen.:nuruhype:
  10. Jaye_Glenn

    Jaye_Glenn Intergalactic Tourist

    PenGUIn looks amazing, but I haven't gotten as much use out of it as I wanted yet. I successfully set up and started a local Frackin' Universe (and other mods) server, and was even able to connect to it and play on it with an instance of the game running on the same machine. But when I tried to connect a different device to the server, I get nothing. Not even a logged error on the server's end. Just an error on the other device about networkissue, can't connect, etc.
    Please note that both the server host and the other machine are on the same wifi network.
    I am using default configuration for PenGUIn
    I have checked that the mods are all synced up.
    I have tried both the IP address provided by PenGUIn and the usual, both with and without port 21025.

    If you need any logs, just ask. Any help would be much appreciated!
  11. Senerio

    Senerio Pangalactic Porcupine

    I don't think PenGUIn has anything to do with that. You could start the server without PenGUIn and you'd likely get the same issue. In most cases, it's all about port forwarding and I only know how to properly port forward my own router as they all have a different firmware.
    Jaye_Glenn likes this.
  12. efsg

    efsg Void-Bound Voyager

  13. pabgon1

    pabgon1 Void-Bound Voyager

    I'm getting an this error, Too many positional arguments given, expected at most 0 got 2. Any ideas? The server was working perfectly fine yesterday.

    Update** C:\Users\UserName\AppData\Local\Senerio\PenGUIn.exe_Url_fjdfn213qrsxg3tsr5wn4dquqspir0l1\\user.config

    ^^ Deleting that file fixes this error, for whoever has the same problem, just run the server after deleting it.

    Attached Files:

    Last edited: Jun 25, 2020
  14. winglessraven

    winglessraven Big Damn Hero

    Did anyone ever come up with a fix for the RDP/Freezing issue? Also getting it on my VMs. Same symptoms as already mentioned, got it on WS2019 and W10 Pro.
  15. winglessraven

    winglessraven Big Damn Hero

    For info, anyone having this issue try lowering the RCON timeout to around 20 - fixed it for me
  16. Danny_Dan4

    Danny_Dan4 Aquatic Astronaut

    Still getting this problem, attempted your fix, still running into the problem.
  17. Mrbludot

    Mrbludot Space Hobo

    May be a dumb question, but do I need to set up dedicated server prior to running this program or will it walk me through that also?
  18. Crystal232

    Crystal232 Big Damn Hero

    Meanwhile I have this error;
    [Info] Session started on 2019-02-11 22: 31: 39
    Error: Too many positional arguments given, expected at most 0 got 2

    BUT I run this off a back up drive and have no idea where the config file is, and there is no uninstall option to rid of it for me. Or the file at all, so how do I delete a file that I might not even have? >.>
    Last edited: Jul 13, 2021
  19. NegativeVisions

    NegativeVisions Space Hobo

    Can someone help me with this?
    [00:52:34] [Warn] RCON connection not established. Please verify your RCON Server configuration and your portforwarding.
  20. Felera

    Felera Space Hobo

    sorry, I may be a dumbass, but how do my friend do to enter the server with me?

Share This Page