1. Welcome to the Starbound support forums. Please check the support FAQs before posting: http://playstarbound.com/support

Bug/Issue UNBELIEVABLE MECH BUG - SPACEFARER UPDATE, STABLE BRANCH

Discussion in 'Starbound Support' started by Brockster17, Jun 12, 2017.

  1. Brockster17

    Brockster17 Subatomic Cosmonaut

    Since the spacefarer update, I have been having a blast with mechs, stations, new ships, a new character, and not having 300 mods. I had actually already done ALL dr.Akaggys quests and gotten myself a full mech with all part slots filled. One morning I got onto Starbound, and I saw there was a hostile and friendly ship in my system. I flew to the hostile one thinking, "Lets wreck these people". I flew next to them, and ran to my teleporter, discovering there was not a "deploy mech" button. I had used my mech many times before, but then it was just... gone. I tried this with stations, ships, the like. I went to dr.Akaggys workshop, only to find that in the assembly station, all the part slots were locked. I tried talking to dr.Akaggy, but all he said was that this was a legitimate buisness. Someone please help me! Also, sorry for the long thread. Thanks!


    P.S. The only mech-related mods I have are Look-a-Mech, More Mech bodies, and Gatling-X.

    EDIT: I almost forgot! I also have Look-a-Legs and Look-a-Limbs.

    Hello darkness, my old friend
     
    Last edited by a moderator: Jun 16, 2017
  2. enderlordalatreon

    enderlordalatreon Big Damn Hero

    Same here, odd, try making a new character and /admin yourself to the outpost and see if that fixes anything. I can't even start the quest meaning I can't even make one.
    Also could be old mods or something.
     
  3. Angry Spatula

    Angry Spatula Space Hobo

    Although I don't have any mech related mods installed, I was having the same problem. However, when I started the "scan things on the outpost" quest by talking to esther, all my worries were replaced with a bright yellow exclamation mark above Dr. Akaggy's head.
     
  4. CeeZero

    CeeZero Aquatic Astronaut

    Same problem here. I used the mech with no trouble yesterday. Today i logged on and i can't use it anymore. The mech assembly station dosn't is locked. I tried to redo all the mech related quest using the admin command and it didn't worked. Funny thing, even if i mark the first quest (mechunlock) as failed and redo it manualy i enter the testing area without a Mech. Is there a universal flag that Can be triggered using the admin command wich allowes a player to use the Mech ? I bet the flag somehow changed its state.
     
  5. Bismuth

    Bismuth Cosmic Narwhal

    Did you guys attempt to revisit the dreadwing and shockhopper missions? If possible try and do the obstacle courses again too.
     
  6. Shuaineart

    Shuaineart Space Hobo

    I think I fixed it! Was having the problem same problem after 1.3.1 with the steam version but verifying the game files seems to have fixed it! my mech is back and i can deploy. haven't check the mech table yet but im guessing its fixed as well.
    If anyone doesn't know how to verify your files its really simple both on steam and GOG if you cant find out how via google give me a shout.
    hopefully that'll hope :)
     
  7. bycomino

    bycomino Void-Bound Voyager

    dont work for me u.u
     
  8. CeeZero

    CeeZero Aquatic Astronaut

    logged in today and the problem was fixed somehow. Probably the game files that got verifyed atomaticly.
     

Share This Page