1. Note: Nightly builds are not officially supported and things that appear broken might actually just be broken with no way of fixing it, but community members may still be willing to assist you with common problems.

Bug/Issue Unplayable lag and broken UI in 1.2

Discussion in 'Nightly Builds Support' started by glassdragon, Dec 13, 2016.

  1. glassdragon

    glassdragon Scruffy Nerf-Herder

    I'm using Mac OS X 10.10.5, and I have no mods on the nightly build (I have mods on stable, but I don't know how that would affect the nightly's performance). Since the 1.2 update, the nightly build has had devastating lag (as in, about one frame per second), and if it runs for a few minutes the environment, UI, and even my cursor start disappearing. Sometimes on launch the entire start menu is black except for the buttons, and the cursor is gone. Is anyone else experiencing this?
  2. Charlatan

    Charlatan Parsec Taste Tester

    [​IMG] please.

    Without the starbound.[​IMG] or starbound_server.[​IMG] it is too hard to pinpoint what it could be.

    You find them in your Starbound/storage folder
  3. glassdragon

    glassdragon Scruffy Nerf-Herder

    I've got starbound.log and also starbound.log.1 through 5, but since starbound.log is the only one I'm capable of opening/reading I'll assume that's the one needed here.
    Opened up the game, start screen was all black with only buttons. At character load, the buttons were there, but with no text or images.

    [21:32:49.649] [Info] Root: Preparing Root...
    [21:32:49.650] [Info] Root: Done preparing Root.
    [21:32:49.650] [Info] Client Version 1.2.0 RC2 (macos x86_64) Source ID: a34e933018299fe40c920f271ebcc593d26cf5d6 Protocol: 728
    [21:32:49.650] [Info] Root: Scanning for asset sources in directory '../assets/'
    [21:32:50.713] [Info] Root: Scanning for asset sources in directory '../mods/'
    [21:32:50.713] [Info] Root: Skipping hidden '.DS_Store' in asset directory
    [21:32:50.713] [Warn] Root: Unrecognized file in asset directory 'mods_go_here', skipping
    [21:32:50.713] [Info] Root: Detected asset source named 'base' at '../assets/packed.pak'
    [21:32:50.713] [Info] Root: Detected unnamed asset source at '../assets/user'
    [21:32:50.713] [Info] Loading assets from: '../assets/packed.pak'
    [21:32:51.156] [Info] Loading assets from: '../assets/user'
    [21:32:52.968] [Info] Assets digest is 69ff0d88a3e0ff89eac70ec53c1d1b4a31ea9c31f9a2259fdb5596320d1466b8
    [21:32:52.968] [Info] Root: Loaded Assets in 3.3179 seconds
    [21:32:52.992] [Info] Application: Initializing SDL Video
    [21:32:53.164] [Info] Application: Initializing SDL Joystick
    [21:32:53.166] [Info] Application: Initializing SDL Sound
    [21:32:54.491] [Info] Initialized Steam services
    [21:32:54.492] [Info] Application: Creating SDL Window
    [21:32:54.597] [Info] Application: Enabling VSync with late swap tearing
    [21:32:54.597] [Info] Application: Enabling VSync late swap tearing failed, falling back to full VSync
    [21:32:55.113] [Info] Application: Opened default audio device with 44.1khz / 16 bit stereo audio, 2048 sample size buffer
    [21:32:55.116] [Info] OpenGL version: '2.1 ATI-10.0.35' vendor: 'ATI Technologies Inc.' renderer: 'ATI Radeon HD 2600 PRO OpenGL Engine' shader: '1.20'
    [21:32:55.119] [Info] Application: initialization...
    [21:32:55.130] [Info] Root: Loaded Configuration in 0.0107235 seconds
    [21:32:55.610] [Info] Application: renderer initialization...
    [21:32:55.622] [Info] detected maximum OpenGL texture size 8192, using atlasNumCells 256
    [21:32:55.637] [Info] detected maximum OpenGL texture size 8192, using atlasNumCells 256
    [21:32:55.637] [Info] detected maximum OpenGL texture size 8192, using atlasNumCells 256
    [21:32:55.639] [Info] Root: Loaded ImageMetadataDatabase in 5.99997e-07 seconds
    [21:32:55.722] [Info] Application: main update loop...
    [21:32:55.744] [Info] No subscribed user generated content
    [21:32:55.799] [Info] Root: Loaded NameGenerator in 0.0537176 seconds
    [21:32:56.170] [Info] Root: Loaded PlantDatabase in 0.370199 seconds
    [21:32:56.912] [Info] Root: Loaded ObjectDatabase in 1.16643 seconds
    [21:32:57.131] [Info] Root: Loaded ProjectileDatabase in 0.961295 seconds
    [21:32:57.599] [Info] Root: Loaded NpcDatabase in 0.466666 seconds
    [21:32:57.624] [Info] Root: Loaded StagehandDatabase in 0.0255192 seconds
    [21:32:57.629] [Info] Root: Loaded VehicleDatabase in 0.0052113 seconds
    [21:32:57.631] [Info] Root: Loaded MonsterDatabase in 0.718348 seconds
    [21:32:57.657] [Info] Root: Loaded PlayerFactory in 0.0276706 seconds
    [21:32:57.658] [Info] Root: Loaded VersioningDatabase in 0.0010638 seconds
    [21:32:57.658] [Info] Root: Loaded EntityFactory in 0.0277435 seconds
    [21:32:58.012] [Info] Root: Loaded ParticleDatabase in 0.352975 seconds
    [21:32:58.956] [Info] Root: Loaded MaterialDatabase in 1.2972 seconds
    [21:32:59.025] [Info] Root: Loaded TerrainDatabase in 0.0694002 seconds
    [21:32:59.408] [Info] Root: Loaded BiomeDatabase in 0.382331 seconds
    [21:32:59.409] [Info] Root: Loaded LiquidsDatabase in 0.0008149 seconds
    [21:32:59.444] [Info] Root: Loaded StatusEffectDatabase in 0.0355402 seconds
    [21:32:59.729] [Info] Root: Writing runtime configuration to '../storage/starbound.config'
    [21:33:00.845] [Info] Root: Loaded DamageDatabase in 1.4003 seconds
    [21:33:00.934] [Info] Root: Loaded EffectSourceDatabase in 0.0897658 seconds
    [21:33:01.012] [Info] Root: Loaded FunctionDatabase in 0.0778027 seconds
    [21:33:01.107] [Info] Root: Loaded TreasureDatabase in 0.0944893 seconds
    [21:33:03.522] [Info] Root: Loaded DungeonDefinitions in 2.41484 seconds
    [21:33:03.522] [Info] Root: Loaded TilesetDatabase in 1.68e-05 seconds
    [21:33:03.552] [Info] Root: Loaded StatisticsDatabase in 0.0301701 seconds
    [21:33:03.566] [Info] Root: Loaded EmoteProcessor in 0.013986 seconds
    [21:33:03.646] [Info] Root: Loaded SpeciesDatabase in 0.079187 seconds
    [21:33:03.924] [Info] Root: Loaded QuestTemplateDatabase in 0.278793 seconds
    [21:33:03.960] [Info] Root: Loaded AiDatabase in 0.0357169 seconds
    [21:33:03.986] [Info] Root: Loaded TechDatabase in 0.0251797 seconds
    [21:33:04.085] [Info] Root: Loaded CodexDatabase in 0.0996212 seconds
    [21:33:04.881] [Info] Root: Loaded BehaviorDatabase in 0.795327 seconds
    [21:33:04.956] [Info] Root: Loaded DanceDatabase in 0.0749292 seconds
    [21:33:04.997] [Info] Root: Loaded SpawnTypeDatabase in 0.0408047 seconds
    [21:33:05.030] [Info] Root: Loaded RadioMessageDatabase in 0.0337918 seconds
    [21:33:14.774] [Info] Root: Loaded ItemDatabase in 17.1167 seconds
    [21:33:15.094] [Info] Root: Loaded CollectionDatabase in 10.0635 seconds
    [21:33:17.418] [Info] detected maximum OpenGL texture size 8192, using atlasNumCells 256
    [21:33:48.701] [Info] UniverseServer: Acquiring universe lock file
    [21:33:48.758] [Info] UniverseServer: Loading settings
    [21:33:48.804] [Info] UniverseServer: Starting UniverseServer with UUID: 9c013f035099cbbd5874dc3b4e227faa
    [21:33:48.854] [Info] UniverseServer: Logged in player 'Ulululu' locally
    [21:33:48.854] [Info] UniverseServer: Logged in account '<anonymous>' as player 'Ulululu' from address local
    [21:33:48.909] [Info] UniverseServer: Player revive position has expired, spawning at ship
    [21:33:48.909] [Info] UniverseServer: Client 'Ulululu' <1> (local) connected
    [21:33:48.941] [Info] UniverseServer: Loading client ship world ClientShipWorld:80883ff5fc4670c44eee9e8f86e7072d
    [21:33:48.978] [Info] UniverseClient: Joined server as client 1
    [21:33:51.038] [Info] detected maximum OpenGL texture size 8192, using atlasNumCells 256
    [21:33:51.038] [Info] detected maximum OpenGL texture size 8192, using atlasNumCells 256
    [21:33:51.049] [Info] detected maximum OpenGL texture size 8192, using atlasNumCells 256
    [21:33:51.103] [Info] detected maximum OpenGL texture size 8192, using atlasNumCells 256
    [21:33:51.121] [Info] Setting steam rich presence connection as steam id 76561198032513699
    [21:33:53.890] [Info] UniverseServer: Warping player 1 to ClientShipWorld:80883ff5fc4670c44eee9e8f86e7072d
    [21:35:01.009] [Info] UniverseServer: Loading celestial world 935340662:458120295:4455667:2
    [21:35:05.454] [Info] UniverseServer: Warping player 1 to CelestialWorld:935340662:458120295:4455667:2=2a5c42b5640cd896679e1e7674dd9ec8
    [21:35:05.594] [Info] Client received world stop packet, leaving: Removed
    [21:35:06.098] [Info] UniverseServer: Stopping idle world ClientShipWorld:80883ff5fc4670c44eee9e8f86e7072d
    You should not attempt further exploration without proper protective equipment!
    [21:35:29.848] [Info] UniverseServer: Loading client ship world ClientShipWorld:80883ff5fc4670c44eee9e8f86e7072d
    [21:35:32.547] [Info] UniverseServer: Warping player 1 to ClientShipWorld:80883ff5fc4670c44eee9e8f86e7072d
    [21:35:32.550] [Info] Client received world stop packet, leaving: Removed
    [21:35:32.685] [Info] UniverseServer: Stopping idle world CelestialWorld:935340662:458120295:4455667:2
    [21:35:58.780] [Info] UniverseClient: Client disconnecting...
    [21:35:58.886] [Info] Client received world stop packet, leaving: Removed
    [21:35:59.275] [Info] UniverseServer: Client 'Ulululu' <1> (local) disconnected for reason:
    [21:35:59.276] [Info] UniverseServer: Stopping idle world ClientShipWorld:80883ff5fc4670c44eee9e8f86e7072d
    [21:35:59.836] [Info] UniverseServer: Stopping UniverseServer
    [21:35:59.839] [Info] Clearing steam rich presence connection
    [21:36:01.591] [Info] Application: quit requested
    [21:36:01.591] [Info] Application: quitting...
    [21:36:01.591] [Info] Application: shutdown...
    [21:36:01.768] [Info] Root: Shutting down Root
    [21:36:02.407] [Info] Application: Destroying SDL Window
    [21:36:02.414] [Info] Application: stopped gracefully

    I also have screenshots of the UI disappearing. The first is immediately after loading a character, with one of my ship lockers open. The second is after randomly picking a bookmarked planet, beaming down to it, and beaming back up.
    Screen Shot 2016-12-13 at 9.34.30 PM.png

    Screen Shot 2016-12-13 at 9.35.44 PM.png

    Hope this helps.
  4. Charlatan

    Charlatan Parsec Taste Tester

    Damnit, why do those logs always appear when I'm awake till morning hours and about to fall asleep?

    Then certain nepus sweep in to save the day while im gone :nurutease:

    Be back to ya as soon as I awake. :zzz:
  5. lazarus78

    lazarus78 The Waste of Time

    Your log shows you are running out of video memory. your gpu only has a measly 256mb of vram which the game is maxing out so it has to start swapping which is very very slow by computer standards.

    Simply put, your gpu sucks and is just barely capable.
  6. glassdragon

    glassdragon Scruffy Nerf-Herder

    The stable build of Starbound and the rest of my Steam library still seem to be running fine... Does the nightly build require a better GPU now? I can't get anything better at the moment, so if the stable release of 1.2 is going to phase out my weak computer I guess I'd like to know in advance. Thanks.
  7. Charlatan

    Charlatan Parsec Taste Tester

    Well a GPU from almost a decade ago is bound to cause trouble at some point.... but it shouldn't behave like this if it's only the VRAM lacking. Especially not *only* for unstable, though I wouldn't know if unstable is less optimized in terms of system load.

    1) Is your whole game lagging as you move around, or is it only large delays for the images to appear/disappear?

    2) What's the rest of your PC's specs ?

    3) Can you check the usage / temperature of your RAM, CPU and GPU in both Stable Starbound and Unstable?

    Windows Task Manager allows you to check RAM and CPU. Your GPU may or may not have it's own diagnostic tools from it's producer.

    Else, to check all of it at the same time, there are tools like CPUID HWMonitor
    Last edited: Dec 14, 2016
  8. lazarus78

    lazarus78 The Waste of Time

    Actually, this is typical behavior for capping ram. The system will have to start paging data to make room for more data, and paging is stupidly slow by comparison. Or in their case, I believe it is called "swap".

    That would be great if they were using Windows. Unfortunately they are using a Mac.
  9. Charlatan

    Charlatan Parsec Taste Tester

    Wops, my bad. I had no idea MAC doesnt have anything similar?
  10. lazarus78

    lazarus78 The Waste of Time

    From the new 1.2 update log:

    Performance Improvements
    • Use larger texture atlases on graphics cards that support them
    I would guess this is related since the error in the log mentions atlas textures reaching the max.
    glassdragon and Charlatan like this.
  11. glassdragon

    glassdragon Scruffy Nerf-Herder

    Sorry for the late reply, I only just saw these. By the time of this posting 1.2 has been released on Stable, so here goes nothing...
    1. The whole game is lagging, whether I'm moving or not.
    2. Mac OS X Yosemite 10.10.5, 2.4 GHz processor, 4 GB SDRAM, about 219 GB of free storage right now (out of 500), 1920 by 1200 display. It's a mid-2007 model, so I've been expecting it to fall short eventually, I'd just like to know for sure if that's what's up.
    3. Unstable build used 85% of my CPU after loading up my character and just standing on my ship. After a few moments, once almost everything disappeared from the screen except the ship teleporter's particle effect and two orange particle effects (from my furniture and/or crafting stations, I believe), it started fluctuating between around 65% and 75%. Stable build is using between 9% and 31% of my CPU, but isn't loading properly—I hear the fish chuckle, but the game window is entirely black and I can't bring up the Steam overlay.
    I'm pretty sure this means that my computer is no longer capable of running the game, which sucks, but it had to happen sometime. There's one thing that's bugging me, though. I know for a fact (because I did it yesterday) that my computer is capable of playing Elder Scrolls Online for several hours straight while the game is experiencing extreme server load due to a seasonal event. That my computer can do this and not Starbound seems weird, but then again I don't know a whole lot about behind-the-scenes computer stuff.

    Thanks for all you guys' help!
    Last edited: Dec 16, 2016
    TheBattleDude likes this.
  12. lazarus78

    lazarus78 The Waste of Time

    Comparing performance between different games is moot. Different engines, different design, different requirements.

    I am just wondering if some of the performance improvements they made might have had a negative effect, or if they were enough to alter the effective system requirements just enough to make it no longer work well under some older hardware.

    You aren't the first Ive seen with new lag issues with 1.2, but people are stingy with giving any actual information to know if there is a commonality between them.
    glassdragon likes this.
  13. TheBattleDude

    TheBattleDude Void-Bound Voyager

    Ugh agreed I run 10.11.6 with a i7 imac and starbound is almost unplayable. All lower macs the game is now totally broken. I could understand this with a advanced 3D MMO game....but starbound?. I do not think starbound supports Mac any longer.
  14. TheBattleDude

    TheBattleDude Void-Bound Voyager

    I do not think starbound supports mac any longer. My imac 3.1 GHz Intel Core i7, 16 GB 1600 MHz DDR3, NVIDIA GeForce GT 750M 1024 MB and the lag makes it unplayable... super lag, black screens, missing characters and much more. 1.2 is a nightmare for mac. Totally agreed how can a advanced 3D MMO work and not starbound...because starbound no longer supports mac. Oh, and I'm NOT running any mods.
  15. lazarus78

    lazarus78 The Waste of Time

    Wow. Dramatic much? It is probably just a glitch they didn't catch. Let's give them a chance to react.

    In_Ter_Face, Charlatan and Uhthing like this.
  16. Uhthing

    Uhthing Space Hobo

    Yeah definitely just need to give it a few days I'm sure they'll have it figured out. I was so confused why SB was so laggy overnight... them updates get ye every time!
  17. Uhthing

    Uhthing Space Hobo

    Playing unstable offline works Great!
  18. Healthire

    Healthire Can't Most Program the Least


    We definitely still support OSX, there have just been a few issues with the latest update. If you want to help find a solution, please try running the latest Starbound Unstable. If that doesn't resolve your problems, please report back here.

    Thank you
    lazarus78 likes this.
  19. glassdragon

    glassdragon Scruffy Nerf-Herder

    Last night I ran both the latest Unstable (as of then) and the latest Stable build. Unstable lasted a little bit longer before breaking completely, and I was actually able to see my character and play around for the first stage of things disappearing. I probably shouldn't have tried to run Stable after that, though, because my computer screen started glitching out and eventually the whole thing crashed.
  20. lazarus78

    lazarus78 The Waste of Time

    Your whole computer? I wonder if your GPU is crapping out.

Share This Page