1. Welcome to the Wargroove support forums. Please check the support FAQs before posting: http://wargroove.com/support

Wargroove patch 1.2.0 - Known Issues and Fixes!

Discussion in 'Support' started by Shubeans, Mar 6, 2019.

  1. Shubeans

    Shubeans QA Wizard Chucklefish

    Bit of an update:
    The desync, we don't know what is causing it and we are working to figure it out. Sometimes it occurs, sometimes it doesn't. Some people it get constantly during playing but some people are only getting it the once and then never again.
    We thought we had it narrowed down to only PC and Switch crossplay, but it turns out some people are getting PC to PC. It's an exciting time.
    We did push a server change, which fixed it for a few people, but not others.

    So please, if you get the desync; as in you are playing a match with people and it tells you that it's a different players turn but for them it is someone else's, and ultimatally means the game 'freezes' please respond to me with:DESYNC ISSUES!
    1. What platform you are on
    2. What platform other users are on
    3. How many Human vs AI players
    4. What map type; 2/3/4player or Scenario?
    5. Who's turn was it before the desync occured; what platform were they playing on.
    6. What turn number was it?
    7. What's the internet connection like for the person who Desynced?
    8. What are your current options setup;
    - Battle animations on/off:
    - Fast movement on/off:
    - Confirm end turn on/off:

    For any other multiplayer issues please give as much detail as you can when reporting them!
    • Porroe

      Porroe Void-Bound Voyager

      There is a crash I encountered several times on Switch that has not been reported on the Google Doc.

      • Start a multiplayer game with turn timer
      • Open the barracks menu and let timer go to 0
      • Press A button to buy any unit once the timer has run out
      • Game crashes and timer has restarted when coming back to the game
      This happens a lot when people move all their units and try to purchase new units at the end of their turn and the timer runs out.
      • Petit

        Petit Space Hobo

        Hello Chucklefish !

        In the map editor, while in the cinematic editor, there is a bug with the "Shout" action, when, after the character and sound has been normally selected in the shout window, the shout box in the timeline appear in red, and the sound is not played while the cinematic runs.
        It is reproductible, and concern some specific sounds :

        Carmina : all Ok
        Undead : skeletons "chaterring" not working
        Florian : All sounds for non commander units not working, expect for dogs.
        Empire : All sounds for non commander units not working, expect for dogs and horses sounds.

        Here is a picture of what it looks like :

        I play on PC, Steam.

        Hope this will get fixed :)
        • Ulysse

          Ulysse Yeah, You!


          I found a minor bug. I found a simple workaround, so I am mainly reporting it to share the solution.

          In a scenario map, making an event which transforms a cristal unit will keep the display of the cristal area of effect around the new unit or structure. It is purely esthetic, the new unit does not provide amor.
          As a workaround, you can simply put a 1 millisecond wait at the beginning of the event. Race condition I guess.

          I made a repro sample: 7DBZGRZG

          • Donutninja

            Donutninja Space Hobo


            My son purchased this game for me as a present and so far it’s been fun to play, I just finished the heavensong level last night.

            Today when I went to move to the next level on the world map I was unable to control the character. I was able to get into the same level and move the army on the first turn but I’m the second turn I couldn’t move anything again. Tested this in the arcade maps with the same result. This is on the switch and is game breaking, please help. I am going to try uninstalling and reinstalling the game to see if that helps.
            • Shubeans

              Shubeans QA Wizard Chucklefish

              We've just pushed an update for the Switch, could you please update the game and let me know if the issue is still occurring?
              I've not heard of this one happening before, and I may need to send you a nice mass of questions :)
                Donutninja likes this.
              • Donutninja

                Donutninja Space Hobo

                Thanks for the reply, a fresh install fixed the issue.
                • Mazodudu

                  Mazodudu Aquatic Astronaut

                  Noticed a small new bug since the latest patch: in multiplayer on Switch, turns do not end automatically anymore, despite the option being turned on.
                  • Ulysse

                    Ulysse Yeah, You!


                    Here is another bug, and a more problematic one.

                    Found on Switch, version 1.2.4.
                    In a scenario map, when a vine or crystal expire at the beginning of a turn, it will prevent any event with the "beginning of turn" condition from firing.

                    I made a repro map: 2JAPWAPA
                    (Are those useful or should I stop making them?)

                    This bug is quite problematic for me because it can easily mess up any scenario map with beginning-of-turn event and Emeric or the Greenfinger.
                    The only workaround I have found is to make your events at the end of the previous turn instead. But that can't replace every case.

                    • Shubeans

                      Shubeans QA Wizard Chucklefish

                      These are incredibly helpful :)
                      Thank you for reporting, I know we have a weird issue with Crystals not triggering other events if it spawns first. There's probably other weird things we don't know about!
                      • ttv_will1v1

                        ttv_will1v1 Tentacle Wrangler

                        I saw on the spreadsheet people were submitting "Map Design" reports, and I have some quickplay suggestions:

                        1. Most players agree that Default: Random Weather is always better for Player1 and gives a very large advantage to Player1 on basically all the current 21 quickplay maps.
                        So I suggest weather for quickplay to be changed to: Always Sunny.

                        2. There are a lot of flawed maps in the pool currently. I saw Tiyuri comment on reddit that the team was considering putting in featured PVP maps into the quickplay pool. Is this still planned? If so, the mapmaking community has a well vetted map pool of 7 that we would love to see used in the pool. You can click here to see it.

                        3. If you'd like to take out the flawed maps, the most flawed ones are: Rambling Range (100% win wagon strat for Player1), Kachi Bochi Bay (Extra income for Player2, large advantage over time), Pin Pon Pools (First Turtle Advantage for Player1), Rimy Ruins (FTA).
                          Last edited: Apr 5, 2019
                          Fadedsun likes this.
                        • Ulysse

                          Ulysse Yeah, You!


                          I have a new bug for scenario maps. And for this one I don't have a repro at the moment because I can't make head or tail of it.

                          Basically, the "Unit: Modify groove" action is wildly off when used in succession.
                          For example, I have an event spawning a Sedge, then setting his groove to 50 %. That works fine, I get my 50 % Sedge. Now, if in that event or another event happening close after I make a modify groove event which adds 0% (yes, nothing) to this Sedge, he suddenly jumps to 100 % groove.
                          If I do that at a later time, say in an event at the end of the turn, I get the result I expect.

                          Note 1: I saw strange groove modifications also when changing the groove of several different commanders in a row (not twice the same). Maybe a variable is not properly cleaned up?
                          Note 2: The shenanigans depend on the commander. If I do what I explained above to a Sigrid instead of a Sedge, she gets 75%. Still wrong, but a different kind of wrong.
                          Note 3: substracting groove energy displays the same kind of issue. However, setting the grove to a specific value seems safe.

                          I have some scenario maps relying quite a lot on groove manipulation, and this is making them a bit unreliable. If someone understands the bug and have a workaround while waiting for a fix, I would happily hear about it.

                          • Ulysse

                            Ulysse Yeah, You!

                            I have investigated the bug above and I think I found out the root of the issue, given the following:
                            • The issue actually depends on the groove the commander currently have, not on the sequence of event.
                            • The issue does not affect Mercia, Emeric and Nuru who have the same groove speed: 10% per turn.
                            I created a repro with Tenri (7% per turn): DJBJMJYK
                            I have several Tenri which I set to different groove values, then I either add or substract 0% of groove to them. The result is that all of them have their groove increased by half of their current groove.

                            My guess is the following:
                            • Groove is not calculated as a percentage but as an integer. Merci has a maximum of 100, Tenri of 150. It is then displayed as a percentage. They both win 10 per turn, but for Mercia it is 10% of her max, and for Tenri 6.5%, hence what we see.
                            • When an event modifies the groove of a unit, it first take the percentage and bring it back to the integer. In Tenri's case, that means multiplying by 1.5. But at the end, it forgets to divide by 1.5, hence the increase by half I am seeing.
                            Something along those lines.
                            Basically, the issue is probably in the arithmetic.

                            I have some maps of my campaign severely crippled by this. And if the issue is in the arithmetic, I can't work around them.
                            It would be really nice if you could fix that bug.

                            (Note: I am on Switch, with version 1.2.5. I think that bug was not there in the original release.)

                            • Shubeans

                              Shubeans QA Wizard Chucklefish

                              Thanks for doing such an in-depth look into this!!

                              It does occur across all platforms, and it should be fixed for the next patch release :)
                              • jimmydeansausage

                                jimmydeansausage Space Hobo

                                PS4 user here: Side Mission 2-1 is not allowing an S-Rank. Beat it in 16 turns and only got an A. I thought maybe I had missed something, so I beat it again, this time in 15 turns. Still only got an A. I was getting S-Ranks on other missions before the latest patch, so it doesn't seem to be all missions. I'm going to test out other campaign missions when I get home to see if it's game-wide, or just this mission that's bugged.
                                • Sonderfall

                                  Sonderfall Yeah, You!

                                  Xbox / Win10: Getting server errors (+ being kicked back to main menu) when trying to do the following:
                                  -Uploading a user created map
                                  -Browsing user generated content
                                  -Browsing online lobbies

                                  Share This Page